Bug 140858 - FC3 fails to install - throws exceptions and dies
FC3 fails to install - throws exceptions and dies
Status: CLOSED DUPLICATE of bug 138419
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2004-11-25 12:57 EST by Satish Sharma
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:07:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Satish Sharma 2004-11-25 12:57:15 EST
Description of problem:

Tried installing FC3 on a machine (Pentium 4, Northbrige chipset
mother board, Seagatte 120 G HD)
Bios does support LBA 

I had earlies FC1 AND FC2 installed on this machine without any problem.
I did verify the data on CD ROM ..and it's good.

Installaiton starts failing after language selection. It puts out a
dialog titled BUG with a message of probe_partion_for_geom() function
failing. If you select ignore it proceeds and finally core dumps as it
tries to write the partiontable.
if you select cancel, the installation is terminated. 

Version-Release number of selected component (if applicable): FC3

How reproducible: YES

Steps to Reproduce:
1. Start from CDROM (iso image)
Actual results:

Expected results:

Additional info:
The following dump was generated by ananconda 
Traceback (most recent call last):
  File "/usr/src/build/475969-i386/install//usr/lib/anaconda/gui.py",
line 1074, in handleRenderCallback
line 242, in renderCallback
  File "/usr/src/build/475969-i386/install//usr/lib/anaconda/gui.py",
line 789, in nextClicked
line 171, in gotoNext
line 239, in moveStep
    rc = apply(func, self.bindArgs(args))
line 551, in turnOnFilesystems
    diskset.savePartitions ()
line 715, in savePartitions
error: Bug: Assertion (heads > 0) at disk_dos.c:485 in function
probe_partition_for_geom() failed.

Local variables in innermost frame:
self: <partedUtils.DiskSet instance at 0xb751354c>
disk: <PedDisk object at 0xb7ca0ba8>
Comment 1 Jeremy Katz 2004-11-25 16:04:09 EST

*** This bug has been marked as a duplicate of 138419 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:07:16 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.