Bug 1408694 - [ESXi][open-vm-tools][RHEL7.4]During minimal RHEL 7.3 installation, open-vm-tools-desktop force installed by anaconda/yumgroup-distro.xml
Summary: [ESXi][open-vm-tools][RHEL7.4]During minimal RHEL 7.3 installation, open-vm-t...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: releng
Version: 7.3
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Lubos Kocman
QA Contact: ldu
Petr Bokoc
URL:
Whiteboard:
Depends On:
Blocks: 1298243 1395321
TreeView+ depends on / blocked
 
Reported: 2016-12-26 12:41 UTC by Abhijeet Sadawarte
Modified: 2017-08-02 13:00 UTC (History)
18 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Minimal installation no longer installs open-vm-tools-desktop and dependencies The _open-vm-tools-desktop_ package was previously marked as default in the _@platform-vmware_ package group (Virtualization utilities and drivers for VMWare). This group is automatically installed by *Anaconda* when it detects that the installation is using a *VMWare* hypervisor. At the same time, this package has many dependencies including a large number of X libraries which are not useful in a minimal installation, and this was causing *Anaconda* to install a high number of unnecessary packages. The _open-vm-tools-desktop_ package is now optional in the _@platform-vmware_ group, and therefore not being installed by default. The other package in the group, _open-vm-tools_, remains mandatory and is therefore installed by default.
Clone Of:
Environment:
Last Closed: 2017-08-01 17:32:24 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1850 normal SHIPPED_LIVE redhat-release update 2017-08-01 18:03:01 UTC

Description Abhijeet Sadawarte 2016-12-26 12:41:00 UTC
Description of problem:

* During a minimal RHEL 7.3 installation, open-vm-tools-desktop is getting installed along with plenty of X library packages as its dependencies 

* X11 is included on a minimal install on VMware.  I expect a minimal install to be without unneeded packages.

Version-Release number of selected component (if applicable):

- Red Hat Enterprise Linux Server release 7.3 (Maipo)


How reproducible:

- take a sample given kickstart file to install minimal RHEL 7.3

~~~
# cat /var/www/html/test.cfg
lang en_US
url --url http://<http_source>/rh7.3/
keyboard us
timezone America/New_York --isUtc
rootpw redhat
bootloader --location=mbr
zerombr
clearpart --all --initlabel
autopart 
auth --passalgo=sha512 --useshadow
selinux --enforcing
firewall --disabled
firstboot --disable
text
skipx    
%packages --nobase
@Core
%end
~~~

And the 'open-vm-tools-desktop' package got installed on the system.

~~~
# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 7.3 (Maipo)

# rpm -qa |grep open-vm-tools
open-vm-tools-10.0.5-2.el7.x86_64
open-vm-tools-desktop-10.0.5-2.el7.x86_64
~~~ 


Actual results:

- for minimal install, open-vm-tools-desktop should not get installed since its causes installing other X library files as its dependencies 

Expected results:

- only open-vm-tools package should install and not 'open-vm-tools-desktop'

Additional info:

- However on RHEL 7.2, I didn't see 'open-vm-tools' package installed on the system with the same kickstart.

Comment 1 Richard W.M. Jones 2016-12-26 21:33:23 UTC
I'm certain that open-vm-tools only is supposed to be
installed, not the -desktop subpackage.

I think this should probably be reassigned to comps, however
I'm not sure what component that would be.

Cathy, could you have a look at this?  I'm on holiday for
the next 3 weeks.

Comment 2 Yaju Cao 2016-12-27 06:35:12 UTC
Change component to releng, this issue is caused by Bug https://bugzilla.redhat.com/show_bug.cgi?id=1128287

Comment 4 Ravindra Kumar 2016-12-30 22:12:55 UTC
There are two use cases:
1. OS being installed without X (headless)
   NOTE: open-vm-tools must be installed in this case
2. OS being installed with X (with desktop environment)
   NOTE: open-vm-tools-desktop must be installed in this case

I believe minimal install falls under #1 above.

Comment 5 Lubos Kocman 2017-01-04 13:51:36 UTC
This package gets installed as part of @guest-agents, @guest-desktop and @platform-vmware yum groups. This group is not being installed by default in our configs

-bash-4.1$ egrep "guest.*agents|platform-vmware" variants-rhel-7.4.xml
      <group default="false">guest-agents</group>
      <group default="false">platform-vmware</group>
      <group default="false">guest-desktop-agents</group>
      <group default="false">platform-vmware</group>
      <group default="false">guest-agents</group>
      <group default="false">guest-desktop-agents</group>
      <group default="false">platform-vmware</group>
      <group default="false">guest-agents</group>
      <group default="false">guest-desktop-agents</group>
      <group default="false">platform-vmware</group>
      <group default="false">guest-agents</group>
      <group default="false">guest-desktop-agents</group>
      <group default="false">platform-vmware</group>


rel-eng does not own these profile definitions in rhel-7 (we still own them in <= RHEL-6).

Moving to anaconda

Comment 6 Vendula Poncova 2017-02-10 10:56:52 UTC
Anaconda installs all mandatory and default packages from the group '@platform-<name>', where <name> is a detected name of a virtualization platform, in this case wmware. It is a result of the requests https://bugzilla.redhat.com/show_bug.cgi?id=884385 and https://bugzilla.redhat.com/show_bug.cgi?id=1128287 .

We can enable the option to remove the specific packages with '-<package>' in the %package section, in this case '-open-vm-tools-desktop', but we suggest to make the open-vm-tools-desktop package optional in the @platform-vmware group. In that case, anaconda will not install the open-vm-tools-desktop package by default.

Comment 8 Richard W.M. Jones 2017-02-10 11:27:19 UTC
(In reply to Vendula Poncova from comment #6)
> We can enable the option to remove the specific packages with '-<package>'
> in the %package section, in this case '-open-vm-tools-desktop', but we
> suggest to make the open-vm-tools-desktop package optional in the
> @platform-vmware group. In that case, anaconda will not install the
> open-vm-tools-desktop package by default.

This seem sensible.  Just make sure that open-vm-tools itself
remains mandatory.

Comment 10 Lubos Kocman 2017-03-06 16:47:11 UTC
commit f052afedece48a5a2d19626f24924bee37efed3a
Author: Lubos Kocman <lkocman@redhat.com>
Date:   Mon Mar 6 11:46:36 2017 -0500

    rhel-7.4: make  open-vm-tools-desktop optional in @platform-vmware. rhbz#1128287

diff --git a/comps-rhel-7.4.xml b/comps-rhel-7.4.xml
index 7a20da2..9c68bae 100644
--- a/comps-rhel-7.4.xml
+++ b/comps-rhel-7.4.xml
@@ -5245,7 +5245,7 @@
     <uservisible>false</uservisible>
     <packagelist>
       <packagereq type="default">open-vm-tools</packagereq>
-      <packagereq type="default">open-vm-tools-desktop</packagereq>
+      <packagereq type="optional">open-vm-tools-desktop</packagereq>
     </packagelist>
   </group>
   <group>
diff --git a/comps-rhel-7.4.xml.in b/comps-rhel-7.4.xml.in
index b0035a6..3863ad1 100644
--- a/comps-rhel-7.4.xml.in
+++ b/comps-rhel-7.4.xml.in
@@ -1820,7 +1820,7 @@
     <uservisible>false</uservisible>
     <packagelist>
       <packagereq type="default">open-vm-tools</packagereq>
-      <packagereq type="default">open-vm-tools-desktop</packagereq>
+      <packagereq type="optional">open-vm-tools-desktop</packagereq>
     </packagelist>
   </group>
   <group>

Comment 12 ldu 2017-04-27 03:02:30 UTC
verify this bug with RHEL7.4 guest on VMware ESXi6.0

Verify version:
kernel-3.10.0-632.el7.x86_64
open-vm-tools-10.1.5-3.el7.x86_64
open-vm-tools-desktop-10.1.5-3.el7.x86_64

Verify steps:
1. Minimal install RHEL7.4 gust on the VMware ESXi6.0 host.
2. Reboot the guest after installation finished.
3. Check the open-vm-tools with command:
$rpm -qa open-vm-tools
$rpm -qa open-vm-tools-desktop
The test result: Verified
The open-vm-tools-desktop not installed, only open-vm-tools installed with minimal installation.

Comment 14 errata-xmlrpc 2017-08-01 17:32:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1850


Note You need to log in before you can comment on or make changes to this bug.