Bug 14087 - Alpha distribution missing key RPMS!!!
Alpha distribution missing key RPMS!!!
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
alpha Linux
high Severity high
: ---
: ---
Assigned To: Matt Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-16 17:46 EDT by mchampig
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-18 11:08:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mchampig 2000-07-16 17:46:29 EDT
The Alpha CDROM is missing the tetex-fonts-1.0.7-5.alpha.rpm and more importantly the
time-1.7-11.alpha.rpm. During the install, the GUI hangs and in the console I get a python
traceback stating that the RPMs were missing. Sure enough, they are not on the CD.
The tetex problem can be worked around by reinstalling and unselecting the TeX related
packages from the individual package selection screen. But the time package can NOT
be deselected (in fact, you get it by default as it's a critical base package). So needless
to say, you can't do an Alpha install with the CD as shipped. :-(

Guess I'll have to wait for the beta-5 CD to get the updates. Are these missing RPMs in
rawhide?
Comment 1 mchampig 2000-07-17 09:06:54 EDT
Update: The problem is much worse than I expected. There are *lots* of missing
packages, many
of them critical, at least if you want X. tk is missing, an xinitrc for example.
Do a diff of packages
from the CD's you shipped with what you have on ftp.beta.redhat.com and you'll
see.

I am filling in the gaps by downloading the missing packages, but *please* put
these on the next
CD.
Comment 2 Matt Wilson 2000-07-17 15:41:10 EDT
It's on CD 2.
Comment 3 mchampig 2000-07-17 21:43:07 EDT
OK, it's not a bug...I figured out (after downloading the missing packages) that the rest were on CD2.

In that case, the bug is that the installer hangs and dumps a python traceback instead of prompting for
CD2. Also, I did the install off an NFS mounted CD-ROM from another machine on the network. How
would that work during a multi-CD install? 
Comment 4 Matt Wilson 2000-07-17 22:53:24 EDT
Copy all RedHat/RPMS/* to the RedHat/RPMS directory on the NFS server.

What is the traceback?
Comment 5 mchampig 2000-07-18 09:43:04 EDT
That's how I got it to install. I copied all the RPMs (on both CDs) into an NFS
mounted directory
and the install proceeded without a hitch. What I'm saying though, is that
multi-CD installs do
not seem to be working. Python dumps a traceback to the console saying that it
can't find 
such-and-such an RPM. What it *should* do upon not finding the RPM is prompt for
another
CD. Since CD-ROM installs are broken on Alpha's anyway I guess it's a moot
point. I'm sticking
to NFS installs off a hard disk for now.
Comment 6 Matt Wilson 2000-07-18 11:08:24 EDT
you realize that it is impossible to do multicd installs when you nfs mount the
cdrom drive?  The nfs server makes the drive always busy, so it's impossible to
unmount and eject the CD to replace it with the next.

Note You need to log in before you can comment on or make changes to this bug.