Bug 1408961 - [GSS](6.4.z) Error while applying CP12 patch in windows environment through CLI command.
Summary: [GSS](6.4.z) Error while applying CP12 patch in windows environment through C...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Patching
Version: 6.4.12
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: CR1
: EAP 6.4.15
Assignee: Radovan Netuka
QA Contact: Jiří Bílek
URL:
Whiteboard:
Depends On:
Blocks: eap6417-payload 1458672
TreeView+ depends on / blocked
 
Reported: 2016-12-28 13:58 UTC by Abhijit humbe
Modified: 2020-07-16 09:05 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-07-02 15:47:26 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker JBEAP-8807 0 Critical Verified [GSS](7.0.z) Error applying patch through CLI 2019-07-10 20:09:01 UTC
Red Hat Issue Tracker JBEAP-8808 0 Major Verified Error applying patch through CLI 2019-07-10 20:09:01 UTC
Red Hat Issue Tracker WFCORE-411 0 Major Closed Syntax error when applying patch and exiting jboss-cli 2019-07-10 20:09:02 UTC
Red Hat Knowledge Base (Solution) 3022911 0 None None None 2017-05-04 02:42:39 UTC
Red Hat Knowledge Base (Solution) 3143091 0 None None None 2017-08-08 04:52:41 UTC

Description Abhijit humbe 2016-12-28 13:58:21 UTC
Description of problem:
Below exception occurs while applying CP12 patch in windows environment.
~~~
D:\install\jboss-eap-6.4>bin\jboss-cli.bat "patch apply D:\install\jboss-
eap-6.4.12-patch.zip"
{
    "outcome" : "success",
    "result" : {}
}
'org.jboss.as.cli' is not recognized as an internal or external command,
operable program or batch file.
~~~

Version-Release number of selected component (if applicable):
JBoss EAP 6.4 CP12

How reproducible:
In Windows environment.

Steps to Reproduce:
1.Download JBoss EAP 6.4.0 and apply JBoss EAP 6.4 CP09 patch first.
2.Now try to apply JBoss EAP 6.4 CP12 patch it will throw exception:
~~~
'org.jboss.as.cli' is not recognized as an internal or external command,
operable program or batch file.
~~~

Actual results:


Expected results:


Additional info:
Patch is applied successfully but it throws exception. This issue occurs only when we try to apply patch through CLI command. It works fine if we apply patch through management console.

Comment 8 kconner 2017-04-07 13:45:33 UTC
*** Bug 1440062 has been marked as a duplicate of this bug. ***

Comment 11 Jiří Bílek 2017-04-20 15:21:47 UTC
Applying patch CP12 gets expected error message, but applying CP15 in CP11 gets error message "patching exception" and applying CP15 in CP14 gets another different error message. Output is below.

Applying CP15 should not get any error message in CP11 nor CP14 -> Reopened



C:\Users\Administrator\Desktop\jboss-eap-6.4.0\jboss-eap-6.4>bin\jboss-cli.bat "--command=patch info"
{
    "outcome" : "success",
    "result" : {
        "cumulative-patch-id" : "jboss-eap-6.4.9.CP",
        "patches" : []
    }
}

C:\Users\Administrator\Desktop\jboss-eap-6.4.0\jboss-eap-6.4>bin\jboss-cli.bat "--command=patch apply ..\..\jboss-eap-6.4.12-patch.zip"
{
    "outcome" : "success",
    "result" : {}
}
'org.jboss.as.cli' is not recognized as an internal or external command,
operable program or batch file.

C:\Users\Administrator\Desktop\jboss-eap-6.4.0\jboss-eap-6.4>bin\jboss-cli.bat "--command=patch rollback --reset-configuration=false"
{
    "outcome" : "success",
    "result" : {}
}

C:\Users\Administrator\Desktop\jboss-eap-6.4.0\jboss-eap-6.4>bin\jboss-cli.bat "--command=patch info"
{
    "outcome" : "success",
    "result" : {
        "cumulative-patch-id" : "jboss-eap-6.4.11.CP",
        "patches" : []
    }
}

C:\Users\Administrator\Desktop\jboss-eap-6.4.0\jboss-eap-6.4>bin\jboss-cli.bat "--command=patch apply ..\..\jboss-eap-6.4.15.CP.CR2-patch.zip"
{
    "outcome" : "success",
    "result" : {}
}
patching exception

C:\Users\Administrator\Desktop\jboss-eap-6.4.0\jboss-eap-6.4>bin\jboss-cli.bat "--command=patch rollback --reset-configuration=false"
{
    "outcome" : "success",
    "result" : {}
}

C:\Users\Administrator\Desktop\jboss-eap-6.4.0\jboss-eap-6.4>bin\jboss-cli.bat "--command=patch info"
{
    "outcome" : "success",
    "result" : {
        "cumulative-patch-id" : "jboss-eap-6.4.14.CP",
        "patches" : []
    }
}

C:\Users\Administrator\Desktop\jboss-eap-6.4.0\jboss-eap-6.4>bin\jboss-cli.bat "--command=patch apply ..\..\jboss-eap-6.4.15.CP.CR2-patch.zip"
{
    "outcome" : "success",
    "result" : {}
}
'cter' is not recognized as an internal or external command,
operable program or batch file.
patching exception


Note You need to log in before you can comment on or make changes to this bug.