Bug 1408968 - Unsupported type error for container image ose-deployer OpenShift metrics
Summary: Unsupported type error for container image ose-deployer OpenShift metrics
Keywords:
Status: CLOSED DUPLICATE of bug 1420721
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: C&U Capacity and Utilization
Version: 5.6.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.7.2
Assignee: Ari Zellner
QA Contact: Einat Pacifici
URL:
Whiteboard: container
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-12-28 15:24 UTC by myoder
Modified: 2020-05-14 15:30 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-27 20:02:19 UTC
Category: Bug
Cloudforms Team: Container Management
Target Upstream Version:


Attachments (Terms of Use)

Description myoder 2016-12-28 15:24:37 UTC
Description of problem: Been having issues collecting metrics from OpenShift.  
At the moment, CloudForms is able to get metrics for 9 out of 11 nodes.  Receiving many unsupported type errors in the logs for the container with image ose-deployer:

[----] E, [2016-12-28T03:46:54.283075 #3252:3d3998] ERROR -- : [RuntimeError]: Unsupported type ManageIQ::Providers::Kubernetes::ContainerManager::Container (id: 123000000003067)  Method:[rescue in deliver]
[----] E, [2016-12-28T03:46:54.283251 #3252:3d3998] ERROR -- : /var/www/miq/vmdb/app/models/metric/ci_mixin/capture.rb:14:in `queue_name_for_metrics_collection'
/var/www/miq/vmdb/app/models/metric/ci_mixin/capture.rb:59:in `perf_capture_queue'
/var/www/miq/vmdb/app/models/metric/capture.rb:196:in `block in queue_captures'
/var/www/miq/vmdb/app/models/metric/capture.rb:190:in `each'
/var/www/miq/vmdb/app/models/metric/capture.rb:190:in `queue_captures'
/var/www/miq/vmdb/app/models/metric/capture.rb:50:in `perf_capture_timer'
/var/www/miq/vmdb/app/models/miq_queue.rb:345:in `block in deliver'
/opt/rh/rh-ruby22/root/usr/share/ruby/timeout.rb:89:in `block in timeout'
/opt/rh/rh-ruby22/root/usr/share/ruby/timeout.rb:34:in `block in catch'
/opt/rh/rh-ruby22/root/usr/share/ruby/timeout.rb:34:in `catch'
/opt/rh/rh-ruby22/root/usr/share/ruby/timeout.rb:34:in `catch'
/opt/rh/rh-ruby22/root/usr/share/ruby/timeout.rb:104:in `timeout'
/var/www/miq/vmdb/app/models/miq_queue.rb:341:in `deliver'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:106:in `deliver_queue_message'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:134:in `deliver_message'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:152:in `block in do_work'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:146:in `loop'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:146:in `do_work'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:334:in `block in do_work_loop'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:331:in `loop'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:331:in `do_work_loop'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:153:in `run'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:128:in `start'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:21:in `start_worker'
/var/www/miq/vmdb/app/models/miq_worker.rb:347:in `block in start'
/opt/rh/cfme-gemset/gems/nakayoshi_fork-0.0.3/lib/nakayoshi_fork.rb:24:in `fork'
/opt/rh/cfme-gemset/gems/nakayoshi_fork-0.0.3/lib/nakayoshi_fork.rb:24:in `fork'
/var/www/miq/vmdb/app/models/miq_worker.rb:345:in `start'
/var/www/miq/vmdb/app/models/miq_worker.rb:274:in `start_worker'
/var/www/miq/vmdb/app/models/miq_worker.rb:154:in `block in sync_workers'
/var/www/miq/vmdb/app/models/miq_worker.rb:154:in `times'
/var/www/miq/vmdb/app/models/miq_worker.rb:154:in `sync_workers'
/var/www/miq/vmdb/app/models/miq_server/worker_management/monitor.rb:52:in `block in sync_workers'
/var/www/miq/vmdb/app/models/miq_server/worker_management/monitor.rb:50:in `each'
/var/www/miq/vmdb/app/models/miq_server/worker_management/monitor.rb:50:in `sync_workers'
/var/www/miq/vmdb/app/models/miq_server.rb:173:in `start'
/var/www/miq/vmdb/app/models/miq_server.rb:265:in `start'
/var/www/miq/vmdb/lib/workers/evm_server.rb:65:in `start'
/var/www/miq/vmdb/lib/workers/evm_server.rb:92:in `start'
/var/www/miq/vmdb/lib/workers/bin/evm_server.rb:4:in `<main>'

The image giving the error is openshift3/ose-deployer:v3.2.1.13

Version-Release number of selected component (if applicable):
CFME 5.6.1.2


How reproducible: Always


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Federico Simoncelli 2017-01-13 09:54:07 UTC
Ari can you check this?

Comment 12 Ari Zellner 2017-01-31 11:10:25 UTC
This PR solves the error mentioned in the log https://github.com/ManageIQ/manageiq/pull/13686
Im still unsure whether this is the reason for not getting ANY metrics from the nodes since this error is about containers

Comment 15 Federico Simoncelli 2017-03-20 08:49:59 UTC
The error mentioned in the title and in the description has been fixed in bug 1420721 (and delivered with an hotfix).
If you don't see these errors anymore (of course you have to be sure to be using the hotfix) then we can close this BZ.

Comment 18 Federico Simoncelli 2017-03-27 20:02:19 UTC

*** This bug has been marked as a duplicate of bug 1420721 ***


Note You need to log in before you can comment on or make changes to this bug.