Bug 140924 - Pasting content from remote X terminals cause "Bad Atom" error
Pasting content from remote X terminals cause "Bad Atom" error
Status: CLOSED DUPLICATE of bug 138617
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-26 09:35 EST by Steffen Persvold
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steffen Persvold 2004-11-26 09:35:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
When opening remote xterminals via ssh and trying to paste something
from that window to a local terminal (your local emacs window for
example), the remote xterminal dies with the following error :

xterm:  warning, error event received:
X Error of failed request:  BadAtom (invalid Atom parameter)
  Major opcode of failed request:  18 (X_ChangeProperty)
  Atom id in failed request:  0x1d1
  Serial number of failed request:  190
  Current serial number in output stream:  192


Version-Release number of selected component (if applicable):
xorg-x11-6.8.1-12.FC3.1

How reproducible:
Always

Steps to Reproduce:
1. log into your local machine with 'ssh localhost'
2. start an xterm from that session 'xterm'
3. select something with the mouse, and try to paste that into a local
window (one that isn't started through ssh).
    

Actual Results:  The "remote" xterm session will die with the
following message :

xterm:  warning, error event received:
X Error of failed request:  BadAtom (invalid Atom parameter)
  Major opcode of failed request:  18 (X_ChangeProperty)
  Atom id in failed request:  0x1d1
  Serial number of failed request:  190
  Current serial number in output stream:  192


Expected Results:  Selected content should have been pasted correctly
into local window

Additional info:
Comment 1 Sitsofe Wheeler 2004-11-26 18:41:45 EST
Sounds like a potential dup of bug 140924 (hint does adding -Y to ssh
help?)
Comment 2 Sitsofe Wheeler 2004-11-26 18:42:22 EST
Sorry that should have been bug 138617
Comment 3 Steffen Persvold 2004-11-27 10:40:25 EST

*** This bug has been marked as a duplicate of 138617 ***
Comment 4 Preston Landers 2005-05-07 13:14:00 EDT
I was seeing this exact problem on Mac OS X version 10.4 (Tiger) but not on
10.3.9 (Panther). Adding the -Y parameter to ssh does seem to fix the problem
for me - although I got this warning:

Warning: No xauth data; using fake authentication data for X11 forwarding.
Comment 5 Red Hat Bugzilla 2006-02-21 14:07:17 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.