Bug 1409268 - gnome-software updates failing in pk-offline-update, cannot download repomd.xml
Summary: gnome-software updates failing in pk-offline-update, cannot download repomd.xml
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: PackageKit
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-12-31 00:00 UTC by Chris Murphy
Modified: 2017-01-01 10:41 UTC (History)
5 users (show)

Fixed In Version: PackageKit-1.1.5-0.1.20161221.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-01 10:41:48 UTC
Type: Bug


Attachments (Terms of Use)
journal.log (1.24 MB, text/plain)
2016-12-31 00:01 UTC, Chris Murphy
no flags Details

Description Chris Murphy 2016-12-31 00:00:48 UTC
Description of problem:

Gnome-shell notifies of updates; I've tried restart & install from gnome-software as well as checking install pending updates from the gnome-shell reboot dialog. The updates are not applied.

Version-Release number of selected component (if applicable):
PackageKit-1.1.4-2.fc25.x86_64
systemd-231-10.fc25.x86_64

How reproducible:
Always


Steps to Reproduce:
1. See above.
2.
3.

Actual results:

journalctl -b-1 contains this entry

[    7.955568] f25h pk-offline-update[676]: failed to update system: cannot update repo 'fedora-cisco-openh264': Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried



Expected results:

It should update. This repo works fine for dnf, and it's been enabled the whole time I've had Fedora 25 installed without this being a problem; and besides shouldn't all packages already be downloaded? Why does pk-offline-update try to update repo in the first place? There isn't even network services.


Additional info:

Comment 1 Chris Murphy 2016-12-31 00:01:53 UTC
Created attachment 1236142 [details]
journal.log

Set params: systemd.log_level=debug rd.debug

Comment 2 Kalev Lember 2016-12-31 11:50:25 UTC
Can you try if https://bodhi.fedoraproject.org/updates/FEDORA-2016-3189d3a4df fixes this, please?

Comment 3 Chris Murphy 2016-12-31 17:03:39 UTC
That is one of the updates in /var/cache/PackageKit that's not being applied by pk-offline-update; however if manually applied with dnf and rebooting, now offline updates happen without error.

Does the problem with 1.1.4-2 affect only certain repos? Since there's no notification of update failure after rebooting, users may not notice this for a while.

Comment 4 Kalev Lember 2016-12-31 17:09:56 UTC
I don't know if it affects only certain repos. It does sound like this from your description; I don't have any more insight.

1.1.5-0.1 fixed a somewhat similar issue with the virtualbox repo; would have been nice to hear if this fixed your issue but I guess we'll not find it out now that you applied the updates with dnf.

Let me know if you can reproduce this in the future. Thanks!

Comment 5 Chris Murphy 2016-12-31 18:15:09 UTC
(In reply to Kalev Lember from comment #4)
> 1.1.5-0.1 fixed a somewhat similar issue with the virtualbox repo; would
> have been nice to hear if this fixed your issue but I guess we'll not find
> it out now that you applied the updates with dnf.

I only updated PackageKit with dnf. How else would I have updated it?

Comment 6 Kalev Lember 2017-01-01 09:47:59 UTC
Ahh, I see! Sorry. I thought you did a whole system update.

OK, in that case it sounds like it's fixed with 1.1.5-0.1.


Note You need to log in before you can comment on or make changes to this bug.