Bug 1409335 - Add ppd for Epson ET-3600
Summary: Add ppd for Epson ET-3600
Alias: None
Product: Fedora
Classification: Fedora
Component: epson-inkjet-printer-escpr
Version: 25
Hardware: x86_64
OS: Linux
Target Milestone: ---
Assignee: Susi Lehtola
QA Contact: Fedora Extras Quality Assurance
Depends On:
TreeView+ depends on / blocked
Reported: 2016-12-31 23:42 UTC by Paul Grabbe
Modified: 2018-08-04 06:36 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Last Closed: 2017-12-12 10:19:38 UTC
Type: Bug

Attachments (Terms of Use)

Description Paul Grabbe 2016-12-31 23:42:44 UTC
Description of problem: Feature request

Driver for Epson ET-3600 ecotank printer not yet included. Request addition of this driver to the list of printers supported in this package.

Version-Release number of selected component (if applicable):

How reproducible:


Steps to Reproduce:
1. Try adding ET-3600 printer
2. This model is not listed

Actual results:

No driver available

Expected results:

Driver available in choices

Additional info:

Can get printer to print over ethernet connection by selecting ET-4550 ppd. Have not tried scanner function yet. Also tried driver packages offered on Epson site for both Fedora 23 and 24. Neither seems to include the ppd for this printer, even though driver was supposed to support this device (via iscan).

Comment 1 Susi Lehtola 2017-01-01 03:18:36 UTC
I can't add a driver that doesn't exist. If upstream's open source driver supports your printer, then the Fedora package can be updated.

Comment 2 Chris Evich 2017-06-27 13:17:50 UTC
I just got an Epson ET-3600 and got it printing successfully (via ethernet/LPD interface) from F24 with the EPSON ET-2550 Series (ESC/P-R) driver.  The only thing it doesn't seem to support is two-sided printing (the hardware does).  

The Epson's Linux driver page for the ET-3600 doesn't list anything except the scanner driver (which works).  Poking around in the hive-mind (and finding this bug), I read the 4550 ESC/P-R driver (attached) can work.

This can be found by going to: http://download.ebz.epson.net/dsc/search/01/search/searchModule and searching for "ET-4550" and "Linux".  I'll try it out in a second.

However, since this printer also "works" with the ET-2550 driver, we clearly already provide most of the important bits, they just need some minor tweaking (for two-sided printing) and listing under the ET-3600 name :D

Comment 3 Chris Evich 2017-06-27 13:20:09 UTC
Created attachment 1292332 [details]
ET-4550 Series Printer Driver Linux 1.6.13 ESC/P-R Driver (generic driver)

Comment 4 Chris Evich 2017-06-27 13:20:58 UTC
Created attachment 1292333 [details]
Source RPM of the same

Comment 5 Chris Evich 2017-06-27 13:22:14 UTC
Marking both attachments as private, since downloading them requires agreeing to Epson's license: http://download.ebz.epson.net/dsc/du/02/DriverDownloadInfo.do?LG2=EN&CN2=&DSCMI=55539&DSCCHK=5ef6ec128765534a989152269045f12fc58077f2#

Comment 6 Chris Evich 2017-06-27 13:48:37 UTC
Success!  I couldn't add the printer via GNOME settings, or system-config-printer, but got it working from the cups interface directly.  From my F25 laptop:

1) Click "add printer" at http://localhost:631/admin
2) Choose Discovered Network Printers: 	EPSON ET-3600 Series (EPSON EPSON ET-3600 Series)
3) Tweak name/description, click continue
4) Hit "Or Provide a PPD File", and point it to /opt/epson-inkjet-printer-escpr/ppds/Epson/Epson-ET-4550_Series-epson-inkjet-printer-escpr.ppd.gz
5) Set options:
    print quality: High
    Duplex Tumble: 2-side long edge
    Media Size: whatever
6) Click set default options
7) Maintenance -> print test page

Comment 7 Fedora End Of Life 2017-07-26 00:09:10 UTC
This message is a reminder that Fedora 24 is nearing its end of life.
Approximately 2 (two) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 24. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '24'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not
able to fix it before Fedora 24 is end of life. If you would still like
to see this bug fixed and are able to reproduce it against a later version
of Fedora, you are encouraged  change the 'version' to a later Fedora
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

Comment 8 Fedora End Of Life 2017-12-12 10:19:38 UTC
Fedora 25 changed to end-of-life (EOL) status on 2017-12-12. Fedora 25 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this

Thank you for reporting this bug and we are sorry it could not be fixed.

Comment 9 ennyme 2018-08-04 06:36:57 UTC
Many times users fail to understand what happened with their device in just a day or even in seconds. They get surprised to see that their completely fine working device stop working all of sudden. If you have an Epson Printer that was working fine till yesterday but denies to print today, then it may not be the printer that has an issue, it may just a Windows update that you installed recently. It has been found many times with many Windows PC user who has installed a Windows update on their device that was causing the issues. It may be a recent Windows update that lies at the heart of the problem. And for the same, you need instant Epson printer support: https://www.epsonprinterrepair.com/

Note You need to log in before you can comment on or make changes to this bug.