Bug 1409337 - dvdauthor-0.7.2 is available
Summary: dvdauthor-0.7.2 is available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dvdauthor
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Shaw
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1409392
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-01 00:12 UTC by Upstream Release Monitoring
Modified: 2017-01-17 22:51 UTC (History)
2 users (show)

Fixed In Version: dvdauthor-0.7.2-1.fc25 dvdauthor-0.7.2-1.fc24 dvdauthor-0.7.2-1.el7
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-11 07:23:08 UTC
Type: ---


Attachments (Terms of Use)

Description Upstream Release Monitoring 2017-01-01 00:12:32 UTC
Latest upstream release: 0.7.2
Current version/release in rawhide: 0.7.1-9.fc24
URL: http://sourceforge.net/projects/dvdauthor

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/639/

Comment 1 Rex Dieter 2017-01-01 19:39:27 UTC
0.7.2 is FTBFS, due to missing graphicsmagick related includes.

src/Makefile ends up with
MAGICK_CFLAGS = -I/usr/include/GraphicsMagick

but as far as I can tell, that ends up not being used anywhere

Comment 2 Rex Dieter 2017-01-01 19:53:35 UTC
and src/Makefile.am only has
AM_CPPFLAGS = -DSYSCONFDIR="\"$(sysconfdir)\"" \
    @XML_CPPFLAGS@ @MAGICK_CPPFLAGS@ @FREETYPE_CPPFLAGS@ @FRIBIDI_CFLAGS@ @FONTCONFIG_CFLAGS@

Regression comes from
https://github.com/ldo/dvdauthor/commit/940456212bb3b451294d2fa281c2b3ae757c20ad
ironically logged as:
"Fix inconsistency between MAGICK_CPPFLAGS being defined in configure,
and MAGICK_CFLAGS being used in Makefile."

So, options off the top of my head:
1  patching src/Makefile* to use @MAGICK_CFLAGS@ here
2  patch configure to query/set MAGICK_CPPFLAGS from pkgconfig too

or some other better idea.

Comment 3 Richard Shaw 2017-01-02 14:43:33 UTC
Ok, trying patching Makefile.am and running autoreconf but I'm getting the following error in mock but not on a local build so I must be missing a package...

+ autoreconf -fi
configure.ac:136: warning: macro 'AM_ICONV' not found in library
libtoolize: putting auxiliary files in AC_CONFIG_AUX_DIR, 'autotools'.
libtoolize: copying file 'autotools/ltmain.sh'
libtoolize: Consider adding 'AC_CONFIG_MACRO_DIRS([m4])' to configure.ac,
libtoolize: and rerunning libtoolize and aclocal.
libtoolize: Consider adding '-I m4' to ACLOCAL_AMFLAGS in Makefile.am.
configure.ac:136: warning: macro 'AM_ICONV' not found in library
configure.ac:136: error: possibly undefined macro: AM_ICONV
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.

I have automake, autoconf, libtool, and gettext as build requirements so now I'm stumped.

Comment 4 Rex Dieter 2017-01-02 14:53:04 UTC
Add
BuildRequires: gettext-devel

which provides /usr/share/aclocal/iconv.m4

that may help.

Comment 5 Richard Shaw 2017-01-02 15:22:39 UTC
That was it but it turns out there's an easier solution. 

The previous maintainer redirected MagickCore-config to /bin/true to trick configure but all I had to do was redirect it to GraphicsMagick-config and now the required include is used.

Comment 6 Fedora Update System 2017-01-02 15:44:26 UTC
dvdauthor-0.7.2-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2017-158c69aedd

Comment 7 Fedora Update System 2017-01-02 15:44:33 UTC
dvdauthor-0.7.2-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-1d1f088eef

Comment 8 Fedora Update System 2017-01-02 15:44:37 UTC
dvdauthor-0.7.2-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-7e4c2c0182

Comment 9 Fedora Update System 2017-01-02 20:18:06 UTC
dvdauthor-0.7.2-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-7e4c2c0182

Comment 10 Fedora Update System 2017-01-02 20:48:33 UTC
dvdauthor-0.7.2-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-1d1f088eef

Comment 11 Fedora Update System 2017-01-03 02:17:50 UTC
dvdauthor-0.7.2-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-158c69aedd

Comment 12 Fedora Update System 2017-01-11 07:23:08 UTC
dvdauthor-0.7.2-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2017-01-11 12:19:30 UTC
dvdauthor-0.7.2-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2017-01-17 22:51:13 UTC
dvdauthor-0.7.2-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.