Bug 1409544 - rich rules unable to act upon icmp packets (accept/log/mark)
Summary: rich rules unable to act upon icmp packets (accept/log/mark)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: firewalld
Version: 7.3
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: rc
: ---
Assignee: Thomas Woerner
QA Contact: Tomas Dolezal
Mirek Jahoda
URL:
Whiteboard:
Depends On:
Blocks: 1459921
TreeView+ depends on / blocked
 
Reported: 2017-01-02 12:47 UTC by Tomas Dolezal
Modified: 2017-08-01 16:22 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
*firewalld* now supports actions on ICMP types in rich rules With this update, the *firewalld* service daemon allows using Internet Control Message Protocol (ICMP) types in rich rules with the accept, log and mark actions.
Clone Of:
: 1459921 (view as bug list)
Environment:
Last Closed: 2017-08-01 16:22:56 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1934 normal SHIPPED_LIVE firewalld bug fix and enhancement update 2017-08-01 17:55:15 UTC

Description Tomas Dolezal 2017-01-02 12:47:27 UTC
Description of problem:
It's not possible to use icmp-type (one of firewalld-internals) for actions in rich rules. This includes inability to log specific/non-specific icmp requests per sources or other constraints.

Version-Release number of selected component (if applicable):
firewalld-0.4.3.2-8.el7.noarch

How reproducible:
always

Steps to Reproduce:
rich rules don't accept icmp-type in their grammar
icmp-block is available instead, which is useful only for blocking the types specified


Expected results:
proceed with rich rule action based on icmp-type (or multiple types?)

Additional info:

Comment 7 errata-xmlrpc 2017-08-01 16:22:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1934


Note You need to log in before you can comment on or make changes to this bug.