Bug 1409577 - Socket error in 'connections' includes interrupt error
Summary: Socket error in 'connections' includes interrupt error
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rhnlib
Version: 7.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Jiří Dostál
QA Contact: Lukáš Hellebrandt
URL:
Whiteboard:
Depends On:
Blocks: 1395284
TreeView+ depends on / blocked
 
Reported: 2017-01-02 14:06 UTC by Jiří Dostál
Modified: 2017-08-01 22:19 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 22:19:00 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2039 0 normal SHIPPED_LIVE rhn-client-tools, rhnlib, rhnsd, and yum-rhn-plugin bug fix update 2017-08-01 19:33:28 UTC

Description Jiří Dostál 2017-01-02 14:06:02 UTC
Description of problem:
If process is terminated when using 'connections' from rhnlib, 'connections' reports socket error but we need to distinguish interrupt more precisely.

This Bugzilla has been created from https://bugzilla.redhat.com/show_bug.cgi?id=1260527 

This issue 
Version-Release number of selected component (if applicable):
rhnlib-2.6.1-1

How reproducible:
Always on RHEL 7

Steps to Reproduce:
1.  Register a RHEL 7 VM to satellite 5.7
2.  Assign provisioning entitlement to RHEL 7 system
3.  Subscribe RHEL 7 system to RHN tools channel.
4.  Install rhncfg and osad packages on RHEL 7 system using below command :
    # yum install rhncfg*
    # yum install osad
5   enable all actions for RHEL 7 system by executing below command :
    # rhn-actions-control --enable-all
6.  Go to RHEL 7 systems profile on satellite webui.
7.  Click on "Details" tab.
8.  Click on "Remote Command".
9.  In "Script" section add following command
    shutdown -h now  
10. Select appropriate time interval and date.
11. Click on schedule.
12. Now wait till command is executed. Once system is shutdown observe its status satellite webui.

Actual results:

1. Command is executed and system shuts down.
2. Status on satellite webUI remains as "The client has not yet completed this action"
3. When we power-on the system again the task gets executed and system gets shutdown
This goes in a loop. Action is never marked as completed.

Expected results:

1. Command is executed and system shuts down.
2. Status on satellite webUI should be : Completed


Additional info:
See https://bugzilla.redhat.com/show_bug.cgi?id=1260527 for original bug report.

This is fixed in spacewalk.git by 
75d9c00b96ab430221c5c7668baebebc74ddd67e
1840e8fb9fe2f5bf8fe29fd62bbd245660ceb1d2

Comment 3 Lukáš Hellebrandt 2017-06-29 14:42:27 UTC
Verified with rhnlib-2.5.65-4, rhn-client-tools-2.0.2-11 (ONLY, rhn-client-tools-2.0.2-16 version is broken).

Schedule a script to be run (long sleep), rhn_check, wait for it to pick up the script (it is shown in WebUI), then kill rhn_check with SIGTERM. If in WebUI, the state of script becomes '"Script executed. Termination signal occurred during execution" (code 0)', this part of fix works fine.

Comment 4 errata-xmlrpc 2017-08-01 22:19:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2039


Note You need to log in before you can comment on or make changes to this bug.