Bug 1409579 - cluster compatibility version upgrade fails if there's a template in the cluster
Summary: cluster compatibility version upgrade fails if there's a template in the cluster
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: ovirt-4.1.0-rc
: ---
Assignee: jniederm
QA Contact: sefi litmanovich
URL:
Whiteboard:
: 1412560 1416084 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-02 14:14 UTC by sefi litmanovich
Modified: 2017-02-15 14:50 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-15 14:50:40 UTC
oVirt Team: Virt
rule-engine: ovirt-4.1+
gklein: blocker+
rule-engine: planning_ack+
tjelinek: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)
engine log (331.93 KB, application/x-gzip)
2017-01-02 14:14 UTC, sefi litmanovich
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 69446 0 master MERGED core: Remove unused field in VmTemplate 2017-01-03 14:41:11 UTC
oVirt gerrit 69498 0 ovirt-engine-4.1 MERGED core: Remove unused field in VmTemplate 2017-01-03 15:43:16 UTC
oVirt gerrit 70784 0 ovirt-engine-4.1 MERGED core: UpdateVmTemplate doesn't load disks 2017-01-22 18:21:50 UTC
oVirt gerrit 70785 0 master MERGED core: UpdateVmTemplate doesn't load disks 2017-01-22 14:43:47 UTC
oVirt gerrit 71572 0 master MERGED core: VmTemplate.actualDiskSize property not cached 2017-02-06 14:51:30 UTC

Description sefi litmanovich 2017-01-02 14:14:56 UTC
Created attachment 1236665 [details]
engine log

Description of problem:
Cluster compatibility upgrade fails always if there's a template in the cluster.
It seems it doesn't matter what the source is, I tried it with a template I imported from glance, and then with a template I created from a vm in the cluster.
In both cases cluster upgrade fails, regardless to vms state as well (even if all are down during upgrade attempt).
If the cluster doesn't have any templates on it, cluster upgrade work as usual.

Version-Release number of selected component (if applicable):
rhevm-4.1.0-0.3.beta2.el7.noarch

How reproducible:
always

Steps to Reproduce:
1. Create a DC-Cluster with 4.0 compatibility version.
2. Add hosts to the cluster.
3. Create a vm.
4. Create a template from the vm.
5. try to upgrade the cluster compatibility version to 4.1

or replace 4 with:
4. import an image from glance as template.

Actual results:

action fails with:
'Error while executing action: Failed updating the properties of the VM template.'

Expected results:
Upgrade succeeds as usual.

Additional info:

2017-01-02 16:11:56,553+02 INFO  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (default task-8) [1caeddcc] Correlation ID: 7def2ae0, Call Stack: null, Custom Event ID: -1, Message: VM test-vm-upgrade configuration was updated by system.
2017-01-02 16:11:57,176+02 WARN  [org.ovirt.engine.core.bll.UpdateVmTemplateCommand] (default task-8) [7621f860] Validation of action 'UpdateVmTemplate' failed for user admin@internal-authz. Reasons: VAR__ACTION__UPDATE,VAR__TYPE__VM_TEMPLATE,VMT_CANNOT_UPDATE_ILLEGAL_FIELD
2017-01-02 16:11:57,266+02 ERROR [org.ovirt.engine.core.bll.UpdateRngDeviceCommand] (default task-8) [7621f860] Transaction rolled-back for command 'org.ovirt.engine.core.bll.UpdateRngDeviceCommand'.
2017-01-02 16:11:57,266+02 ERROR [org.ovirt.engine.core.bll.UpdateVmCommand] (default task-8) [7621f860] Transaction rolled-back for command 'org.ovirt.engine.core.bll.UpdateVmCommand'.
2017-01-02 16:11:57,266+02 ERROR [org.ovirt.engine.core.bll.UpdateClusterCommand] (default task-8) [7621f860] Transaction rolled-back for command 'org.ovirt.engine.core.bll.UpdateClusterCommand'.
2017-01-02 16:11:57,274+02 ERROR [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (default task-8) [7621f860] Correlation ID: deb708c4-9011-4fe4-8625-45ce37e1cb3c, Call Stack: null, Custom Event ID: -1, Message: Failed to update Host cluster (User: admin@internal-authz)

Comment 1 jniederm 2017-01-02 18:51:00 UTC
The problem appears only when there is a template with a disk in the upgraded cluster.

It was caused by change of a non-changeable abandoned property VmTemplate#bootDiskSizeGB. Solved by removing the property.

Comment 2 jniederm 2017-01-03 14:26:33 UTC
Problem description:
UpdateVmTemplateCommand checks (VmTemplateHandler.isUpdateValid) whether the only update-able properties (@EditableVmTemplateField) are updated. UpdateVmTemplateCommand holds two instance of VmTemplate, new (getVmTemplate()) and old (oldTemplate) one. Only the old one is being filled by storage related properties (by method VmTemplateHandler.updateDisksFromDb), among others #bootDiskSizeGB. The problem was that #bootDiskSizeGB property was not marked as editable and thus the validation (VmTemplateHandler.isUpdateValid) was failing since value of #bootDiskSizeGB differed between new and old VmTemplate instance.

Comment 4 Lukas Svaty 2017-01-12 17:24:48 UTC
*** Bug 1412560 has been marked as a duplicate of this bug. ***

Comment 5 Lukas Svaty 2017-01-12 17:30:51 UTC
This was not included in last build as the last build cut off is from 1st december:

ENGINE_CUTOFF: 83307d893bc60a0c736d6b654d7dfdd2503c780e

moving back to ASSIGNED

Comment 6 jniederm 2017-01-12 17:36:55 UTC
Patches (http://gerrit.ovirt.org/69446, http://gerrit.ovirt.org/69498) are already merged. The bug was probably moved to ON_QA too early.

Comment 7 Lukas Svaty 2017-01-12 17:50:42 UTC
After conversation with DEV this can be tested on upstream, thus there is a point to have this ON_QA. Moving back to ON_QA.

Comment 8 sefi litmanovich 2017-01-17 08:57:21 UTC
Tried to verify on master (upstream) - ovirt-engine-4.1.0-0.4.master.20170116141310.gita30debd.el7.centos.noarch, but the bug re produced partially.
Partially means - The bug occurred when the template I had in the cluster was one I imported from glance (And was created I guess sometime during our 4.0 testing).
The bug did not occur when I had only a newly created template in the cluster.
Moving the bug back to assigned.
Let me know if some more info is required.

Comment 9 Red Hat Bugzilla Rules Engine 2017-01-17 08:57:27 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 10 jniederm 2017-01-17 18:56:01 UTC
Hi Sefi, I can't reproduce it. I did:

1. Create new DC v. 4.0
2. Create new Cluster v. 4.0
3. Add a Host to the cluster
4. Add NFS Data storage domain to the DC
6. Storage tab > select predefined "ovirt-image-repository"
7. Select "Fedora 25 Cloud Atomic Image ..."
8. Click Import toolbar button
9. Check "Import as Template" checkbox and import in the cluster.
10. Check that the template is imported and has a disk.
11. Edit the cluster
12. Select 4.1 version
13. Confirm using OK

... and it worked. Can you please provide steps to reproduce?

I checked that the fixing patch (git commit 911d25d6922) is part of commit a30debd that is supposed to be a build cutoff based on the package name.

Comment 11 Tomas Jelinek 2017-01-18 07:40:40 UTC
OK, seems that it happens only with some specific template (not enough to import from glance, it has to have something more specific).
Consequently, removing the blocker flag.

Comment 12 Red Hat Bugzilla Rules Engine 2017-01-18 07:40:45 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 13 jniederm 2017-01-18 19:43:24 UTC
I can't say that steps to reproduce from comment 10 doesn't work any more. It (at lease sometimes) worked.

Comment 14 Gil Klein 2017-01-24 13:35:37 UTC
This issue is still reproducible with 4.1.0.9 : rhevm-4.1.0.2-0.2.el7.noarch

2017-01-24 15:26:40,359+02 WARN  [org.ovirt.engine.core.bll.scheduling.policyunits.CpuAndMemoryBalancingPolicyUnit] (DefaultQuartzScheduler2) [a2524fc] All candidate hosts have been filtered, can't balance the cluster 'golden_env_mixed_1' based on the CPU usage, will try memory based approach
2017-01-24 15:26:40,361+02 INFO  [org.ovirt.engine.core.bll.scheduling.policyunits.PowerSavingBalancePolicyUnit] (DefaultQuartzScheduler2) [a2524fc] Automatic power management is disabled for cluster 'golden_env_mixed_1'.
2017-01-24 15:27:40,387+02 WARN  [org.ovirt.engine.core.bll.scheduling.policyunits.CpuAndMemoryBalancingPolicyUnit] (DefaultQuartzScheduler3) [] All candidate hosts have been filtered, can't balance the cluster 'golden_env_mixed_1' based on the CPU usage, will try memory based approach
2017-01-24 15:27:40,407+02 INFO  [org.ovirt.engine.core.bll.scheduling.policyunits.PowerSavingBalancePolicyUnit] (DefaultQuartzScheduler3) [] Automatic power management is disabled for cluster 'golden_env_mixed_1'.
2017-01-24 15:28:40,414+02 WARN  [org.ovirt.engine.core.bll.scheduling.policyunits.CpuAndMemoryBalancingPolicyUnit] (DefaultQuartzScheduler8) [3373c157] All candidate hosts have been filtered, can't balance the cluster 'golden_env_mixed_1' based on the CPU usage, will try memory based approach
2017-01-24 15:28:40,416+02 INFO  [org.ovirt.engine.core.bll.scheduling.policyunits.PowerSavingBalancePolicyUnit] (DefaultQuartzScheduler8) [3373c157] Automatic power management is disabled for cluster 'golden_env_mixed_1'.
2017-01-24 15:29:40,440+02 WARN  [org.ovirt.engine.core.bll.scheduling.policyunits.CpuAndMemoryBalancingPolicyUnit] (DefaultQuartzScheduler1) [69f89264] All candidate hosts have been filtered, can't balance the cluster 'golden_env_mixed_1' based on the CPU usage, will try memory based approach
2017-01-24 15:29:40,441+02 INFO  [org.ovirt.engine.core.bll.scheduling.policyunits.PowerSavingBalancePolicyUnit] (DefaultQuartzScheduler1) [69f89264] Automatic power management is disabled for cluster 'golden_env_mixed_1'.
2017-01-24 15:30:40,448+02 WARN  [org.ovirt.engine.core.bll.scheduling.policyunits.CpuAndMemoryBalancingPolicyUnit] (DefaultQuartzScheduler4) [73bec318] All candidate hosts have been filtered, can't balance the cluster 'golden_env_mixed_1' based on the CPU usage, will try memory based approach
2017-01-24 15:30:40,449+02 INFO  [org.ovirt.engine.core.bll.scheduling.policyunits.PowerSavingBalancePolicyUnit] (DefaultQuartzScheduler4) [73bec318] Automatic power management is disabled for cluster 'golden_env_mixed_1'.

2017-01-24 15:31:16,023+02 INFO  [org.ovirt.engine.core.bll.UpdateClusterCommand] (default task-14) [1d906f1e-144c-4816-b3a9-720e3b291fe6] Lock Acquired to object 'EngineLock:{exclusiveLocks='[942600cd-37df-4673-8bb1-f27e54cfc8cb=<TEMPLATE, ACTION_TYPE_FAILED_CLUSTER_IS_BEING_UPDATED$clusterName golden_env_mixed_1>]', sharedLocks='[8cf571be-651e-47c4-8180-9d34a1bbb108=<VM, ACTION_TYPE_FAILED_CLUSTER_IS_BEING_UPDATED$clusterName golden_env_mixed_1>, c5dae804-2e04-4d2c-958c-98348c3733d6=<VM, ACTION_TYPE_FAILED_CLUSTER_IS_BEING_UPDATED$clusterName golden_env_mixed_1>, efdb0b04-5e58-4d68-b8cd-330cd0eb4903=<VM, ACTION_TYPE_FAILED_CLUSTER_IS_BEING_UPDATED$clusterName golden_env_mixed_1>, aa57be76-e7c1-438e-910a-a22f312f2770=<VM, ACTION_TYPE_FAILED_CLUSTER_IS_BEING_UPDATED$clusterName golden_env_mixed_1>, fca3ba48-4eac-4c8c-b7ea-2fe76c2a6a7e=<VM, ACTION_TYPE_FAILED_CLUSTER_IS_BEING_UPDATED$clusterName golden_env_mixed_1>, e6a2f67a-db75-4657-a99f-2b019629ce77=<VM, ACTION_TYPE_FAILED_CLUSTER_IS_BEING_UPDATED$clusterName golden_env_mixed_1>]'}'
2017-01-24 15:31:16,041+02 INFO  [org.ovirt.engine.core.bll.UpdateClusterCommand] (default task-14) [1d906f1e-144c-4816-b3a9-720e3b291fe6] Running command: UpdateClusterCommand internal: false. Entities affected :  ID: 67b1e240-ae6d-47f3-85b8-e23521331de1 Type: ClusterAction group EDIT_CLUSTER_CONFIGURATION with role type ADMIN
2017-01-24 15:31:16,114+02 INFO  [org.ovirt.engine.core.bll.UpdateVmCommand] (default task-14) [4395677b] Running command: UpdateVmCommand internal: true. Entities affected :  ID: 8cf571be-651e-47c4-8180-9d34a1bbb108 Type: VMAction group EDIT_VM_PROPERTIES with role type USER
2017-01-24 15:31:16,115+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [4395677b] Field 'balloonEnabled' can not be updated when status is 'Up'
2017-01-24 15:31:16,115+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [4395677b] Field 'rngDevice' can not be updated when status is 'Up'
2017-01-24 15:31:16,115+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [4395677b] Field 'soundDeviceEnabled' can not be updated when status is 'Up'
2017-01-24 15:31:16,115+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [4395677b] Field 'consoleEnabled' can not be updated when status is 'Up'
2017-01-24 15:31:16,116+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [4395677b] Field 'virtioScsiEnabled' can not be updated when status is 'Up'
2017-01-24 15:31:16,116+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [4395677b] Field 'graphicsDevices' can not be updated when status is 'Up'
2017-01-24 15:31:16,121+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [4395677b] Field 'balloonEnabled' can not be updated when status is 'Up'
2017-01-24 15:31:16,121+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [4395677b] Field 'rngDevice' can not be updated when status is 'Up'
2017-01-24 15:31:16,121+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [4395677b] Field 'soundDeviceEnabled' can not be updated when status is 'Up'
2017-01-24 15:31:16,121+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [4395677b] Field 'consoleEnabled' can not be updated when status is 'Up'
2017-01-24 15:31:16,122+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [4395677b] Field 'virtioScsiEnabled' can not be updated when status is 'Up'
2017-01-24 15:31:16,122+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [4395677b] Field 'graphicsDevices' can not be updated when status is 'Up'
2017-01-24 15:31:16,154+02 INFO  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (default task-14) [4395677b] EVENT_ID: SYSTEM_UPDATE_VM(253), Correlation ID: 4395677b, Call Stack: null, Custom Event ID: -1, Message: VM golden_env_mixed_virtio_3_0 configuration was updated by system.
2017-01-24 15:31:16,188+02 INFO  [org.ovirt.engine.core.bll.UpdateVmCommand] (default task-14) [6979f332] Running command: UpdateVmCommand internal: true. Entities affected :  ID: aa57be76-e7c1-438e-910a-a22f312f2770 Type: VMAction group EDIT_VM_PROPERTIES with role type USER
2017-01-24 15:31:16,189+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [6979f332] Field 'balloonEnabled' can not be updated when status is 'Up'
2017-01-24 15:31:16,189+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [6979f332] Field 'rngDevice' can not be updated when status is 'Up'
2017-01-24 15:31:16,189+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [6979f332] Field 'soundDeviceEnabled' can not be updated when status is 'Up'
2017-01-24 15:31:16,189+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [6979f332] Field 'consoleEnabled' can not be updated when status is 'Up'
2017-01-24 15:31:16,190+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [6979f332] Field 'virtioScsiEnabled' can not be updated when status is 'Up'
2017-01-24 15:31:16,190+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [6979f332] Field 'graphicsDevices' can not be updated when status is 'Up'
2017-01-24 15:31:16,191+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [6979f332] Field 'balloonEnabled' can not be updated when status is 'Up'
2017-01-24 15:31:16,191+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [6979f332] Field 'rngDevice' can not be updated when status is 'Up'
2017-01-24 15:31:16,191+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [6979f332] Field 'soundDeviceEnabled' can not be updated when status is 'Up'
2017-01-24 15:31:16,191+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [6979f332] Field 'consoleEnabled' can not be updated when status is 'Up'
2017-01-24 15:31:16,192+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [6979f332] Field 'virtioScsiEnabled' can not be updated when status is 'Up'
2017-01-24 15:31:16,192+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [6979f332] Field 'graphicsDevices' can not be updated when status is 'Up'
2017-01-24 15:31:16,205+02 INFO  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (default task-14) [6979f332] EVENT_ID: SYSTEM_UPDATE_VM(253), Correlation ID: 6979f332, Call Stack: null, Custom Event ID: -1, Message: VM golden_env_mixed_virtio_2_1 configuration was updated by system.
2017-01-24 15:31:16,232+02 INFO  [org.ovirt.engine.core.bll.UpdateVmCommand] (default task-14) [1cf2253e] Running command: UpdateVmCommand internal: true. Entities affected :  ID: c5dae804-2e04-4d2c-958c-98348c3733d6 Type: VMAction group EDIT_VM_PROPERTIES with role type USER
2017-01-24 15:31:16,232+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [1cf2253e] Field 'balloonEnabled' can not be updated when status is 'Up'
2017-01-24 15:31:16,232+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [1cf2253e] Field 'rngDevice' can not be updated when status is 'Up'
2017-01-24 15:31:16,232+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [1cf2253e] Field 'soundDeviceEnabled' can not be updated when status is 'Up'
2017-01-24 15:31:16,232+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [1cf2253e] Field 'consoleEnabled' can not be updated when status is 'Up'
2017-01-24 15:31:16,233+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [1cf2253e] Field 'virtioScsiEnabled' can not be updated when status is 'Up'
2017-01-24 15:31:16,233+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [1cf2253e] Field 'graphicsDevices' can not be updated when status is 'Up'
2017-01-24 15:31:16,234+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [1cf2253e] Field 'balloonEnabled' can not be updated when status is 'Up'
2017-01-24 15:31:16,234+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [1cf2253e] Field 'rngDevice' can not be updated when status is 'Up'
2017-01-24 15:31:16,234+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [1cf2253e] Field 'soundDeviceEnabled' can not be updated when status is 'Up'
2017-01-24 15:31:16,234+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [1cf2253e] Field 'consoleEnabled' can not be updated when status is 'Up'
2017-01-24 15:31:16,235+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [1cf2253e] Field 'virtioScsiEnabled' can not be updated when status is 'Up'
2017-01-24 15:31:16,235+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [1cf2253e] Field 'graphicsDevices' can not be updated when status is 'Up'
2017-01-24 15:31:16,248+02 INFO  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (default task-14) [1cf2253e] EVENT_ID: SYSTEM_UPDATE_VM(253), Correlation ID: 1cf2253e, Call Stack: null, Custom Event ID: -1, Message: VM golden_env_mixed_virtio_1_1 configuration was updated by system.
2017-01-24 15:31:16,278+02 INFO  [org.ovirt.engine.core.bll.UpdateVmCommand] (default task-14) [3a68338c] Running command: UpdateVmCommand internal: true. Entities affected :  ID: e6a2f67a-db75-4657-a99f-2b019629ce77 Type: VMAction group EDIT_VM_PROPERTIES with role type USER
2017-01-24 15:31:16,278+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [3a68338c] Field 'balloonEnabled' can not be updated when status is 'Up'
2017-01-24 15:31:16,278+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [3a68338c] Field 'rngDevice' can not be updated when status is 'Up'
2017-01-24 15:31:16,278+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [3a68338c] Field 'soundDeviceEnabled' can not be updated when status is 'Up'
2017-01-24 15:31:16,278+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [3a68338c] Field 'consoleEnabled' can not be updated when status is 'Up'
2017-01-24 15:31:16,279+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [3a68338c] Field 'virtioScsiEnabled' can not be updated when status is 'Up'
2017-01-24 15:31:16,279+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [3a68338c] Field 'graphicsDevices' can not be updated when status is 'Up'
2017-01-24 15:31:16,281+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [3a68338c] Field 'balloonEnabled' can not be updated when status is 'Up'
2017-01-24 15:31:16,281+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [3a68338c] Field 'rngDevice' can not be updated when status is 'Up'
2017-01-24 15:31:16,281+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [3a68338c] Field 'soundDeviceEnabled' can not be updated when status is 'Up'
2017-01-24 15:31:16,281+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [3a68338c] Field 'consoleEnabled' can not be updated when status is 'Up'
2017-01-24 15:31:16,281+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [3a68338c] Field 'virtioScsiEnabled' can not be updated when status is 'Up'
2017-01-24 15:31:16,281+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [3a68338c] Field 'graphicsDevices' can not be updated when status is 'Up'
2017-01-24 15:31:16,295+02 INFO  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (default task-14) [3a68338c] EVENT_ID: SYSTEM_UPDATE_VM(253), Correlation ID: 3a68338c, Call Stack: null, Custom Event ID: -1, Message: VM golden_env_mixed_virtio_3_1 configuration was updated by system.
2017-01-24 15:31:16,316+02 INFO  [org.ovirt.engine.core.bll.UpdateVmCommand] (default task-14) [5cc185e] Running command: UpdateVmCommand internal: true. Entities affected :  ID: efdb0b04-5e58-4d68-b8cd-330cd0eb4903 Type: VMAction group EDIT_VM_PROPERTIES with role type USER
2017-01-24 15:31:16,316+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [5cc185e] Field 'balloonEnabled' can not be updated when status is 'Up'
2017-01-24 15:31:16,316+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [5cc185e] Field 'rngDevice' can not be updated when status is 'Up'
2017-01-24 15:31:16,316+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [5cc185e] Field 'soundDeviceEnabled' can not be updated when status is 'Up'
2017-01-24 15:31:16,316+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [5cc185e] Field 'consoleEnabled' can not be updated when status is 'Up'
2017-01-24 15:31:16,317+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [5cc185e] Field 'virtioScsiEnabled' can not be updated when status is 'Up'
2017-01-24 15:31:16,317+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [5cc185e] Field 'graphicsDevices' can not be updated when status is 'Up'
2017-01-24 15:31:16,318+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [5cc185e] Field 'balloonEnabled' can not be updated when status is 'Up'
2017-01-24 15:31:16,318+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [5cc185e] Field 'rngDevice' can not be updated when status is 'Up'
2017-01-24 15:31:16,318+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [5cc185e] Field 'soundDeviceEnabled' can not be updated when status is 'Up'
2017-01-24 15:31:16,318+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [5cc185e] Field 'consoleEnabled' can not be updated when status is 'Up'
2017-01-24 15:31:16,319+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [5cc185e] Field 'virtioScsiEnabled' can not be updated when status is 'Up'
2017-01-24 15:31:16,319+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [5cc185e] Field 'graphicsDevices' can not be updated when status is 'Up'
2017-01-24 15:31:16,330+02 INFO  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (default task-14) [5cc185e] EVENT_ID: SYSTEM_UPDATE_VM(253), Correlation ID: 5cc185e, Call Stack: null, Custom Event ID: -1, Message: VM golden_env_mixed_virtio_2_0 configuration was updated by system.
2017-01-24 15:31:16,353+02 INFO  [org.ovirt.engine.core.bll.UpdateVmCommand] (default task-14) [e769e06] Running command: UpdateVmCommand internal: true. Entities affected :  ID: fca3ba48-4eac-4c8c-b7ea-2fe76c2a6a7e Type: VMAction group EDIT_VM_PROPERTIES with role type USER
2017-01-24 15:31:16,353+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [e769e06] Field 'balloonEnabled' can not be updated when status is 'Up'
2017-01-24 15:31:16,353+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [e769e06] Field 'rngDevice' can not be updated when status is 'Up'
2017-01-24 15:31:16,353+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [e769e06] Field 'soundDeviceEnabled' can not be updated when status is 'Up'
2017-01-24 15:31:16,353+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [e769e06] Field 'consoleEnabled' can not be updated when status is 'Up'
2017-01-24 15:31:16,354+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [e769e06] Field 'virtioScsiEnabled' can not be updated when status is 'Up'
2017-01-24 15:31:16,354+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [e769e06] Field 'graphicsDevices' can not be updated when status is 'Up'
2017-01-24 15:31:16,355+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [e769e06] Field 'balloonEnabled' can not be updated when status is 'Up'
2017-01-24 15:31:16,355+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [e769e06] Field 'rngDevice' can not be updated when status is 'Up'
2017-01-24 15:31:16,355+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [e769e06] Field 'soundDeviceEnabled' can not be updated when status is 'Up'
2017-01-24 15:31:16,355+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [e769e06] Field 'consoleEnabled' can not be updated when status is 'Up'
2017-01-24 15:31:16,356+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [e769e06] Field 'virtioScsiEnabled' can not be updated when status is 'Up'
2017-01-24 15:31:16,356+02 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (default task-14) [e769e06] Field 'graphicsDevices' can not be updated when status is 'Up'
2017-01-24 15:31:16,370+02 INFO  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (default task-14) [e769e06] EVENT_ID: SYSTEM_UPDATE_VM(253), Correlation ID: e769e06, 
This issue is still reproducible with 4.1.0.9

Call Stack: null, Custom Event ID: -1, Message: VM golden_env_mixed_virtio_1_0 configuration was updated by system.
2017-01-24 15:31:16,395+02 WARN  [org.ovirt.engine.core.bll.UpdateVmTemplateCommand] (default task-14) [1faa1295] Validation of action 'UpdateVmTemplate' failed for user admin@internal-authz. Reasons: VAR__ACTION__UPDATE,VAR__TYPE__VM_TEMPLATE,VMT_CANNOT_UPDATE_ILLEGAL_FIELD
2017-01-24 15:31:16,399+02 ERROR [org.ovirt.engine.core.bll.UpdateVmCommand] (default task-14) [1faa1295] Transaction rolled-back for command 'org.ovirt.engine.core.bll.UpdateVmCommand'.
2017-01-24 15:31:16,399+02 ERROR [org.ovirt.engine.core.bll.UpdateVmCommand] (default task-14) [1faa1295] Transaction rolled-back for command 'org.ovirt.engine.core.bll.UpdateVmCommand'.
2017-01-24 15:31:16,399+02 ERROR [org.ovirt.engine.core.bll.UpdateVmCommand] (default task-14) [1faa1295] Transaction rolled-back for command 'org.ovirt.engine.core.bll.UpdateVmCommand'.
2017-01-24 15:31:16,399+02 ERROR [org.ovirt.engine.core.bll.UpdateVmCommand] (default task-14) [1faa1295] Transaction rolled-back for command 'org.ovirt.engine.core.bll.UpdateVmCommand'.
2017-01-24 15:31:16,399+02 ERROR [org.ovirt.engine.core.bll.UpdateVmCommand] (default task-14) [1faa1295] Transaction rolled-back for command 'org.ovirt.engine.core.bll.UpdateVmCommand'.
2017-01-24 15:31:16,399+02 ERROR [org.ovirt.engine.core.bll.UpdateVmCommand] (default task-14) [1faa1295] Transaction rolled-back for command 'org.ovirt.engine.core.bll.UpdateVmCommand'.
2017-01-24 15:31:16,399+02 ERROR [org.ovirt.engine.core.bll.UpdateClusterCommand] (default task-14) [1faa1295] Transaction rolled-back for command 'org.ovirt.engine.core.bll.UpdateClusterCommand'.
2017-01-24 15:31:16,402+02 ERROR [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (default task-14) [1faa1295] EVENT_ID: USER_UPDATE_CLUSTER_FAILED(812), Correlation ID: 1d906f1e-144c-4816-b3a9-720e3b291fe6, Call Stack: null, Custom Event ID: -1, Message: Failed to update Host cluster (User: admin@internal-authz)
2017-01-24 15:31:16,402+02 INFO  [org.ovirt.engine.core.bll.UpdateClusterCommand] (default task-14) [1faa1295] Lock freed to object 'EngineLock:{exclusiveLocks='[942600cd-37df-4673-8bb1-f27e54cfc8cb=<TEMPLATE, ACTION_TYPE_FAILED_CLUSTER_IS_BEING_UPDATED$clusterName golden_env_mixed_1>]', sharedLocks='[8cf571be-651e-47c4-8180-9d34a1bbb108=<VM, ACTION_TYPE_FAILED_CLUSTER_IS_BEING_UPDATED$clusterName golden_env_mixed_1>, c5dae804-2e04-4d2c-958c-98348c3733d6=<VM, ACTION_TYPE_FAILED_CLUSTER_IS_BEING_UPDATED$clusterName golden_env_mixed_1>, efdb0b04-5e58-4d68-b8cd-330cd0eb4903=<VM, ACTION_TYPE_FAILED_CLUSTER_IS_BEING_UPDATED$clusterName golden_env_mixed_1>, aa57be76-e7c1-438e-910a-a22f312f2770=<VM, ACTION_TYPE_FAILED_CLUSTER_IS_BEING_UPDATED$clusterName golden_env_mixed_1>, fca3ba48-4eac-4c8c-b7ea-2fe76c2a6a7e=<VM, ACTION_TYPE_FAILED_CLUSTER_IS_BEING_UPDATED$clusterName golden_env_mixed_1>, e6a2f67a-db75-4657-a99f-2b019629ce77=<VM, ACTION_TYPE_FAILED_CLUSTER_IS_BEING_UPDATED$clusterName golden_env_mixed_1>]'}'

Comment 15 Red Hat Bugzilla Rules Engine 2017-01-24 13:35:43 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 16 Tal Nisan 2017-01-24 15:08:36 UTC
*** Bug 1416084 has been marked as a duplicate of this bug. ***

Comment 17 Gil Klein 2017-01-24 20:53:55 UTC
(In reply to Tomas Jelinek from comment #11)
> OK, seems that it happens only with some specific template (not enough to
> import from glance, it has to have something more specific).
> Consequently, removing the blocker flag.
I'm adding back the blocker+ as this seems to be reoccurring on different QE environments.

See comment #14 and also the duplicates BZ #1412560 and BZ #1416084

Please contact me if you want access to the a system that can reproduce it easily

Comment 18 Tal Nisan 2017-01-30 13:41:22 UTC
*** Bug 1417597 has been marked as a duplicate of this bug. ***

Comment 19 sefi litmanovich 2017-02-01 09:56:42 UTC
Verified with rhevm-4.1.0.3-0.1.el7.

Upgraded 4.0 cluster to 4.1 with several templates in the cluster, (some created in 4.1, some old templates imported from glance, also different disk types).
One of the templates with 'actual_size' value in DB = 0.
Upgrade succeeded as expected.

Comment 20 jniederm 2017-02-02 12:35:35 UTC
The bot is too eager regarding attaching patches.


Note You need to log in before you can comment on or make changes to this bug.