Bug 140958 - anaconda neglected to install email client, browser
anaconda neglected to install email client, browser
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: comps (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-26 18:24 EST by John Summerfield
Modified: 2014-03-16 22:50 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-28 13:58:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda-generate ks file (1.38 KB, text/plain)
2004-11-26 18:28 EST, John Summerfield
no flags Details

  None (edit)
Description John Summerfield 2004-11-26 18:24:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040809 Epiphany/1.3.8

Description of problem:
When I installed RHEL AS, I had icons for a browser and an email
client, but neither was isntalled.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot install CD
2. Install from CD - see ks file RSN
3.
    

Actual Results:  See above

Expected Results:  I assumed the RH-preferred GUI email client and
browser would be standard components.

Additional info:
Comment 1 John Summerfield 2004-11-26 18:28:52 EST
Created attachment 107495 [details]
Anaconda-generate ks file

The primary purpose of providing this is to show the package selections I made.
Many of them I expected to be in a server install.

Perhaps you could consider "basic server" to which one is expected to add
components and "server" which has most stuff by default.

This is AS, I can imagine it being put to single-purpose and all-purpose uses.
Comment 2 Jay Turner 2004-11-27 15:36:58 EST
Both evolution and firefox (the default mail client and browser, respectively)
are included in the "Graphical Internet" group, which gets pulled into the
"Workstation Common" meta-group.  Your kickstart files indicates that you didn't
install this group, which is why the icons don't map to anything (the icons
actually call helper applications, not the evolution and firefox applications
directly.)
Comment 3 John Summerfield 2004-11-27 21:38:32 EST
I didn't deselect them either.

This is a _server_ configuration. Why would I choose _Internet applications?_

The default server configuraton ought be a working server, and this isn't
really. It lacks the tools for the sysadmin to use to communicate with colleagues.

Whatever is installed on a server, if RH believes it should have a GUI desktop
then the basic desktop should include a usable email client.


Importantly, there should be no configured press-buttons for starting stuff that
is not installed. If I click on the "email" button then I expect an email client
to start.

I am unhappy that this bug was closed without proper consideration.
Comment 4 Jay Turner 2004-11-28 06:04:14 EST
Well, in a sense you did deselect them by not specifying that group to be
included in your kickstart configuration file.  You specified a particular
configuration and anaconda fulfilled that request without second guessing what
you were trying to do.  If you had gone through the normal installer, you would
have probably ended up with an entirely different installed package set.  As for
a usuable email client, there are probably several installed (can't tell for
sure without seeing your install.log) but I suspect that /bin/mail exists, which
has been a perfectly good email client for about 20 years.

A standard server install (from the RH prospective) doesn't actually include X
at all, as most folks that are setting up true servers want as few packages
installed, thus resulting in the least amount of space devoted to the OS.  As
for the press-buttons, as I said before, they are actually helper applications
which can launch a number of applications, they are part of the normal desktop
install, and when going through a normal install there would indeed be graphical
applications to back them up.  Since you did a customized kickstart install, RH
isn't going to second guess your package selection and start installing stuff
you didn't ask for.  For all we know, you're installing epiphany post-install
and want the helper buttons to launch that (which it will.)

So, I closed the bug because it's not valid.  You're complaint is that when
doing a custom install in which you didn't ask for a graphical email client or
browser, none got installed.  That's as designed and intended.
Comment 5 John Summerfield 2004-11-28 06:35:40 EST
Bullshit.

I did _not_ do a kickstart install. Where did I say I did a kickstart
install?

Are you listening? I am getting very annoyed about this.

I DID NOT DO A KICKSTART INSTALL.

I certainly DID NOT DESELECT GUI components because I wanted to see
what RH proposes to offer by of server configuration aids.

The _only_ sens in which I did a custom isntall is I added non-default
servers,

You've twice closed this problem without taking the trouble to
understand it.


I don't see any information in the Anaconda logs that is helpful, but
if you want them you can have them.

I suggest Jeremy add info to the log that shows what menu choices are
made at each stage, especially at the package-selecton stage but also
at partitioning.
Comment 6 Jay Turner 2004-11-28 06:53:50 EST
You included a kickstart config file, so thought that was the kickstart config
file you used.  I see now you posted the anaconda generated kickstart file. 
Anyway, by default a "server" install doesn't include any X applications, as I
pointed out in comment 4.  You would see an entirely different default package
selection if you were installing from the WS or Desktop discs.  I'll verify the
default package selection for AS shortly.
Comment 7 Bill Nottingham 2005-03-28 13:58:20 EST
I beleive that's not a bug; server doesn't include X apps.

Note You need to log in before you can comment on or make changes to this bug.