Bug 1409587 - docbook-style-xsl: xsltproc returned non-zero exit status 5 (Error in the stylesheet)
Summary: docbook-style-xsl: xsltproc returned non-zero exit status 5 (Error in the sty...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: docbook-style-xsl
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ondrej Vasik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1409371
TreeView+ depends on / blocked
 
Reported: 2017-01-02 14:58 UTC by Tomas Orsava
Modified: 2017-01-03 10:32 UTC (History)
4 users (show)

Fixed In Version: docbook-style-xsl-1.79.2-3.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-03 09:32:23 UTC
Type: Bug


Attachments (Terms of Use)

Description Tomas Orsava 2017-01-02 14:58:33 UTC
Description of problem:
My package `qutebrowser` uses `a2x` to build a manpage [0], which then calls xsltproc that uses a stylesheet from this `docbook-style-xsl` package. Everything works with docbook-style-xsl version 1.79.1-1, but with docbook-style-xsl version 1.79.2-2 xsltproc returns non-zero exit status 5 (Error in the stylesheet).

[0] http://pkgs.fedoraproject.org/cgit/rpms/qutebrowser.git/tree/qutebrowser.spec#n44


Version-Release number of selected component (if applicable):
docbook-style-xsl 1.79.2-2


How reproducible:
Every time


Steps to Reproduce:
1. build `qutebrowser` in koji for rawhide


Actual results:
+ a2x -f manpage doc/qutebrowser.1.asciidoc
a2x: ERROR: "xsltproc"  --stringparam callout.graphics 0 --stringparam navig.graphics 0 --stringparam admon.textlabel 1 --stringparam admon.graphics 0  "/etc/asciidoc/docbook-xsl/manpage.xsl" "/builddir/build/BUILD/qutebrowser-0.8.4/doc/qutebrowser.1.xml" returned non-zero exit status 5

Log: https://kojipkgs.fedoraproject.org//work/tasks/9054/17149054/build.log


Expected results:
Compiled man page

Comment 1 Ondrej Vasik 2017-01-02 19:04:16 UTC
I think this can be related to the change of the online stylesheet location. docbook-style-xsl 1.79.2 uses http://cdn.docbook.org/release/xsl-nons/current/ , while the old docbook-style-xsl 1.79.1 and current asciidoc uses old sourceforge location. I think it is possible asciidoc should be updated instead - or maybe both URI rewrites should be used temporarily in xmlcatalog file. This can be confirmed by using docbook-style-xsl-1.79.2-1.fc26 - as the first build was without change of online stylesheet location.
Adding asciidoc maintainer to cc...

Comment 2 Ondrej Vasik 2017-01-03 09:32:23 UTC
Restored the old URI rewrites for sourceforge online location (just for the current version, not for the 1.79.1 ...). Works for me locally, so closing Rawhide - feel free to reopen, if the issue still occurs with docbook-style-xsl-1.79.2-3.fc26 or later .
Still, in my opinion bug in asciidoc package - and this is just a workaround.

Comment 3 Tomas Orsava 2017-01-03 10:32:25 UTC
The fix works and qutebrowser builds nicely, thank you!


Note You need to log in before you can comment on or make changes to this bug.