Bug 1409588 - LimitNICE= for negative number sets incorrect nice value
Summary: LimitNICE= for negative number sets incorrect nice value
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: systemd
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Lukáš Nykrýn
QA Contact: Branislav Blaškovič
URL:
Whiteboard:
Depends On:
Blocks: 74systemd
TreeView+ depends on / blocked
 
Reported: 2017-01-02 14:59 UTC by Branislav Blaškovič
Modified: 2017-08-01 09:12 UTC (History)
2 users (show)

Fixed In Version: systemd-219-31.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 09:12:22 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2297 normal SHIPPED_LIVE systemd bug fix and enhancement update 2017-08-01 12:40:16 UTC

Description Branislav Blaškovič 2017-01-02 14:59:47 UTC
Description of problem:
If I want to set NICE for a unit via LimitNICE= in unit file, it does not set it properly for negative numbers.

Version-Release number of selected component (if applicable):
systemd-219-30.el7.centos.20161209.1.x86_64 (from copr)

How reproducible:
always

Steps to Reproduce:
1. Set LimitNICE=-2 in unit file and run 'nice' in process
2. or run /CoreOS/systemd/Regression/LimitSTACK-option

Actual results:
LimitNICE=0 (ulimit -e returns 18446744073709551614 which could be bug in ulimit)

Expected results:
LimitNICE=-2

Comment 1 Lukáš Nykrýn 2017-01-03 12:21:03 UTC
https://github.com/systemd/systemd/commit/29857001854a02c292f1f3b324e7a66831e859c8 seems to be relevant

Comment 3 Lukáš Nykrýn 2017-01-03 13:52:24 UTC
https://github.com/lnykryn/systemd-rhel/pull/73

Comment 4 Lukáš Nykrýn 2017-01-16 11:27:07 UTC
fix merged to upstream staging branch ->
https://github.com/lnykryn/systemd-rhel/commit/c56c1f6c2b683d6f20a7e8caeecec6c3cb76798f
-> post

Comment 8 errata-xmlrpc 2017-08-01 09:12:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2297


Note You need to log in before you can comment on or make changes to this bug.