Bug 1409589 - Screen flickers after Fedora 25 installation
Summary: Screen flickers after Fedora 25 installation
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: wayland
Version: 25
Hardware: x86_64
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-02 15:04 UTC by pdimitrov
Modified: 2017-02-13 17:06 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-13 17:06:16 UTC
Type: Bug


Attachments (Terms of Use)

Description pdimitrov 2017-01-02 15:04:14 UTC
Description of problem:
After installing the KDE spin of Fedora 25, my screen keeps flickering which I suppose must be due to some conflict with the graphic card. My workstation is using Optimus NVIDIA optimus where I have currently disabled the NVIDIA card and keep only the integrated one:

$ lspci -nn | grep VGA
00:02.0 VGA compatible controller [0300]: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller [8086:0416] (rev 06)

As far as I know Wayland is now default with the release so any feedback on how to check for information from it or how to disable it are more than welcome.

How reproducible:
Flicker is also visible on Live-user run, only requirement is the specific hardware.

Actual results:
Screen keeps flashing with varying frequency although refresh rate and all graphic settings are default.

Expected results:
Screen redrawing should be seamless.

Additional info:
I am ready to provide you with any configuration info you may require.

Comment 1 pdimitrov 2017-02-13 17:06:16 UTC
It seems that the most recent updates on Fedora fix this issue. No flicker appears anymore.


Note You need to log in before you can comment on or make changes to this bug.