Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1409590 - After dnf upgrade dnf is unusable
Summary: After dnf upgrade dnf is unusable
Keywords:
Status: CLOSED DUPLICATE of bug 1409557
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: rawhide
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-02 15:07 UTC by Pavol Babinčák
Modified: 2017-01-02 17:55 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-02 17:48:16 UTC
Type: Bug


Attachments (Terms of Use)

Description Pavol Babinčák 2017-01-02 15:07:35 UTC
Description of problem:
After upgrade of dnf in docker rawhide dnf is unusable.

/usr/libexec/system-python: relocation error: /lib64/libpython3.6m.so.1.0: symbol getentropy, version GLIBC_2.25 not defined in file libc.so.6 with link time reference

Version-Release number of selected component (if applicable):
Before: dnf-1.1.9-6.fc26.noarch
After: dnf-2.0.0-2.fc26.noarch

How reproducible:
Always

Steps to Reproduce:
1. Run
$ docker run --rm -ti fedora:rawhide bash -c 'dnf upgrade -y dnf && dnf'

Actual results:
dnf is upgraded including dependencies and then dnf command prints error:

/usr/libexec/system-python: relocation error: /lib64/libpython3.6m.so.1.0: symbol getentropy, version GLIBC_2.25 not defined in file libc.so.6 with link time reference

Also any other dnf command prints that error.

Expected results:
upgrade dnf and print dnf usage

Additional info:
Maybe it is related to upgrade of one of these packages:
system-python-3.5.1-15.fc26.x86_64
system-python-libs-3.5.1-15.fc26.x86_64

->

system-python-3.5.1-15.fc26.x86_64
system-python-libs-3.5.1-15.fc26.x86_64

but I'm reporting this against dnf as that's what is broken now.

Comment 1 Igor Gnatenko 2017-01-02 17:48:16 UTC
Please upgrade whole container, not just dnf.

*** This bug has been marked as a duplicate of bug 1409557 ***

Comment 2 Lukas Slebodnik 2017-01-02 17:55:20 UTC
(In reply to Igor Gnatenko from comment #1)
> Please upgrade whole container, not just dnf.
> 

Simpler workaround is to upgrade dnf and glibc.
BTW microdnf would not be affected by this bug; because it does not depend on python3.6 :-)
Maybe it's time to have both microdnf and dnf in rawhide base image :-)


Note You need to log in before you can comment on or make changes to this bug.