Bug 140961 - cisco vpnclient crashes tg3 driver
cisco vpnclient crashes tg3 driver
Status: CLOSED DUPLICATE of bug 73733
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-26 19:06 EST by Ryan Dooley
Modified: 2015-01-04 17:13 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-26 22:07:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ryan Dooley 2004-11-26 19:06:38 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020
Firefox/0.10.1

Description of problem:
Fedora Core 3: no updates
Kernel: 2.6.9-1.667(smp)
Cisco VPN client: 4.6.00 (0045)
Platform: Dell Dimension 8400

After a successful connect to a Cisco vpn concentrator, the tg3
interface dies with the following message in the kernel ring buffer:

Cisco Systems VPN Client Version 4.6.00 (0045) kernel module loaded
Badness in local_bh_enable at kernel/softirq.c:141
 [<02123b69>] local_bh_enable+0x34/0x57
 [<42deebb2>] handle_vpnup+0x70/0x162 [cisco_ipsec]
 [<42dee9e5>] interceptor_ioctl+0xdd/0x100 [cisco_ipsec]
 [<0226a263>] dev_ifsioc+0x41f/0x42b
 [<42dee908>] interceptor_ioctl+0x0/0x100 [cisco_ipsec]
 [<0226a594>] dev_ioctl+0x325/0x3b7
 [<0226187b>] sock_ioctl+0x60/0x2bc
 [<021634ae>] sys_ioctl+0x211/0x253
Badness in local_bh_enable at kernel/softirq.c:141
 [<02123b69>] local_bh_enable+0x34/0x57
 [<022683fa>] dev_remove_pack+0x5/0xa
 [<42deec03>] handle_vpnup+0xc1/0x162 [cisco_ipsec]
 [<42dee9e5>] interceptor_ioctl+0xdd/0x100 [cisco_ipsec]
 [<0226a263>] dev_ifsioc+0x41f/0x42b
 [<42dee908>] interceptor_ioctl+0x0/0x100 [cisco_ipsec]
 [<0226a594>] dev_ioctl+0x325/0x3b7
 [<0226187b>] sock_ioctl+0x60/0x2bc
 [<021634ae>] sys_ioctl+0x211/0x253
Debug: sleeping function called from invalid context at
net/core/dev.c:3086
in_atomic():0[expected: 0], irqs_disabled():1
 [<0211dbf3>] __might_sleep+0x7d/0x8a
 [<0226abf9>] synchronize_net+0x11/0x1b
 [<42deec03>] handle_vpnup+0xc1/0x162 [cisco_ipsec]
 [<42dee9e5>] interceptor_ioctl+0xdd/0x100 [cisco_ipsec]
 [<0226a263>] dev_ifsioc+0x41f/0x42b
 [<42dee908>] interceptor_ioctl+0x0/0x100 [cisco_ipsec]
 [<0226a594>] dev_ioctl+0x325/0x3b7
 [<0226187b>] sock_ioctl+0x60/0x2bc
 [<021634ae>] sys_ioctl+0x211/0x253
Badness in local_bh_enable at kernel/softirq.c:141
 [<02123b69>] local_bh_enable+0x34/0x57
 [<42deebb2>] handle_vpnup+0x70/0x162 [cisco_ipsec]
 [<42dee9e5>] interceptor_ioctl+0xdd/0x100 [cisco_ipsec]
 [<0226a263>] dev_ifsioc+0x41f/0x42b
 [<42dee908>] interceptor_ioctl+0x0/0x100 [cisco_ipsec]
 [<0226a594>] dev_ioctl+0x325/0x3b7
 [<0226187b>] sock_ioctl+0x60/0x2bc
 [<021634ae>] sys_ioctl+0x211/0x253
Badness in local_bh_enable at kernel/softirq.c:141
 [<02123b69>] local_bh_enable+0x34/0x57
 [<022683fa>] dev_remove_pack+0x5/0xa
 [<42deec03>] handle_vpnup+0xc1/0x162 [cisco_ipsec]
 [<42dee9e5>] interceptor_ioctl+0xdd/0x100 [cisco_ipsec]
 [<0226a263>] dev_ifsioc+0x41f/0x42b
 [<42dee908>] interceptor_ioctl+0x0/0x100 [cisco_ipsec]
 [<0226a594>] dev_ioctl+0x325/0x3b7
 [<0226187b>] sock_ioctl+0x60/0x2bc
 [<021634ae>] sys_ioctl+0x211/0x253
Debug: sleeping function called from invalid context at
net/core/dev.c:3086
in_atomic():0[expected: 0], irqs_disabled():1
 [<0211dbf3>] __might_sleep+0x7d/0x8a
 [<0226abf9>] synchronize_net+0x11/0x1b
 [<42deec03>] handle_vpnup+0xc1/0x162 [cisco_ipsec]
 [<42dee9e5>] interceptor_ioctl+0xdd/0x100 [cisco_ipsec]
 [<0226a263>] dev_ifsioc+0x41f/0x42b
 [<42dee908>] interceptor_ioctl+0x0/0x100 [cisco_ipsec]
 [<0226a594>] dev_ioctl+0x325/0x3b7
 [<0226187b>] sock_ioctl+0x60/0x2bc
 [<021634ae>] sys_ioctl+0x211/0x253
tg3: eth0: Link is down.
tg3: eth0: Link is up at 100 Mbps, full duplex.
tg3: eth0: Flow control is on for TX and on for RX.


Version-Release number of selected component (if applicable):
kernel-{smp-}2.6.9-1.667

How reproducible:
Always

Steps to Reproduce:
1. Download and install fedora core 3
2. Download and install cisco vpn client 4.6.00 (0045)
3. Connect to vpn
4. Connect to remote host, login and type say "ps"
    

Actual Results:  Interface crashed and tg3 reloads itself.

Expected Results:  tg3 should not crash.

Additional info:
Comment 1 Dave Jones 2004-11-26 22:07:27 EST
binary driver, with known problems. nothing we can do.
bug cisco.


*** This bug has been marked as a duplicate of 73733 ***

Note You need to log in before you can comment on or make changes to this bug.