Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1409610 - mod_perl-2.0.10-1.fc26 FTBFS: t/apache/read.t test fails
Summary: mod_perl-2.0.10-1.fc26 FTBFS: t/apache/read.t test fails
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mod_perl
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Pisar
QA Contact: Fedora Extras Quality Assurance
URL: https://apps.fedoraproject.org/kosche...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-02 15:32 UTC by Petr Pisar
Modified: 2017-01-20 15:20 UTC (History)
4 users (show)

Fixed In Version: mod_perl-2.0.10-2.fc26 mod_perl-2.0.10-2.fc25 mod_perl-2.0.10-2.fc24 mod_perl-2.0.10-2.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-13 02:23:35 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
CPAN 119685 0 None None None 2017-01-04 11:48:21 UTC
Debian BTS 849082 0 None None None 2017-01-04 11:36:58 UTC

Description Petr Pisar 2017-01-02 15:32:40 UTC
mod_perl-2.0.10-1.fc26 fails to build in F26 because some tests fail:

# Failed test 1 in t/apache/read.t at line 52
t/apache/read.t ......................... 
1..1
# Running under perl version 5.024000 for linux
# Current time local: Thu Dec 22 19:11:21 2016
# Current time GMT:   Thu Dec 22 19:11:21 2016
# Using Test.pm version 1.28_01
# Using Apache/Test.pm version 1.40
not ok 1
Failed 1/1 subtests 

A difference between passing and failig build root is:

gcc 	6.2.1-2.fc26 	> 	6.3.1-1.fc26
	httpd 	2.4.23-7.fc26 	> 	2.4.25-2.fc26
	httpd-devel 	2.4.23-7.fc26 	> 	2.4.25-2.fc26
	libgomp 	6.2.1-2.fc26 	> 	6.3.1-1.fc26
	libselinux 	2.5-13.fc26 	> 	2.5-14.fc26
	systemtap-sdt-devel 	3.1-0.20161212git... 	> 	3.1-0.20161220git...
	httpd-filesystem 	2.4.23-7.fc26 	> 	2.4.25-2.fc26
	libgcc 	6.2.1-2.fc26 	> 	6.3.1-1.fc26
	perl-Storable 	1:2.56-366.fc26 	> 	1:2.56-367.fc26
	gmp 	1:6.1.1-1.fc25 	> 	1:6.1.2-1.fc26
	openssl-libs 	1:1.1.0c-4.fc26 	> 	1:1.1.0c-5.fc26
	nghttp2 		> 	1.17.0-1.fc26
	httpd-tools 	2.4.23-7.fc26 	> 	2.4.25-2.fc26
	cpp 	6.2.1-2.fc26 	> 	6.3.1-1.fc26
	libev 		> 	4.23-1.fc26
	libstdc++ 	6.2.1-2.fc26 	> 	6.3.1-1.fc26
	python3-pyparsing 	2.1.5-2.fc25 	> 	2.1.5-3.fc26
	libtool-ltdl 	2.4.6-12.fc26 	> 	2.4.6-13.fc26
	python3 	3.5.2-7.fc26 	> 	3.6.0-0.6.rc1.fc26
	libuuid 	2.29-1.fc26 	> 	2.29-2.fc26
	glib2 	2.51.0-1.fc26 	> 	2.51.0-2.fc26
	python3-setuptools 	28.8.0-1.fc26 	> 	30.4.0-2.fc26
	system-python-libs 	3.5.2-7.fc26 	> 	3.6.0-0.6.rc1.fc26
	openssl 	1:1.1.0c-4.fc26 	> 	1:1.1.0c-5.fc26
	kernel-headers 	4.10.0-0.rc0.git4.1.... 	> 	4.10.0-0.rc0.git7.1....
	libmount 	2.29-1.fc26 	> 	2.29-2.fc26
	python3-pip 	9.0.1-1.fc26 	> 	9.0.1-3.fc26
	p11-kit-trust 	0.23.2-2.fc24 	> 	0.23.3-1.fc26
	p11-kit 	0.23.2-2.fc24 	> 	0.23.3-1.fc26
	nss-util 	3.27.0-2.fc26 	> 	3.28.0-2.fc26
	python3-libs 	3.5.2-7.fc26 	> 	3.6.0-0.6.rc1.fc26
	libbabeltrace 	1.5.0-1.fc26 	> 	1.5.0-2.fc26
	libsemanage 	2.5-8.fc26 	> 	2.5-9.fc26
	util-linux 	2.29-1.fc26 	> 	2.29-2.fc26
	libblkid 	2.29-1.fc26 	> 	2.29-2.fc26
	libfdisk 	2.29-1.fc26 	> 	2.29-2.fc26
	rpm-libs 	4.13.0-8.fc26 	> 	4.13.0-9.fc26
	iptables-libs 	1.6.0-2.fc25 	> 	1.6.0-3.fc26
	rpm-build 	4.13.0-8.fc26 	> 	4.13.0-9.fc26
	audit-libs 	2.7-1.fc26 	> 	2.7-2.fc26
	rpm-plugin-selinux 	4.13.0-8.fc26 	> 	4.13.0-9.fc26
	libpwquality 	1.3.0-6.fc25 	> 	1.3.0-7.fc26
	libstdc++-devel 	6.2.1-2.fc26 	> 	6.3.1-1.fc26
	system-python 	3.5.2-7.fc26 	> 	3.6.0-0.6.rc1.fc26
	gnupg2 	2.1.16-1.fc26 	> 	2.1.17-1.fc26
	rpm 	4.13.0-8.fc26 	> 	4.13.0-9.fc26
	gdb-headless 	7.12-29.fc26 	> 	7.12-31.fc26
	libcap-ng 	0.7.8-1.fc25 	> 	0.7.8-2.fc26
	libxml2 	2.9.3-4.fc25 	> 	2.9.4-1.fc26
	file 	5.29-1.fc26 	> 	5.29-2.fc26
	gcc-c++ 	6.2.1-2.fc26 	> 	6.3.1-1.fc26
	libsmartcols 	2.29-1.fc26 	> 	2.29-2.fc26
	rpm-build-libs 	4.13.0-8.fc26 	> 	4.13.0-9.fc26
	file-libs 	5.29-1.fc26 	> 	5.29-2.fc26

Comment 1 Petr Pisar 2017-01-02 16:14:07 UTC
This caused by upgrading httpd from 2.4.23-7.fc26 to 2.4.25-2.fc26.

Comment 2 Petr Pisar 2017-01-04 11:38:36 UTC
The new httpd was pushed into all Fedoras, Debian has patches.

Comment 3 Fedora Update System 2017-01-04 12:17:08 UTC
mod_perl-2.0.10-2.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-206cd7f7fb

Comment 4 Fedora Update System 2017-01-04 12:17:23 UTC
mod_perl-2.0.10-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2017-b79ea2eb1d

Comment 5 Fedora Update System 2017-01-04 13:02:28 UTC
mod_perl-2.0.10-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-f9389a34c7

Comment 6 Fedora Update System 2017-01-04 22:22:16 UTC
mod_perl-2.0.10-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-b79ea2eb1d

Comment 7 Fedora Update System 2017-01-04 23:29:32 UTC
mod_perl-2.0.10-2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-206cd7f7fb

Comment 8 Fedora Update System 2017-01-05 02:49:00 UTC
mod_perl-2.0.10-2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-f9389a34c7

Comment 9 Fedora Update System 2017-01-13 02:23:35 UTC
mod_perl-2.0.10-2.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2017-01-13 07:20:50 UTC
mod_perl-2.0.10-2.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2017-01-20 15:20:33 UTC
mod_perl-2.0.10-2.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.