Bug 1409613 - Cloudera image creation for Sahara fails - http://archive.cloudera.com/cdh5/redhat/7/x86_64/cdh/.0/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found
Summary: Cloudera image creation for Sahara fails - http://archive.cloudera.com/cdh5/r...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: sahara-image-elements
Version: 10.0 (Newton)
Hardware: x86_64
OS: Unspecified
unspecified
medium
Target Milestone: beta
: 11.0 (Ocata)
Assignee: Elise Gafford
QA Contact: Luigi Toscano
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-02 15:43 UTC by Chris Janiszewski
Modified: 2018-01-29 12:21 UTC (History)
6 users (show)

Fixed In Version: sahara-image-elements-6.0.0-6.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-17 19:53:59 UTC
cjanisze: needinfo-


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
Launchpad 1657482 None None None 2017-01-19 14:30:04 UTC

Description Chris Janiszewski 2017-01-02 15:43:09 UTC
Description of problem:
Cloudera image creation for Sahara fails - http://archive.cloudera.com/cdh5/redhat/7/x86_64/cdh/.0/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found

There seems to be an error on how link to repodata.xml is being generated .. please see the version in the link.

more output:
####################

+ install-packages -e
Nothing to uninstall
dib-run-parts Mon Jan  2 10:00:02 EST 2017 99-package-uninstalls completed
dib-run-parts Mon Jan  2 10:00:02 EST 2017 ----------------------- PROFILING -----------------------
dib-run-parts Mon Jan  2 10:00:02 EST 2017 
dib-run-parts Mon Jan  2 10:00:02 EST 2017 Target: pre-install.d
dib-run-parts Mon Jan  2 10:00:02 EST 2017 
dib-run-parts Mon Jan  2 10:00:02 EST 2017 Script                                     Seconds
dib-run-parts Mon Jan  2 10:00:02 EST 2017 ---------------------------------------  ----------
dib-run-parts Mon Jan  2 10:00:02 EST 2017 
dib-run-parts Mon Jan  2 10:00:02 EST 2017 00-check-java                                 0.002
dib-run-parts Mon Jan  2 10:00:02 EST 2017 00-dnf-update                                 0.002
dib-run-parts Mon Jan  2 10:00:02 EST 2017 00-fix-requiretty                             0.005
dib-run-parts Mon Jan  2 10:00:02 EST 2017 00-rhel-registration                         66.583
dib-run-parts Mon Jan  2 10:00:02 EST 2017 00-rhsm                                       0.002
dib-run-parts Mon Jan  2 10:00:02 EST 2017 00-usr-local-bin-secure-path                  0.004
dib-run-parts Mon Jan  2 10:00:02 EST 2017 01-dib-python                                 0.003
dib-run-parts Mon Jan  2 10:00:02 EST 2017 01-install-bin                                0.004
dib-run-parts Mon Jan  2 10:00:02 EST 2017 01-override-yum-arch                          0.002
dib-run-parts Mon Jan  2 10:00:02 EST 2017 01-yum-keepcache                              0.004
dib-run-parts Mon Jan  2 10:00:02 EST 2017 02-package-installs                           5.163
dib-run-parts Mon Jan  2 10:00:02 EST 2017 03-baseline-tools                             0.002
dib-run-parts Mon Jan  2 10:00:02 EST 2017 04-dib-init-system                            0.004
dib-run-parts Mon Jan  2 10:00:02 EST 2017 10-add-mirror                                 1.097
dib-run-parts Mon Jan  2 10:00:02 EST 2017 10-rhel-blacklist                             0.002
dib-run-parts Mon Jan  2 10:00:02 EST 2017 76-unlimited-security-artifacts               0.760
dib-run-parts Mon Jan  2 10:00:02 EST 2017 99-package-uninstalls                         0.033
dib-run-parts Mon Jan  2 10:00:02 EST 2017 
dib-run-parts Mon Jan  2 10:00:02 EST 2017 --------------------- END PROFILING ---------------------
dib-run-parts Mon Jan  2 10:00:02 EST 2017 Running /tmp/in_target.d/install.d/00-baseline-environment
Running install-packages install. Package list: iscsi-initiator-utils
Not loading "rhnplugin" plugin, as it is disabled
Not loading "product-id" plugin, as it is disabled
Loading "search-disabled-repos" plugin
Not loading "subscription-manager" plugin, as it is disabled
Config time: 0.032
Yum version: 3.4.3
rpmdb time: 0.000
Setting up Package Sacks
http://archive.cloudera.com/cdh5/redhat/7/x86_64/cdh/.0/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found
Trying other mirror.
To address this issue please refer to the below knowledge base article 

https://access.redhat.com/articles/1320623

If above article doesn't help to resolve this issue please open a ticket with Red Hat Support.

################################



Version-Release number of selected component (if applicable):
OSP10

How reproducible:
Every time

Steps to Reproduce:
1. yum install sahara-image-elements -y
2. download rhel7.qcow2 from CDN
3. sahara-image-create -p cloudera

Actual results:
failure: repodata/repomd.xml from cloudera-cdh5: [Errno 256] No more mirrors to try.

Expected results:
cloudera image created

Additional info:
Building MapR and Hortonworks image with the same method worked good.

Comment 1 Luigi Toscano 2017-01-02 15:48:34 UTC
Does it work if you specify the version of cloudera (-v 5.7) ?

Comment 2 Chris Janiszewski 2017-01-02 16:17:38 UTC
I have specified -v 5.5 and no longer got an error.
Maybe this is something that could be fixed in docs:
https://access.redhat.com/documentation/en/red-hat-openstack-platform/10/paged/%e2%81%a0openstack-data-processing/ Chapter 4 calls for specifying version with Hortonworks, but doesn't mention Cloudera

Comment 3 Luigi Toscano 2017-01-20 12:16:39 UTC
Hi, do you have some time to test the following patch?
https://review.openstack.org/#/c/423236/

Comment 9 Luigi Toscano 2017-03-29 21:49:32 UTC
No error when running 
$ sahara-image-create -p cloudera

Verified on:

sahara-image-elements-6.0.0-7.el7ost.noarch
diskimage-builder-1.27.1-0.20170302013848.65c6da5.el7ost.noarch
dib-utils-0.0.11-1.el7ost.noarch

Comment 10 errata-xmlrpc 2017-05-17 19:53:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.