Bug 1409615 - thermostat: FTBFS in Fedora Rawhide
Summary: thermostat: FTBFS in Fedora Rawhide
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: thermostat
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Severin Gehwolf
QA Contact: Fedora Extras Quality Assurance
URL: http://apps.fedoraproject.org/koschei...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-02 16:00 UTC by gil cattaneo
Modified: 2017-01-11 14:09 UTC (History)
4 users (show)

Fixed In Version: thermostat-1.6.4-5.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-11 14:09:45 UTC
Type: Bug


Attachments (Terms of Use)
rebuilt with netty3.10.6.Final (9.77 KB, patch)
2017-01-02 16:00 UTC, gil cattaneo
no flags Details | Diff

Description gil cattaneo 2017-01-02 16:00:54 UTC
Created attachment 1236670 [details]
rebuilt with netty3.10.6.Final

Description of problem:
Package thermostat fails to build from source in Fedora Rawhide.

Because of "Package resolution failed	No package found for: osgi(org.jboss.netty) = 3.9.3"

Version-Release number of selected component (if applicable):
1.6.4-4.fc26

Steps to Reproduce:
koji build --scratch f26 thermostat-1.6.4-4.fc26.src.rpm

Additional info:
This package is tracked by Koschei. See:
http://apps.fedoraproject.org/koschei/package/thermostat

About the patch:
- improve maven macros
- minor changes to adapt to current guideline

Task info: https://koji.fedoraproject.org/koji/taskinfo?taskID=17149520

Comment 1 Severin Gehwolf 2017-01-05 22:33:14 UTC
Thanks for the patch!

I've pushed a build with just the netty3 version update since we collect other changes upstream. I'll be sure to include them in an upcoming update.

https://koji.fedoraproject.org/koji/taskinfo?taskID=17171480


Note You need to log in before you can comment on or make changes to this bug.