Bug 140963 - Logitech MX 1000 mouse: xorg does not see all 12 buttons
Logitech MX 1000 mouse: xorg does not see all 12 buttons
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-26 19:12 EST by Sergey V. Udaltsov
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-27 04:36:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sergey V. Udaltsov 2004-11-26 19:12:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
I plugged in Logitech MX 1000 mouse. Xorg server does not distinguish
some of its buttons. xev shows button numbers up to 5 - the side
buttons do not work. There is a discussion here:
http://www.linux-gamers.net/modules/wfsection/print.php?articleid=46.
I tried the approach described there (writing 12 buttons and other
options into xorg.conf) - but found that protocol "evdev" is not
supported.

xorg server would need ability to work with "evdev" Protocol directly
(there are some patches mentioned on that page).

Version-Release number of selected component (if applicable):
xorg-x11-6.8.1-12.FC3.1

How reproducible:
Always

Steps to Reproduce:
1. Plug in Logitech MX 1000 mouse (USB port)
2. Configure xorg.conf to use 12 buttons 
3. xmodmap -e "pointer = 1 2 3 6 7 8 9 10 11 12 4 5"

    

Actual Results:  xmodmap says it only sees 7 buttons, so cannot map 12
of them

Expected Results:  swapping buttons 11/12 and 4/5
Comment 1 Mike A. Harris 2004-11-27 04:36:50 EST
X11 does not support 12 buttons at all.  It supports up to 7 buttons
maximum, and scroll wheels and similar devices generally count and
work like 2 individual buttons.

As such, this is not a bug, but a hard coded limitation in the
X server, and possibly in the protocol itself.

If you have a device which has 7 or less buttons, including the
scroll wheels and similar gizmos, and some or all of the extra
buttons do not work, you may be able to get them to work by
editing various config file options documented in the appropriate
manpages.  Other devices however may simply not have driver support
for the special buttons on some pointing devices.  That is also
not a bug, but rather lack of a feature, either in the X.Org
mouse driver, or the kernel input drivers, or both.

In any case, with the current X server framework, it is only
possible to have a maximum of 7 buttons.

The proper place for these limitations to be overcome in the
future, is in upstream enhancements to the X.Org drivers,
the server, the X11 protocol, and the Linux kernel.  You can
file a bug report as a feature enhancement request in the
X.Org bugzilla at:  http://bugs.freedesktop.org in the xorg
component in order to track this if you like.  Someone may
be able to enhance the X mouse driver to handle some of the
extra buttons on some pointing devices out there, however
a proper long term solution that works with all buttons on
all devices will require some much larger future upstream
X server and driver development, which is outside the scope
of what we track in our bugzilla.

I also recommend discussing this on the xorg@freedesktop.org
mailing list if you're interested in the developmental aspects
of solving the bigger problem described above.

I'm closing this as "NOTABUG" as it is an X server/protocol
limitation, as well as potentially lack of hardware support
in the kernel and/or X drivers, and not a bug.

Comment 2 Sergey V. Udaltsov 2004-11-27 10:27:41 EST
Created a but against xorg:

https://bugs.freedesktop.org/show_bug.cgi?id=1947

Also, I am a bit surprised why the page I mentioned describes some
operations with 12-button mouse as real. Do they cheat, I wonder?...
Comment 3 Alessandro Polverini 2005-04-23 03:04:11 EDT
Seems like this is fixed in latest xorg, someone can confirm?
Comment 4 Sergey V. Udaltsov 2005-04-23 21:08:43 EDT
Well at least latest rpm for fc3 (xorg-x11-6.8.2-1.FC3.13) - still breaks at
xmodmap with the same error.
Comment 5 Mike A. Harris 2005-04-24 16:13:04 EDT
X11R7 will be the first X.Org X11 release to support more than
7 buttons on devices of this nature by using the "evdev" input
driver.  Fedora Core 5 will probably be the first OS release
to come with the "evdev" driver.

Note You need to log in before you can comment on or make changes to this bug.