Bug 140969 - bad interaction between hide all windows and gkrellm
bad interaction between hide all windows and gkrellm
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-26 23:13 EST by Suchandra Thapa
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-21 00:46:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Suchandra Thapa 2004-11-26 23:13:32 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
This may or may not be considered a bug but it looks like one.  If
gkrellm is set so that it doesn't appear in the gnome-panel, clicking
on the hide all windows button and starting another application in the
same workspace effectively loses the gkrellm window.  The only
recourse is to kill gkrellm and restart it.

I believe that this would apply to any other application that don't
appear in the gnome-panel or in the dock.  I'm not sure whether this
can be considered a bug but it is unexpected behavior.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. run gkrellm and change the configuration so that it does not show
up in the gnome-panel
2. click on hide all windows button
3. start another application in the same workspace
4. gkrellm is no longer visible and can't be made visible using the
hide all windows button
    

Additional info:
Comment 1 Havoc Pennington 2004-12-21 00:46:02 EST
The bug in my mind is the config option for "don't show up in the
gnome panel" - but I doubt the gkrellm people are interested in fixing
it to "just work" since half gkrellm's appeal is the ability to
micromanage all its details.

Since gkrellm, and this gkrellm option, are basically "tweaker"
functionality I think it's OK to solve this by telling you the trick:
Alt+Tab.

Another approach is to set gkrellm to be a dock or desktop window
type, which will also result in not being in the taskbar but then
gkrellm would not be minimized when doing "show desktop"

Anyhow, no way to fix this without removing the config option
silliness from gkrellm.

Note You need to log in before you can comment on or make changes to this bug.