Bug 1409695 - 'rhui haproxy delete' reports success but doesn't delete the haproxy or is --force the required option?
Summary: 'rhui haproxy delete' reports success but doesn't delete the haproxy or is --...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Update Infrastructure for Cloud Providers
Classification: Red Hat
Component: Tools
Version: 3.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: 3.0.7
: 3.0.x
Assignee: RHUI Bug List
QA Contact: Vratislav Hutsky
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-03 03:11 UTC by Irina Gulina
Modified: 2019-01-23 18:05 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-23 18:05:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0149 0 None None None 2019-01-23 18:05:17 UTC

Description Irina Gulina 2017-01-03 03:11:08 UTC
Description of problem:
 'rhui haproxy delete' reports success but doesn't delete the haproxy or is --force the required option? No Halting msg then as for CDS removing.

Version-Release number of selected component (if applicable):
20161220

How reproducible:
always

Steps to Reproduce:
1. rhui haproxy delete hostname
2.
3.

Actual results:
>> rhui haproxy delete hap01.example.com

------------------------------------------------------------------------------
>> echo $?
0
>> rhui haproxy list

-= RHUI HAProxy Load-balancers =-

  Hostname:             hap01.example.com
  SSH Username:         ec2-user
  SSH Private Key:      /root/.ssh/id_rsa_rhua

>> rhui haproxy delete hapr01.example.com --help
  optional arguments:
  -h, --help   show this help message and exit
  -f, --force  Delete the system, even if it is the last of its kind.

Meanwhile for 'rhui cds delete': 
>> rhui cds delete cds01.example.com
Halting: --force is not on and this will remove all instances.

Resolution: 
1. Add 'Halting' as for cds removing
2. Maybe change Halting msg "this will remove all instances." with "this will remove the last of its kind" both for CDS and Haproxy?
3. Put 'required' tag on '--force'?

Comment 3 Radek Bíba 2017-10-24 11:50:35 UTC
The specified haproxy isn't deleted (and, most importantly, unconfigured) even if it's not the only one, and -f doesn't help. The command completes very quicky, and although I haven't debugged it, I just think it doesn't do anything for some reason. It takes much more time in the interactive mode of rhui-manager.

Comment 7 errata-xmlrpc 2019-01-23 18:05:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0149


Note You need to log in before you can comment on or make changes to this bug.