Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1409704 - PCP support for vCPU hotplug/unplug
Summary: PCP support for vCPU hotplug/unplug
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pcp
Version: 7.3
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Nathan Scott
QA Contact: Miloš Prchlík
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-03 04:36 UTC by Mark Goodwin
Modified: 2017-08-01 18:29 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 18:29:33 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1968 0 normal SHIPPED_LIVE pcp bug fix and enhancement update 2017-08-01 18:09:55 UTC

Description Mark Goodwin 2017-01-03 04:36:46 UTC
Description of problem: pmdalinux should support CPU hotplug/unplug for KVM guests

Steps to Reproduce:
1. setup a qemu/kvm guest (RHEL6.5 or later) with 2 vCPUs and provisioned for 4 vCPUs
2. boot guest
3. use virt-manager to hotplug 2 more vCPUs

Actual results: guest pmdalinux CPU indom stays at 2 vCPUS

Expected results: guest pmdalinux CPU indom should be dynamic

Additional info: vCPU hot-unplug doesn't seem to be supported (not yet anyway on my sandybridge host running f25), but that should be accommodated too.

Comment 1 Nathan Scott 2017-01-19 06:29:43 UTC
This is resolved by upstream commit bfe5828499e.

Comment 3 Miloš Prchlík 2017-06-13 11:59:06 UTC
Verified with build pcp-3.11.8-5.el7.

Comment 4 errata-xmlrpc 2017-08-01 18:29:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1968


Note You need to log in before you can comment on or make changes to this bug.