Bug 1409744 - Update wxWidgets to 3.1.0
Summary: Update wxWidgets to 3.1.0
Keywords:
Status: CLOSED DUPLICATE of bug 1417646
Alias: None
Product: Fedora
Classification: Fedora
Component: mingw-wxWidgets
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Thomas Sailer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-03 08:39 UTC by Jan Niklas Hasse
Modified: 2017-02-13 12:22 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-30 14:10:35 UTC


Attachments (Terms of Use)
spec file patch. Bumps the version number, adds new files, removes no longer needed patches (13.09 KB, patch)
2017-01-03 08:39 UTC, Jan Niklas Hasse
no flags Details | Diff

Description Jan Niklas Hasse 2017-01-03 08:39:10 UTC
Created attachment 1236803 [details]
spec file patch. Bumps the version number, adds new files, removes no longer needed patches

This updates the wxWidgets version of mingw-wxWidgets packages to 3.1.0. I've tested the library files and created a sample (wxWidgets 3) application which worked fine on Windows.

I'm new to working with RPMs and Fedora, I hope creating a bug report is the right way to request this change.

Comment 1 Thomas Sailer 2017-01-30 11:34:32 UTC
Mainline packages wxWidgets 3 as separate package (wxBase3 vs. wxBase). So this should be done in mingw too. Are you packager (i.e. fas account, etc)? So can you rename your package to mingw-wxWidgets3 and submit a new review? I can then review it...

Comment 2 Jan Niklas Hasse 2017-01-30 12:23:41 UTC
I'm not a packager, but I have a fas account: jhasse

Comment 3 Thomas Sailer 2017-01-30 14:10:35 UTC

*** This bug has been marked as a duplicate of bug 1417646 ***


Note You need to log in before you can comment on or make changes to this bug.