Bug 140977 - wrong sys_lib_search_path_spec in /usr/bin/libtool
wrong sys_lib_search_path_spec in /usr/bin/libtool
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: libtool (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexandre Oliva
David Lawrence
:
: 143889 145920 (view as bug list)
Depends On:
Blocks: 137160
  Show dependency treegraph
 
Reported: 2004-11-27 05:11 EST by Joe Orton
Modified: 2007-11-30 17:07 EST (History)
6 users (show)

See Also:
Fixed In Version: RHBA-2005-234
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-09 08:27:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Orton 2004-11-27 05:11:26 EST
Description of problem:
The sys_lib_search_path_spec in /usr/bin/libtool references the wrong
version of GCC.

This seems to mean at least that it can't build shared C++ libraries.

Version-Release number of selected component (if applicable):
gcc-3.4.3-3.EL4
libtool-1.5.6-4

How reproducible:
always

Steps to Reproduce:
$ echo 'void foo(void) {}' > foo.cpp
$ /usr/bin/libtool --mode=compile --tag=CXX g++ -c foo.cpp
 g++ -c foo.cpp  -fPIC -DPIC -o .libs/foo.o
 g++ -c foo.cpp -o foo.o >/dev/null 2>&1
$ /usr/bin/libtool --mode=link --tag=CXX g++ -o libfoo.la -rpath
/usr/lib foo.lo
g++ -shared -nostdlib
/usr/lib/gcc/i386-redhat-linux/3.4.1/../../../crti.o
/usr/lib/gcc/i386-redhat-linux/3.4.1/crtbeginS.o  .libs/foo.o 
-L/usr/lib/gcc/i386-redhat-linux/3.4.1
-L/usr/lib/gcc/i386-redhat-linux/3.4.1/../../.. -lstdc++ -lm -lc
-lgcc_s /usr/lib/gcc/i386-redhat-linux/3.4.1/crtendS.o
/usr/lib/gcc/i386-redhat-linux/3.4.1/../../../crtn.o  -Wl,-soname
-Wl,libfoo.so.0 -o .libs/libfoo.so.0.0.0
g++: /usr/lib/gcc/i386-redhat-linux/3.4.1/../../../crti.o: No such
file or directory
g++: /usr/lib/gcc/i386-redhat-linux/3.4.1/crtbeginS.o: No such file or
directoryg++: /usr/lib/gcc/i386-redhat-linux/3.4.1/crtendS.o: No such
file or directory
g++: /usr/lib/gcc/i386-redhat-linux/3.4.1/../../../crtn.o: No such
file or directory

Mitigating circumstances:
Usually libtool is used by creating a new libtool script not the
pre-built one, it's only the pre-built one which suffers from this issue.

Recommend to just rebuild libtool-1.5.6 for RHEL4.
Comment 1 Daniel Reed 2005-01-03 18:12:43 EST
*** Bug 143889 has been marked as a duplicate of this bug. ***
Comment 2 Jairo Medina 2005-01-18 11:55:47 EST
Can you release a rebuilt rpm fixing this problem for FC3 ?
I have an application that compiles in other distributions but not in FC3.

Thanks,
Comment 3 Joe Orton 2005-02-09 09:06:06 EST
*** Bug 145920 has been marked as a duplicate of this bug. ***
Comment 4 Antonio Zugaldia 2005-03-03 04:35:16 EST
I think that this issue is connected with Bug 138742, that has also problems in
the sys_lib_search_path_spec variable in the generated libtool.

At least I get the same errors when trying to compile packages in RHEL 4 in x86_64:

/usr/lib/libpopt.so: could not read symbols: File in wrong format

I haven't been able to install the binary packages from Rawhide in RHEL, neither
to build the source packages.
Comment 5 Jay Turner 2005-04-16 13:50:56 EDT
Fix confirmed with libtool-1.5.6-4.EL4.1 which will be released as part of
RHBA-2005:234.  Moving to PROD_READY.
Comment 6 Tim Powers 2005-06-09 08:27:44 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-234.html

Note You need to log in before you can comment on or make changes to this bug.