Bug 1409799 - NFS Server is not coming up for the 3.8 volume after updating to 3.9
Summary: NFS Server is not coming up for the 3.8 volume after updating to 3.9
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: GlusterFS
Classification: Community
Component: nfs
Version: mainline
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Atin Mukherjee
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-03 12:50 UTC by Atin Mukherjee
Modified: 2017-01-04 12:07 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1409782
Environment:
Last Closed: 2017-01-03 16:48:21 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Atin Mukherjee 2017-01-03 12:52:07 UTC
Bug description:

gNFS Server is not coming up for the 3.8 volume after updating to  3.9.

I had two nodes cluster in 3.8 with Dis-Rep ( 2*2 ) volume and done the upgrade to 3.9.

After updating all cluster nodes, bumped up the cluster op-version to 30901 and checked the volume status, in v status, NFS Server was showing N/A.

Comment 2 Worker Ant 2017-01-03 12:53:59 UTC
REVIEW: http://review.gluster.org/16316 (glusterd: restart all daemons on volume dict change in op-version bump) posted (#1) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 3 Worker Ant 2017-01-03 13:31:13 UTC
REVIEW: http://review.gluster.org/16316 (glusterd: restart all daemons on volume dict change in op-version bump) posted (#2) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 4 Atin Mukherjee 2017-01-03 16:48:21 UTC
This is not a bug as in case of an upgrade user has to explicitly enable gNFS to bring back the service up. Closing this now.


Note You need to log in before you can comment on or make changes to this bug.