Bug 1409801 - Wired networking not working on Dell Latitude 3350
Summary: Wired networking not working on Dell Latitude 3350
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 27
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-03 13:02 UTC by Ferry
Modified: 2019-01-09 12:54 UTC (History)
10 users (show)

Fixed In Version: kernel-4.15.3-300.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-06 14:55:46 UTC
Type: Bug


Attachments (Terms of Use)
Output from dmesg (69.77 KB, text/plain)
2017-09-08 04:20 UTC, Shaun Assam
no flags Details
Kernel config files with ACPI_REV_OVERRIDE enabled (35.94 KB, application/x-xz)
2017-12-26 18:20 UTC, Shaun Assam
no flags Details

Description Ferry 2017-01-03 13:02:36 UTC
Description of problem:

Wired network is not working on a Dell Latitude 3350.

Version-Release number of selected component (if applicable):

Tried multiple kernels, the latest being 4.8.15-200.fc24.x86_64

How reproducible:

Boot Fedora 24 (and probably 25) on a Dell Latitude 3350. Notice wired network isn't working.

Actual results:

No network

Expected results:

Network

Additional info:

The issue seems to stem from the BIOS assigning an reserved IRQ to the device. Information by someone more knowledgeable on the topic than me (as well as patch) here:
https://patchwork.kernel.org/patch/9423907/

I can confirm the acpi_rev_override kernel parameter fixes the issue on Ubuntu. From what I got in other bugs the CONFIG_ACPI_REV_OVERRIDE_POSSIBLE option has been removed from Fedora kernels since 4.4 as the sound issues it resolved on the Dell XPS 13 were (somewhat) resolved since then (opinions seem to differ) and it was considered only useful for that issue.

We can get around it by using the parameters 'noapic acpi=off', but that seems to turn off way more stuff than the acpi_rev_override parameter would, which just seems to change the ACPI revision reported to the BIOS for the OS.

Thanks for whatever support provided and the best wishes for the new year!

Comment 1 Justin M. Forbes 2017-04-11 14:46:07 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There are a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 24 kernel bugs.

Fedora 25 has now been rebased to 4.10.9-100.fc24.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 26, and are still experiencing this issue, please change the version to Fedora 26.

If you experience different issues, please open a new bug report for those.

Comment 2 Justin M. Forbes 2017-04-28 17:19:26 UTC
*********** MASS BUG UPDATE **************
This bug is being closed with INSUFFICIENT_DATA as there has not been a response in 2 weeks. If you are still experiencing this issue, please reopen and attach the 
relevant data from the latest kernel you are running and any data that might have been requested previously.

Comment 3 Shaun Assam 2017-09-08 04:20:10 UTC
Created attachment 1323565 [details]
Output from dmesg

dmesg output of Fedora 26 kernel 4.12.9-300.fc26.x86_64

Comment 4 Shaun Assam 2017-09-08 04:53:25 UTC
Dell Latitude 3350 shows the following errors when booting on Fedora 26 with kernel 4.12.9-300.fc26.x86_64:

[    1.972457] pci 0000:00:1c.2: Error enabling bridge (-16), continuing
[    1.973304] r8169 0000:03:00.0 (unnamed net_device) (uninitialized): enable failure

This happens with any kernel from Fedora 25 and 26. Can use any of the following kernel parameters as a workaround: acpi=noirq, noapic and nolapic. I've tried the acpi_rev_override parameter and did a cold reboot twice in a row, unfortunately that didn't work for me. The system's BIOS/firmware is the latest version, A10.

This error does not appear with CentOS 7.3 kernel 3.10.0-514 or elrepo's mainline kernel (currently kernel-ml-4.12.10-1). Can we please re-open this bug to prevent this issue with future Fedora kernel releases?

Comment 5 Shaun Assam 2017-09-23 18:15:18 UTC
This is still an issue on Fedora 26 with kernel 4.12.14-300.fc26.x86_64. This bug should be re-open and changed to Fedora 26.

Comment 6 Shaun Assam 2017-10-03 14:04:57 UTC
This is still an issue on Fedora 26 with kernel 4.13.4-200.fc26.x86_64. This bug should be re-open for Fedora 26.

Comment 7 Ferry 2017-11-21 11:47:34 UTC
Hi

any news on this?

This parameter is useful for quite a bit of hardware issues. Unfortunately vendors still write not-too-shavvy-firmware. Having Linux report the same ACPI revision as Windows solves quite a few problems with BIOS/(U)EFI's otherwise doing weird stuff (like assigning IRQ's to devices that were already granted exclusively to other devices, or configuring the audio as HDA instead of I2C, etc.).

I personally don't see any security implications or other issues which would justify removing this option because it was only deemed useful for a certain soundcard issue at one time. It frequently has use and the possibility to use it out of the box would certainly aid Fedora.

Comment 8 Shaun Assam 2017-11-26 18:31:21 UTC
The issue is present on Fedora 27 with kernel 4.13.15-300.fc27.x86_64

I've tried the following kernel parameters with Fedora 27 to help troubleshoot the issue, and to see if they might work:

acpi_rev_override=5
acpi_osi='!Windows 2016'
acpi=force

Unfortunately they didn't work, even after doing two cold reboots.

Updating ticket to reflect the above.

Comment 9 Ferry 2017-11-28 16:55:49 UTC
Hi Shaun,

those won't work indeed, Fedora doesn't have the options enabled in the kernel, so the parameters aren't going to do anything.

[ferry@bcld-builder3 boot]$ grep -i override config-4.13.13-300.fc27.x86_64 
# CONFIG_ACPI_REV_OVERRIDE_POSSIBLE is not set

Comment 10 Ferry 2017-11-29 10:53:30 UTC
Hey Shaun,

out of interest, could you test if kernel parameter

pci=assign-busses

helps?

I don't have a system to test with unfortunately.

Comment 11 Shaun Assam 2017-11-29 14:55:19 UTC
Hi Ferry,

Thanks for the info in comment #9 -- I learned something new today.

I tried the pci=assign-busses parameter but unfortunately it didn't work. I'm still getting the errors in comment #4.

Comment 12 Shaun Assam 2017-12-26 18:20:46 UTC
Created attachment 1372550 [details]
Kernel config files with ACPI_REV_OVERRIDE enabled

Comment 13 Shaun Assam 2017-12-26 18:23:04 UTC
I can confirm this issue can be resolved by turning on the ACPI_REV_OVERRIDE option in the kernel config files for i686 and x86_64. Currently the
configuration is set to:

# CONFIG_ACPI_REV_OVERRIDE_POSSIBLE is not set

By changing it to:

CONFIG_ACPI_REV_OVERRIDE_POSSIBLE=y

The following boot errors no longer occur:

[    1.972457] pci 0000:00:1c.2: Error enabling bridge (-16),
continuing
[    1.973304] r8169 0000:03:00.0 (unnamed net_device) (uninitialized):
enable failure

In addition to fixing the ethernet issue, it also fixes an issue with
the Bluetooth device on the laptop automatically switching on after
shutdown/reboot (not when resuming from sleep/hibernate). The Bluetooth
icon would appear in the GNOME System Menu and would have to manually
be turned off. Since applying the ACPI_REV fix, this is no longer a
problem. I have been testing this change for the last three days and
have not encountered any issues resulting from this fix.

The issue regarding this bug has been patched in the upstream kernel
for sometime and is already included in the code for current versions
of the Fedora kernel (see drivers/acpi/blacklist.c for details -- the
code applies to Dell laptops/computers). 

I would like to request this fix be included in future Fedora kernel
releases so we may close this bug and possibly fix other, opened, bugs
related to this configuration.

I have submitted this fix to the Fedora Kernel mailing list.

Comment 14 Shaun Assam 2018-02-11 21:57:26 UTC
ACPI_REV_OVERRIDE is turned on by default and this bug is resolved as of kernel 4.15.2-300.fc27. Setting ticket status to CLOSED.

Comment 15 Andre Robatino 2018-02-11 22:02:09 UTC
Just noting that 4.15.2-300.fc27 isn't stable (or even in testing) so this isn't fixed yet.

Comment 16 Shaun Assam 2018-02-11 22:06:49 UTC
Sorry for jumping ahead on this one. I'll re-open it until 4.15.2-300.fc27 is in stable.

Comment 17 Shaun Assam 2018-03-06 14:55:46 UTC
As of kernel 4.15.3-300.fc27 this issue is resolved. Closing ticket.


Note You need to log in before you can comment on or make changes to this bug.