Bug 1409830 - After installing LBaaS in OSP10 , both v1 and v2 tabs show up in horizon [NEEDINFO]
Summary: After installing LBaaS in OSP10 , both v1 and v2 tabs show up in horizon
Keywords:
Status: CLOSED DUPLICATE of bug 1368601
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron-lbaas-ui
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 10.0 (Newton)
Assignee: belharar
QA Contact: Toni Freger
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-03 14:48 UTC by Jeremy
Modified: 2020-06-11 13:10 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-19 12:00:54 UTC
Target Upstream Version:
jmelvin: needinfo? (belharar)
jmelvin: needinfo? (belharar)


Attachments (Terms of Use)
showing both lbaas tabs (21.23 KB, image/png)
2017-01-03 14:48 UTC, Jeremy
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1653723 0 None None None 2017-01-03 15:01:17 UTC

Description Jeremy 2017-01-03 14:48:01 UTC
Created attachment 1236908 [details]
showing both lbaas tabs

Description of problem: After installing v2 lbaas and neutron-lbaas-ui package in OSP10 we see 2 lbaas tabs. one for v1 and v2. Will attach a screenshot of the issue.


Version-Release number of selected component (if applicable):
openstack-neutron-lbaas-9.1.0-1.el7ost.noarch               Mon Dec 12 18:32:47 2016
openstack-neutron-lbaas-ui-1.0.0-1.el7ost.noarch           

How reproducible:
100

Steps to Reproduce:
1.https://access.redhat.com/solutions/2837871
2.
3.

Actual results:
v1 and v2 lbaas dashboard tabs

Expected results:
only v2 dashboard tab

Additional info:

Comment 8 Jeremy 2017-03-02 18:09:54 UTC
We figured out we can set /etc/openstack/local_settings enable_lb false; restart httpd to get rid of the lbaas v1 tab and leave only the v2 tab

seems v2 lbaas does not work in horizon, so customer has to use cli which isn't a good option. This may also be tracked in:

https://bugs.launchpad.net/neutron-lbaas-dashboard/+bug/1629258
https://bugzilla.redhat.com/show_bug.cgi?id=1368601

Comment 9 Nir Magnezi 2017-06-19 12:00:54 UTC

*** This bug has been marked as a duplicate of bug 1368601 ***


Note You need to log in before you can comment on or make changes to this bug.