Bug 1409842 - perl-String-Diff-0.07-3.fc26 FTBFS: tests fail with YAML 1.21
Summary: perl-String-Diff-0.07-3.fc26 FTBFS: tests fail with YAML 1.21
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-String-Diff
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jan Pazdziora
QA Contact: Fedora Extras Quality Assurance
URL: https://apps.fedoraproject.org/kosche...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-03 15:25 UTC by Petr Pisar
Modified: 2017-02-16 09:12 UTC (History)
5 users (show)

Fixed In Version: perl-String-Diff-0.07-5.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-16 09:12:24 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github yappo p5-String-Diff issues 6 0 None None None 2017-01-03 15:25:42 UTC

Description Petr Pisar 2017-01-03 15:25:42 UTC
perl-String-Diff-0.07-3.fc26 fails to build in F26 because tests fail:

t/01_export.t ........... ok
#   Failed test at t/02_diff_fully-pp.t line 16.
#     Structures begin differing at:
#          $got->[1] = undef
#     $expected->[1] = ARRAY(0x1f0bee0)
# Looks like you failed 1 test of 13.
t/02_diff_fully-pp.t .... 
Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/13 subtests 
#   Failed test at t/02_diff_fully.t line 15.
#     Structures begin differing at:
#          $got->[1] = undef
#     $expected->[1] = ARRAY(0x2630018)
# Looks like you failed 1 test of 13.
t/02_diff_fully.t ....... 
Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/13 subtests 

This is caused by upgrading perl-YAML from 1.20-1.fc26 to 1.21-1.fc26 and Debian provided a patch in its bug tracker.

Comment 2 Jan Pazdziora 2017-01-11 10:47:11 UTC
Do you propose to wait for new upstream release, or make fix in Fedora with the patch?

Comment 3 Petr Pisar 2017-01-11 11:02:46 UTC
It's only matter of tests, so the modules are fine and it does not affect users. But there will be Fedora 26 mass rebuild, so it would be great to fix it before the mass rebuild. Provided upstream has not yet responded for (more than two weeks), I would go with patching Fedora.


Note You need to log in before you can comment on or make changes to this bug.