Bug 1409848 - Repeated logging of nfs related errors in glusterd log
Summary: Repeated logging of nfs related errors in glusterd log
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhgs-server-container
Version: cns-3.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Raghavendra Talur
QA Contact: Anoop
URL:
Whiteboard:
Depends On:
Blocks: 1385250
TreeView+ depends on / blocked
 
Reported: 2017-01-03 15:52 UTC by Raghavendra Talur
Modified: 2019-01-24 14:35 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Known Issue
Doc Text:
The following two lines might be repeatedly logged in rhgs-server-docker container/gluster container logs. [MSGID: 106006] [glusterd-svc-mgmt.c:323:glusterd_svc_common_rpc_notify] 0-management: nfs has disconnected from glusterd. [socket.c:701:__socket_rwv] 0-nfs: readv on /var/run/gluster/1ab7d02f7e575c09b793c68ec2a478a5.socket failed (Invalid argument) These logs come up because glusterd is not able to start nfs service. There is no functional impact as nfs export is not supported in through containerized gluster.
Clone Of:
Environment:
Last Closed: 2019-01-24 14:35:45 UTC


Attachments (Terms of Use)

Description Raghavendra Talur 2017-01-03 15:52:43 UTC
Description of problem:

The following three lines are continuously logged at 2 minutes interval. 


[2017-01-02 04:33:36.729574] I [MSGID: 106006] [glusterd-svc-mgmt.c:323:glusterd_svc_common_rpc_notify] 0-management: nfs has disconnected from glusterd.
[2017-01-02 04:34:30.737762] W [socket.c:701:__socket_rwv] 0-nfs: readv on /var/run/gluster/1ab7d02f7e575c09b793c68ec2a478a5.socket failed (Invalid argument)
The message "I [MSGID: 106006] [glusterd-svc-mgmt.c:323:glusterd_svc_common_rpc_notify] 0-management: nfs has disconnected from glusterd." repeated 39 times between [2017-01-02 04:33:36.729574] and [2017-01-02 04:35:33.747552]




How reproducible:
Always


Steps to Reproduce:
1. start rhgs-server-docker container
2. /var/log/glusterfs/etc-glusterfs-glusterd.vol.log

Actual results:
The above mentioned log lines are found in log file.


Expected results:
These logs should not be present.

Comment 3 Raghavendra Talur 2017-01-05 12:39:57 UTC
I had used " rhgs-server-docker container/gluster container" because I am not aware of standard terminology used to refer to gluster container. If there is a standard term for it, use that.

Everything else looks good.


Note You need to log in before you can comment on or make changes to this bug.