Bug 1409856 - Mirror on sync does not properly remove catalog entries from 'on_demand' repos
Summary: Mirror on sync does not properly remove catalog entries from 'on_demand' repos
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Pulp
Version: 6.2.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Bruno Rocha
URL:
Whiteboard:
Depends On:
Blocks: 1426408
TreeView+ depends on / blocked
 
Reported: 2017-01-03 16:10 UTC by Justin Sherrill
Modified: 2021-04-06 17:53 UTC (History)
17 users (show)

Fixed In Version: pulp-2.8.7.7-1,pulp-rpm-2.8.7.9-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1426408 (view as bug list)
Environment:
Last Closed: 2017-05-01 13:57:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Pulp Redmine 2503 0 High CLOSED - CURRENTRELEASE remove_missing does not seem to remove on_demand catalog entries 2017-02-23 21:01:57 UTC
Pulp Redmine 2542 0 Normal CLOSED - CURRENTRELEASE Streamer needs to try all available catalog entries. 2017-02-23 21:01:48 UTC
Pulp Redmine 2646 0 Normal CLOSED - COMPLETE Backport #2542, Streamer needs to try all available catalog entries 2017-03-30 23:09:50 UTC
Pulp Redmine 2647 0 Normal CLOSED - COMPLETE Backport #2503, remove_missing does not remove on_demand catalog entries 2017-03-30 23:09:31 UTC
Red Hat Product Errata RHBA-2017:1191 0 normal SHIPPED_LIVE Satellite 6.2.9 Async Bug Release 2017-05-01 17:49:42 UTC

Description Justin Sherrill 2017-01-03 16:10:58 UTC
Description of problem:

When a repo is configured to use mirror on sync for a repo and that repo is using on_demand as a download policy, if the rpm is removed from the upstream repo pulp will still think it can be downloaded from there because it hasn't removed the catalog entries.


Version-Release number of selected component (if applicable):
6.2.6

How reproducible:
Always

Steps to Reproduce:
1.  Create two yum repos on some webserver:  

mkdir /var/www/html/pub/repoA
mkdir /var/www/html/pub/repoB
# Copy some rpm to repoA
cp somerpm.rpm /var/www/html/pub/repoA
createrepo /var/www/html/pub/repoA
createrepo /var/www/html/pub/repoB


2.  Create two products in the webUI.

ProductA
ProductB

3.  Under each of these, create a repo with mirror on sync checked, download policy set to on_demand, and the url pointing to our webserver from above:

ProductA -> RepoA -> http://mywebserver.com/pub/repoA
ProductB -> RepoB -> http://mywebserver.com/pub/repoB

4.  Sync both RepoA and RepoB
5.  on the webserver mv the rpm from RepoA to RepoB and create the metadata

mv /var/www/html/pub/repoA/somerpm.rpm /var/www/html/pub/repoB/somerpm.rpm 
createrepo /var/www/html/pub/repoA
createrepo /var/www/html/pub/repoB

6.  Resync RepoA and RepoB
7.  register a client and assign it to the ProductB product
8.  try to 'yum install somerpm' on the client

Actual results:
Will get a 404


Expected results:
Should not get a 404


Additional info:

Comment 1 pulp-infra@redhat.com 2017-01-03 16:32:04 UTC
The Pulp upstream bug status is at NEW. Updating the external tracker on this bug.

Comment 2 pulp-infra@redhat.com 2017-01-03 16:32:07 UTC
The Pulp upstream bug priority is at High. Updating the external tracker on this bug.

Comment 4 pulp-infra@redhat.com 2017-01-04 16:01:52 UTC
The Pulp upstream bug status is at ASSIGNED. Updating the external tracker on this bug.

Comment 5 pulp-infra@redhat.com 2017-01-05 20:01:38 UTC
The Pulp upstream bug status is at POST. Updating the external tracker on this bug.

Comment 6 Ina Panova 2017-01-23 12:48:11 UTC
Does step "Resync RepoA and RepoB" includes the re-publish on metadata as well?

Comment 7 Justin Sherrill 2017-01-23 15:51:49 UTC
Ina, i don't think it matters, but in my reproducer steps it would have published (via auto publish)

Comment 8 pulp-infra@redhat.com 2017-01-24 18:31:29 UTC
The Pulp upstream bug status is at NEW. Updating the external tracker on this bug.

Comment 9 pulp-infra@redhat.com 2017-01-24 18:31:33 UTC
The Pulp upstream bug priority is at Normal. Updating the external tracker on this bug.

Comment 10 pulp-infra@redhat.com 2017-01-24 20:01:25 UTC
The Pulp upstream bug status is at ASSIGNED. Updating the external tracker on this bug.

Comment 13 pulp-infra@redhat.com 2017-01-25 15:31:48 UTC
The Pulp upstream bug status is at MODIFIED. Updating the external tracker on this bug.

Comment 14 pulp-infra@redhat.com 2017-01-27 23:01:27 UTC
The Pulp upstream bug status is at POST. Updating the external tracker on this bug.

Comment 15 pulp-infra@redhat.com 2017-02-10 20:31:28 UTC
The Pulp upstream bug status is at MODIFIED. Updating the external tracker on this bug.

Comment 16 pulp-infra@redhat.com 2017-02-10 20:31:38 UTC
All upstream Pulp bugs are at MODIFIED+. Moving this bug to POST.

Comment 17 pulp-infra@redhat.com 2017-02-16 20:32:12 UTC
The Pulp upstream bug status is at ON_QA. Updating the external tracker on this bug.

Comment 18 pulp-infra@redhat.com 2017-02-16 20:32:21 UTC
The Pulp upstream bug status is at ON_QA. Updating the external tracker on this bug.

Comment 19 pulp-infra@redhat.com 2017-02-23 21:01:49 UTC
The Pulp upstream bug status is at CLOSED - CURRENTRELEASE. Updating the external tracker on this bug.

Comment 20 pulp-infra@redhat.com 2017-02-23 21:01:58 UTC
The Pulp upstream bug status is at CLOSED - CURRENTRELEASE. Updating the external tracker on this bug.

Comment 21 pm-sat@redhat.com 2017-02-23 21:10:54 UTC
Please add verifications steps for this bug to help QE verify

Comment 23 Michael Hrivnak 2017-03-23 12:37:13 UTC
Requested backporting has been completed.

Comment 24 pulp-infra@redhat.com 2017-03-30 01:33:18 UTC
The Pulp upstream bug status is at POST. Updating the external tracker on this bug.

Comment 25 pulp-infra@redhat.com 2017-03-30 01:33:23 UTC
The Pulp upstream bug priority is at Normal. Updating the external tracker on this bug.

Comment 26 pulp-infra@redhat.com 2017-03-30 01:33:29 UTC
The Pulp upstream bug status is at POST. Updating the external tracker on this bug.

Comment 27 pulp-infra@redhat.com 2017-03-30 01:33:33 UTC
The Pulp upstream bug priority is at Normal. Updating the external tracker on this bug.

Comment 28 pulp-infra@redhat.com 2017-03-30 23:09:32 UTC
The Pulp upstream bug status is at CLOSED - COMPLETE. Updating the external tracker on this bug.

Comment 29 pulp-infra@redhat.com 2017-03-30 23:09:51 UTC
The Pulp upstream bug status is at CLOSED - COMPLETE. Updating the external tracker on this bug.

Comment 30 Bruno Rocha 2017-04-13 23:00:02 UTC
Verified in:

satellite-6.2.9-2.0.el7sat.noarch


Steps:

Followed the specified steps, registered client and package installed successful.

Comment 32 errata-xmlrpc 2017-05-01 13:57:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1191


Note You need to log in before you can comment on or make changes to this bug.