Bug 1409861 - cannot set volume options if the key has multiple values.
Summary: cannot set volume options if the key has multiple values.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gdeploy
Version: rhgs-3.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: RHGS 3.2.0
Assignee: Sachidananda Urs
QA Contact: Manisha Saini
URL:
Whiteboard:
Depends On:
Blocks: Gluster-HC-2 1351528
TreeView+ depends on / blocked
 
Reported: 2017-01-03 16:17 UTC by RamaKasturi
Modified: 2017-03-23 05:09 UTC (History)
6 users (show)

Fixed In Version: gdeploy-2.0.1-9
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-23 05:09:09 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:0482 normal SHIPPED_LIVE Red Hat Gluster Storage 3.2.0 gdeploy bug fix and enhancement update 2017-03-23 09:06:28 UTC

Description RamaKasturi 2017-01-03 16:17:49 UTC
Description of problem:
Consider a situation where user needs to enable ssl on multiple volumes.As part of that auth.ssl-allow needs to be set on the volume which has multiple values. As of now it is not possible to set multiple values for a single key using gdeploy

Version-Release number of selected component (if applicable):
gdeploy-2.0.1-8.el7rhgs.noarch

How reproducible:
Always

Steps to Reproduce:
1. Try setting the option auth.ssl-allow on the volumes using gdeploy.
2.
3.

Actual results:
It is not possible to set this key since the key has multiple values.

Expected results:
User should be able to set the key with multiple values through gdeploy

Additional info:

Comment 2 Sachidananda Urs 2017-01-04 11:06:31 UTC
Patch: https://github.com/gluster/gdeploy/commit/38b80c0345 should fix the issue.

If value has multiple items then they have to be separated by `;' or a `:'

For example:

[volume]
action=create
volname=ssl
transport=tcp
replica_count=2
force=yes
brick_dirs=/data/1
key=auth.ssl-allow
value="10.70.37.173;10.70.37.107"


Or

[volume]
action=create
volname=ssl
transport=tcp
replica_count=2
force=yes
brick_dirs=/data/1
key=auth.ssl-allow
value="10.70.37.173:10.70.37.107"

Comment 4 RamaKasturi 2017-01-10 13:20:32 UTC
proposing this as a blocker as the workaround suggested by sachi for enabling ssl on the volumes require multiple values to be set for a single key and this feature is not present in gdeploy as of now.

Comment 6 Manisha Saini 2017-02-06 11:25:46 UTC
Verified this bug on

# rpm -qa | grep gdeploy
gdeploy-2.0.1-9.el7rhgs.noarch

Gdeploy is able to set multiple values in volume option

Config file

[hosts]
10.70.37.131
10.70.37.85

[volume1]
action=create
volname=disrt-replica1
transport=tcp
replica=yes
replica_count=2
force=yes
brick_dirs=/mnt/data1/1,/mnt/data1/2,/mnt/data3/3
key=auth.ssl-allow
value="10.70.37.192:10.70.37.142"

[volume2]
action=create
volname=disrt-replica2
transport=tcp
replica=yes
replica_count=2
force=yes
brick_dirs=/mnt/data2/2,/mnt/data2/3,/mnt/data3/4
key=auth.ssl-allow
value="10.70.37.192:10.70.37.129"



================================

gluster v info
 
Volume Name: disrt-replica1
Type: Distributed-Replicate
Volume ID: 93a6e55a-5194-40a7-afe8-43cd67b1ae9f
Status: Started
Snapshot Count: 0
Number of Bricks: 3 x 2 = 6
Transport-type: tcp
Bricks:
Brick1: 10.70.37.131:/mnt/data1/1
Brick2: 10.70.37.85:/mnt/data1/1
Brick3: 10.70.37.131:/mnt/data1/2
Brick4: 10.70.37.85:/mnt/data1/2
Brick5: 10.70.37.131:/mnt/data3/3
Brick6: 10.70.37.85:/mnt/data3/3
Options Reconfigured:
auth.ssl-allow: 10.70.37.192,10.70.37.142
performance.readdir-ahead: on
 
Volume Name: disrt-replica2
Type: Distributed-Replicate
Volume ID: d3f4dd59-3d16-4b00-8134-afdf5691e787
Status: Started
Snapshot Count: 0
Number of Bricks: 3 x 2 = 6
Transport-type: tcp
Bricks:
Brick1: 10.70.37.131:/mnt/data2/2
Brick2: 10.70.37.85:/mnt/data2/2
Brick3: 10.70.37.131:/mnt/data2/3
Brick4: 10.70.37.85:/mnt/data2/3
Brick5: 10.70.37.131:/mnt/data3/4
Brick6: 10.70.37.85:/mnt/data3/4
Options Reconfigured:
auth.ssl-allow: 10.70.37.192,10.70.37.129
performance.readdir-ahead: on

Comment 8 errata-xmlrpc 2017-03-23 05:09:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2017-0482.html


Note You need to log in before you can comment on or make changes to this bug.