Bug 1409887 - Reports flicker after opening
Summary: Reports flicker after opening
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnucash
Version: 25
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-03 18:19 UTC by John Haiducek
Modified: 2017-04-28 18:49 UTC (History)
3 users (show)

Fixed In Version: gnucash-2.6.16-1.fc26 gnucash-2.6.16-1.fc24 gnucash-2.6.16-1.fc25 gnucash-2.6.16-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-19 17:00:27 UTC
Type: Bug


Attachments (Terms of Use)

Description John Haiducek 2017-01-03 18:19:42 UTC
Description of problem:

Most GNUCash reports reload repeatedly after opening, creating the appearance that they are flickering on the screen.


Version-Release number of selected component (if applicable):


How reproducible:

Every time

Steps to Reproduce:
1. Open gnucash
2. Select a report

Actual results:

Report loads and reloads repeatedly.

Expected results:

Report should load once.

Additional info:

The flickering stops eventually. Sometimes it stops on its own after 5-15 seconds; sometimes it stops when I switch to a different report and then back to the first one.

Comment 1 John Haiducek 2017-01-18 14:48:46 UTC
This bug is being discussed on the gnucash-users mailing list:

https://lists.gnucash.org/pipermail/gnucash-user/2017-January/068525.html

No bug has been filed yet on the Gnome bugzilla.

Comment 2 John Haiducek 2017-01-30 00:17:22 UTC
An upstream bug report has been filed:

https://bugzilla.gnome.org/show_bug.cgi?id=777875

Comment 3 info@kobaltwit.be 2017-04-11 13:07:38 UTC
This should be resolved for gnucash 2.6.16, release two weeks ago.

Comment 4 Fedora Update System 2017-04-12 05:32:18 UTC
gnucash-docs-2.6.16-1.el7 gnucash-2.6.16-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-d6eee41170

Comment 5 Fedora Update System 2017-04-12 05:34:03 UTC
gnucash-docs-2.6.16-1.fc24 gnucash-2.6.16-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2017-d90785c9e9

Comment 6 Fedora Update System 2017-04-12 05:35:05 UTC
gnucash-docs-2.6.16-1.fc25 gnucash-2.6.16-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-12b3d5be69

Comment 7 Fedora Update System 2017-04-12 05:36:02 UTC
gnucash-docs-2.6.16-1.fc26 gnucash-2.6.16-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-25a9acff45

Comment 8 Fedora Update System 2017-04-12 21:23:32 UTC
gnucash-2.6.16-1.fc24, gnucash-docs-2.6.16-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-d90785c9e9

Comment 9 Fedora Update System 2017-04-12 21:54:36 UTC
gnucash-2.6.16-1.fc25, gnucash-docs-2.6.16-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-12b3d5be69

Comment 10 Fedora Update System 2017-04-12 23:22:51 UTC
gnucash-2.6.16-1.fc26, gnucash-docs-2.6.16-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-25a9acff45

Comment 11 Fedora Update System 2017-04-13 00:48:09 UTC
gnucash-2.6.16-1.el7, gnucash-docs-2.6.16-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-d6eee41170

Comment 12 John Haiducek 2017-04-14 19:30:57 UTC
Just installed the update (Fedora 25). The problem is mostly fixed. The reports view still blinks once upon opening, but that glitch is much more tolerable than minutes of flickering.

Comment 13 Fedora Update System 2017-04-19 17:00:27 UTC
gnucash-2.6.16-1.fc26, gnucash-docs-2.6.16-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2017-04-22 08:19:21 UTC
gnucash-2.6.16-1.fc24, gnucash-docs-2.6.16-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2017-04-22 09:21:54 UTC
gnucash-2.6.16-1.fc25, gnucash-docs-2.6.16-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2017-04-28 18:49:51 UTC
gnucash-2.6.16-1.el7, gnucash-docs-2.6.16-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.