Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1409905 - [abrt] WARNING: CPU: 0 PID: 0 at drivers/net/wireless/intel/iwlwifi/dvm/main.c:2063 iwl_stop_sw_queue+0x93/0xa0 [iwldvm]
Summary: [abrt] WARNING: CPU: 0 PID: 0 at drivers/net/wireless/intel/iwlwifi/dvm/main....
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 25
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:96e0489dd52207d8925916741fd...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-03 20:31 UTC by M. Edward (Ed) Borasky
Modified: 2019-01-09 12:54 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-18 00:08:01 UTC
Type: ---


Attachments (Terms of Use)
File: dmesg (167.14 KB, text/plain)
2017-01-03 20:32 UTC, M. Edward (Ed) Borasky
no flags Details

Description M. Edward (Ed) Borasky 2017-01-03 20:31:52 UTC
Additional info:
reporter:       libreport-2.8.0
WARNING: CPU: 0 PID: 0 at drivers/net/wireless/intel/iwlwifi/dvm/main.c:2063 iwl_stop_sw_queue+0x93/0xa0 [iwldvm]
Modules linked in: fuse ccm xt_addrtype br_netfilter nf_nat_h323 nf_conntrack_h323 nf_nat_pptp nf_nat_proto_gre nf_conntrack_pptp nf_conntrack_proto_gre nf_nat_tftp nf_conntrack_tftp nf_nat_sip nf_conntrack_sip nf_nat_irc nf_conntrack_irc nf_nat_ftp nf_conntrack_ftp xt_CHECKSUM ipt_MASQUERADE nf_nat_masquerade_ipv4 tun nf_conntrack_netbios_ns nf_conntrack_broadcast xt_CT dm_thin_pool dm_persistent_data ip6t_rpfilter dm_bio_prison libcrc32c loop ip6t_REJECT nf_reject_ipv6 xt_conntrack ip_set nfnetlink ebtable_broute bridge stp llc ebtable_nat ip6table_raw ip6table_mangle ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 ip6table_security iptable_raw iptable_mangle iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack iptable_security ebtable_filter ebtables
 ip6table_filter ip6_tables intel_rapl uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_v4l2 x86_pkg_temp_thermal intel_powerclamp coretemp kvm_intel arc4 videobuf2_core iwldvm snd_hda_codec_hdmi videodev kvm snd_hda_codec_realtek mac80211 snd_hda_codec_generic irqbypass iTCO_wdt iTCO_vendor_support asus_nb_wmi asus_wmi mxm_wmi sparse_keymap snd_hda_intel snd_hda_codec crct10dif_pclmul media snd_hda_core snd_hwdep crc32_pclmul snd_seq snd_seq_device ghash_clmulni_intel iwlwifi intel_cstate snd_pcm intel_uncore snd_timer snd intel_rapl_perf soundcore mei_me mei i2c_i801 joydev cfg80211 i2c_smbus rfkill lpc_ich shpchp tpm_tis tpm_tis_core tpm wmi nfsd auth_rpcgss nfs_acl lockd grace sunrpc hid_logitech_hidpp i915 hid_logitech_dj crc32c_intel i2c_algo_bit drm_kms_helper serio_raw drm
 atl1c fjes video
CPU: 0 PID: 0 Comm: swapper/0 Not tainted 4.8.15-300.fc25.x86_64 #1
Hardware name: ASUSTeK Computer Inc. U46E/U46E, BIOS U46E.206 10/07/2011
 0000000000000286 920343f8b5216369 ffffa07c37003590 ffffffff8d3e5e1d
 0000000000000000 0000000000000000 ffffa07c370035d0 ffffffff8d0a0e8b
 0000080f347e0000 0000000000000004 ffffa07b4bfb2064 ffffa07b96673100
Call Trace:
 <IRQ>  [<ffffffff8d3e5e1d>] dump_stack+0x63/0x86
 [<ffffffff8d0a0e8b>] __warn+0xcb/0xf0
 [<ffffffff8d0a0fbd>] warn_slowpath_null+0x1d/0x20
 [<ffffffffc08c19a3>] iwl_stop_sw_queue+0x93/0xa0 [iwldvm]
 [<ffffffffc061234c>] iwl_trans_pcie_tx+0xdbc/0x1460 [iwlwifi]
 [<ffffffffc08cc25b>] ? iwlagn_tx_skb+0xeb/0xd40 [iwldvm]
 [<ffffffffc0611fcf>] ? iwl_trans_pcie_tx+0xa3f/0x1460 [iwlwifi]
 [<ffffffff8d41059d>] ? swiotlb_tbl_map_single+0x26d/0x2a0
 [<ffffffffc08cc3fc>] iwlagn_tx_skb+0x28c/0xd40 [iwldvm]
 [<ffffffffc08ca392>] iwlagn_mac_tx+0x22/0x40 [iwldvm]
 [<ffffffffc0752b6d>] ieee80211_tx_frags+0x41d/0x470 [mac80211]
 [<ffffffffc0757548>] __ieee80211_subif_start_xmit+0x638/0xd50 [mac80211]
 [<ffffffff8d3ea5eb>] ? plist_add+0x9b/0xf0
 [<ffffffffc0757c70>] ieee80211_subif_start_xmit+0x10/0x20 [mac80211]
 [<ffffffff8d6dd493>] dev_hard_start_xmit+0xa3/0x1f0
 [<ffffffff8d706691>] sch_direct_xmit+0xf1/0x1a0
 [<ffffffff8d6ddb54>] __dev_queue_xmit+0x494/0x6b0
 [<ffffffff8d6ddd80>] dev_queue_xmit+0x10/0x20
 [<ffffffff8d726b72>] ip_finish_output2+0x292/0x380
 [<ffffffffc099623d>] ? ipv4_confirm+0x7d/0x100 [nf_conntrack_ipv4]
 [<ffffffff8d726e0a>] ip_finish_output+0x12a/0x1d0
 [<ffffffff8d717aa3>] ? nf_hook_slow+0x73/0xd0
 [<ffffffff8d72786e>] ip_output+0x6e/0xf0
 [<ffffffff8d726ce0>] ? __ip_flush_pending_frames.isra.40+0x80/0x80
 [<ffffffff8d7235f3>] ip_forward_finish+0x43/0x70
 [<ffffffff8d7239a1>] ip_forward+0x381/0x470
 [<ffffffff8d7235b0>] ? ip_frag_mem+0x50/0x50
 [<ffffffff8d72165d>] ip_rcv_finish+0xdd/0x3b0
 [<ffffffff8d721fb2>] ip_rcv+0x282/0x3a0
 [<ffffffff8d721580>] ? inet_del_offload+0x40/0x40
 [<ffffffff8d6dace0>] __netif_receive_skb_core+0x520/0xa90
 [<ffffffff8d6db268>] __netif_receive_skb+0x18/0x60
 [<ffffffff8d6db2f0>] netif_receive_skb_internal+0x40/0xb0
 [<ffffffff8d4106c3>] ? swiotlb_tbl_unmap_single+0xf3/0x120
 [<ffffffff8d6db37c>] netif_receive_skb+0x1c/0x70
 [<ffffffffc01fe5ed>] atl1c_clean+0x2ed/0x3a0 [atl1c]
 [<ffffffff8d6dbaec>] net_rx_action+0x22c/0x370
 [<ffffffff8d8068f2>] __do_softirq+0x112/0x2ab
 [<ffffffff8d0a6ad8>] irq_exit+0xe8/0xf0
 [<ffffffff8d806634>] do_IRQ+0x54/0xd0
 [<ffffffff8d8044cc>] common_interrupt+0x8c/0x8c
 <EOI>  [<ffffffff8d68945f>] ? cpuidle_enter_state+0x11f/0x2c0
 [<ffffffff8d689637>] cpuidle_enter+0x17/0x20
 [<ffffffff8d0e534a>] call_cpuidle+0x2a/0x50
 [<ffffffff8d0e5730>] cpu_startup_entry+0x2a0/0x350
 [<ffffffff8d7f64e7>] rest_init+0x77/0x80
 [<ffffffff8df7ffeb>] start_kernel+0x45f/0x480
 [<ffffffff8df7f120>] ? early_idt_handler_array+0x120/0x120
 [<ffffffff8df7f2ca>] x86_64_start_reservations+0x24/0x26
 [<ffffffff8df7f419>] x86_64_start_kernel+0x14d/0x170

Comment 1 M. Edward (Ed) Borasky 2017-01-03 20:32:03 UTC
Created attachment 1236995 [details]
File: dmesg

Comment 2 M. Edward (Ed) Borasky 2017-01-06 19:27:14 UTC
Description of problem:
Bringing the laptop up

Version-Release number of selected component:
kernel-core-4.8.15-300.fc25

Additional info:
reporter:       libreport-2.8.0
cmdline:        BOOT_IMAGE=/boot/vmlinuz-4.8.15-300.fc25.x86_64 root=UUID=97c78d89-f2d4-491e-bce1-6cc602f0d0e8 ro rhgb quiet LANG=en_US.UTF-8
kernel:         4.8.15-300.fc25.x86_64
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
runlevel:       N 5
type:           Kerneloops

Truncated backtrace:
#1 [IRQ] dump_stack
#2 [IRQ] __warn
#3 [IRQ] warn_slowpath_null
#4 [IRQ] iwl_stop_sw_queue in iwldvm
#5 [IRQ] iwl_trans_pcie_tx in iwlwifi
#6 [IRQ] ? iwlagn_tx_skb in iwldvm
#7 [IRQ] ? enqueue_task_rt
#8 [IRQ] iwlagn_tx_skb in iwldvm
#9 [IRQ] iwlagn_mac_tx in iwldvm
#10 [IRQ] ieee80211_tx_frags in mac80211

Comment 3 Laura Abbott 2017-01-17 01:21:14 UTC
*********** MASS BUG UPDATE **************
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 25 kernel bugs.
 
Fedora 25 has now been rebased to 4.9.3-200.fc25.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you have moved on to Fedora 26, and are still experiencing this issue, please change the version to Fedora 26.
 
If you experience different issues, please open a new bug report for those.

Comment 4 M. Edward (Ed) Borasky 2017-01-30 12:47:48 UTC
(In reply to Laura Abbott from comment #3)
> *********** MASS BUG UPDATE **************
> We apologize for the inconvenience.  There is a large number of bugs to go
> through and several of them have gone stale.  Due to this, we are doing a
> mass bug update across all of the Fedora 25 kernel bugs.
>  
> Fedora 25 has now been rebased to 4.9.3-200.fc25.  Please test this kernel
> update (or newer) and let us know if you issue has been resolved or if it is
> still present with the newer kernel.
>  
> If you have moved on to Fedora 26, and are still experiencing this issue,
> please change the version to Fedora 26.
>  
> If you experience different issues, please open a new bug report for those.

I've updated both my Fedora 25 systems to the current kernel. I haven't seen this issue since the initial finding / report. And I don't know how to trigger it.

I'll try a stress test - a big download or repeated WiFi speed tests - and see if I can trigger it.

Comment 5 M. Edward (Ed) Borasky 2017-04-17 23:51:03 UTC
I can't reproduce this - you can close it as far as I'm concerned.


Note You need to log in before you can comment on or make changes to this bug.