Bug 1409911 - [RFE] Add novajoin metadata REST service
Summary: [RFE] Add novajoin metadata REST service
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-novajoin
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: Upstream M2
: 12.0 (Pike)
Assignee: Rob Crittenden
QA Contact: Prasanth Anbalagan
URL:
Whiteboard:
: 1304017 (view as bug list)
Depends On: 1401666
Blocks: 1442136 1469329
TreeView+ depends on / blocked
 
Reported: 2017-01-03 21:12 UTC by Rob Crittenden
Modified: 2019-09-09 17:12 UTC (History)
22 users (show)

Fixed In Version: python-novajoin-1.0.13-0.20170403154656.054c186.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1493557 (view as bug list)
Environment:
Last Closed: 2017-12-13 20:57:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:3462 normal SHIPPED_LIVE Red Hat OpenStack Platform 12.0 Enhancement Advisory 2018-02-16 01:43:25 UTC

Description Rob Crittenden 2017-01-03 21:12:25 UTC
Description of problem:

Clone from https://blueprints.launchpad.net/tripleo/+spec/novajoin

A nova metadata REST service and notification listener to detect when an instance is created and if requested, register it with IPA (freeipa.org) via cloud-init. This will provide the credentials needed for easy certmonger integration using the IPA CA to provision certificates. See also https://blueprints.launchpad.net/tripleo/+spec/tls-via-certmonger

Comment 2 Nathan Kinder 2017-01-09 15:57:06 UTC
*** Bug 1304017 has been marked as a duplicate of this bug. ***

Comment 20 errata-xmlrpc 2017-12-13 20:57:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462


Note You need to log in before you can comment on or make changes to this bug.