Bug 140996 - Dell Poweredge 420 Server video not supported
Dell Poweredge 420 Server video not supported
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-27 12:02 EST by Winston Ojeda
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-15 10:37:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Winston Ojeda 2004-11-27 12:02:32 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
I just got a brand new Dell PowerEdge SC420 server. I installed FC3
and Xorg would kill the video signal and the keyboard as well every
time upon boot.
Logs say it found an "Unknown Intel Chipset". It took a while to
figure out that the driver is loading is the Gereric Vesa driver and
the only resolution it supports is 800x600 16. Once I forced this
mode, X came up right away.

Anyone knows what Video is this thing using? Dell doesn't say. Is it
supported by Xorg? My quess is not.
All I know is the Chipset on this board is the Intel E7221. A chipset
I couldn't even find on the Intel site. Is this custom made for Dell
or what?

I can't work on 800x600. Is there a workaround for this problem?

Version-Release number of selected component (if applicable):
xorg-x11-6.8.1-12

How reproducible:
Always

Steps to Reproduce:
1. Start machine
2. wait for X to kick in
3. Monitor signal is gone
4. keyboard is gone
    

Actual Results:  There is no monitor signal or keyboard

Expected Results:  X to start

Additional info:

Temoporary work around is to edit xorg.conf to default to 16 bit
800x600... LAME!
Comment 1 Jeff 2004-12-18 17:38:54 EST
Intel® E7221
had to add "base=0xf0000000 size=0x800000 type=write-combining" >|
/proc/mtrr
to get it to work at all .
VESA VBE OEM Product: Intel(r)CopperRiver Graphics Controller
Xorg 6.8.1,
Comment 2 Mike A. Harris 2005-02-01 01:51:29 EST
Please attach the X server log file and config file, and
/var/log/messages from after starting up a failed X session, as
individual uncompressed file attachments.  Also attach the
output of "lsmod -v" and "lsmod -vvn".

Once you have attached the requested information, we will review
the details, and try to determine the cause of the problem.

Thanks in advance.
Comment 3 Mike A. Harris 2005-04-15 10:37:39 EDT
This bug has not been updated to provide us with the information
we've requested above.  If you have not already updated to the
latest Fedora Core xorg-x11 and kernel updates, please do so now and
if you still encounter the problem described above, please report the
issue to X.Org bugzilla at http://bugs.freedestop.org in the "xorg"
component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes that
become available for consideration in future updates.

Setting status to "NOTABUG" due to lack of information.

Note You need to log in before you can comment on or make changes to this bug.