Bug 1409964 - New package : Tap as a service extension for neutron
Summary: New package : Tap as a service extension for neutron
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: RDO
Classification: Community
Component: Package Review
Version: trunk
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: trunk
Assignee: Javier Peña
QA Contact: hguemar
URL:
Whiteboard:
: 1534642 (view as bug list)
Depends On:
Blocks: 1411311 1476900
TreeView+ depends on / blocked
 
Reported: 2017-01-04 03:09 UTC by zenghui.shi
Modified: 2019-04-25 14:38 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-25 14:38:52 UTC
jpena: rdo-review+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1411311 0 unspecified NEW [RFE] Integrate Tap as a Service (TaaS) into RHOSP 2021-04-29 17:19:15 UTC
Red Hat Bugzilla 1411434 0 medium CLOSED [RFE] Support TaaS (Tap-As-A-Service) with OpenDaylight 2021-02-22 00:41:40 UTC

Description zenghui.shi 2017-01-04 03:09:04 UTC
Description of problem:

spec URL : https://github.com/zshi-redhat/openstack-tap-as-a-service.spec/blob/master/taas.spec

Description: 
introducing the functionality of port mirroring in OpenStack Neutron provisioned networks

Comment 2 Javier Peña 2017-12-12 14:01:15 UTC
Could you create a review for the rdoinfo project in review.rdoproject.org, as specified in step 2 for https://www.rdoproject.org/documentation/add-packages/#how-to-add-a-new-openstack-package-to-rdo-trunk ?

This is needed as the next step to get the package integrated in RDO.

Comment 4 Ricardo Noriega 2018-01-15 16:39:37 UTC
*** Bug 1534642 has been marked as a duplicate of this bug. ***

Comment 5 Ricardo Noriega 2018-01-15 16:42:35 UTC
Here it's the rdoinfo patch:

https://review.rdoproject.org/r/#/c/11337/

Comment 6 Javier Peña 2018-01-16 09:03:16 UTC
Here is the initial licensecheck output:

$ licensecheck -r .
./.coveragerc: *No copyright* UNKNOWN
./.gitreview: *No copyright* UNKNOWN
./.mailmap: *No copyright* UNKNOWN
./.testr.conf: *No copyright* UNKNOWN
./API_REFERENCE.rst: *No copyright* UNKNOWN
./CONTRIBUTING.rst: *No copyright* UNKNOWN
./HACKING.rst: *No copyright* UNKNOWN
./INSTALL.rst: *No copyright* UNKNOWN
./LICENSE: *No copyright* Apache (v2.0)
./MANIFEST.in: *No copyright* UNKNOWN
./README.rst: *No copyright* UNKNOWN
./babel.cfg: *No copyright* UNKNOWN
./openstack-common.conf: *No copyright* UNKNOWN
./requirements.txt: *No copyright* UNKNOWN
./setup.cfg: *No copyright* Apache
./setup.py: Apache (v2.0) GENERATED FILE
./test-requirements.txt: *No copyright* UNKNOWN
./tox.ini: *No copyright* UNKNOWN
./devstack/README.rst: *No copyright* UNKNOWN
./devstack/devstackgaterc: Apache (v2.0)
./devstack/plugin.sh: Apache (v2.0)
./devstack/settings: *No copyright* UNKNOWN
./etc/taas.ini: *No copyright* UNKNOWN
./etc/taas_plugin.ini: *No copyright* UNKNOWN
./neutron_taas/_i18n.py: *No copyright* Apache (v2.0)
./specs/index.rst: *No copyright* UNKNOWN
./tools/test-setup.sh: *No copyright* UNKNOWN
./tools/tox_install.sh: *No copyright* UNKNOWN
./tools/tox_install_project.sh: *No copyright* UNKNOWN
./doc/source/api_reference.rst: *No copyright* UNKNOWN
./doc/source/conf.py: *No copyright* Apache (v2.0)
./doc/source/contributing.rst: *No copyright* UNKNOWN
./doc/source/index.rst: *No copyright* UNKNOWN
./doc/source/installation.rst: *No copyright* UNKNOWN
./doc/source/presentations.rst: *No copyright* UNKNOWN
./doc/source/readme.rst: *No copyright* UNKNOWN
./neutron_taas/common/constants.py: Apache (v2.0)
./neutron_taas/common/topics.py: Apache (v2.0)
./neutron_taas/db/head.py: Apache (v2.0)
./neutron_taas/db/taas_db.py: Apache (v2.0)
./neutron_taas/extensions/taas.py: Apache (v2.0)
./neutron_taas/taas_client/tapflow.py: Apache (v2.0)
./neutron_taas/taas_client/tapservice.py: Apache (v2.0)
./specs/mitaka/tap-as-a-service.rst: *No copyright* CC by (v3.0)
./neutron_taas/db/migration/taas_init_ops.py: Apache (v2.0)
./neutron_taas/services/taas/taas_plugin.py: Apache (v2.0)
./neutron_taas/tests/tempest_plugin/plugin.py: Apache (v2.0)
./neutron_taas/db/migration/alembic_migration/README: *No copyright* UNKNOWN
./neutron_taas/db/migration/alembic_migration/env.py: Apache (v2.0)
./neutron_taas/db/migration/alembic_migration/script.py.mako: *No copyright* UNKNOWN
./neutron_taas/services/taas/agents/taas_agent_api.py: Apache (v2.0)
./neutron_taas/services/taas/service_drivers/__init__.py: Apache (v2.0)
./neutron_taas/services/taas/service_drivers/service_driver_context.py: Apache (v2.0)
./neutron_taas/services/taas/service_drivers/taas_agent_api.py: Apache (v2.0)
./neutron_taas/services/taas/service_drivers/taas_rpc.py: Apache (v2.0)
./neutron_taas/tests/tempest_plugin/services/client.py: Apache (v2.0)
./neutron_taas/tests/tempest_plugin/tests/taas_client.py: Apache (v2.0)
./neutron_taas/tests/unit/db/test_migrations.py: Apache (v2.0)
./neutron_taas/tests/unit/db/test_taas_db.py: Apache (v2.0)
./neutron_taas/tests/unit/extensions/test_taas.py: Apache (v2.0)
./neutron_taas/tests/unit/taas_client/test_cli20_tapflow.py: Apache (v2.0)
./neutron_taas/tests/unit/taas_client/test_cli20_tapservice.py: Apache (v2.0)
./neutron_taas/db/migration/alembic_migration/versions/CONTRACT_HEAD: *No copyright* UNKNOWN
./neutron_taas/db/migration/alembic_migration/versions/EXPAND_HEAD: *No copyright* UNKNOWN
./neutron_taas/db/migration/alembic_migration/versions/start_neutron_taas.py: Apache (v2.0)
./neutron_taas/services/taas/agents/extensions/taas.py: Apache (v2.0)
./neutron_taas/services/taas/agents/ovs/taas_ovs_agent.py: Apache (v2.0)
./neutron_taas/services/taas/drivers/linux/ovs_constants.py: Apache (v2.0)
./neutron_taas/services/taas/drivers/linux/ovs_taas.py: Apache (v2.0)
./neutron_taas/services/taas/drivers/linux/ovs_utils.py: Apache (v2.0)
./neutron_taas/tests/tempest_plugin/tests/api/base.py: Apache (v2.0)
./neutron_taas/tests/tempest_plugin/tests/api/test_taas.py: Apache (v2.0)
./neutron_taas/tests/tempest_plugin/tests/scenario/base.py: Apache (v2.0)
./neutron_taas/tests/tempest_plugin/tests/scenario/manager.py: Apache (v2.0)
./neutron_taas/tests/tempest_plugin/tests/scenario/test_taas.py: Apache (v2.0)
./neutron_taas/tests/unit/services/taas/test_taas_plugin.py: Apache (v2.0)
./neutron_taas/db/migration/alembic_migration/versions/newton/contract/1817af933379_remove_network_id_from_tap_service.py: Apache (v2.0)
./neutron_taas/db/migration/alembic_migration/versions/newton/contract/2ecce0368a62_add_foreign_key_constraint_on_tap_id_association.py: Apache (v2.0)
./neutron_taas/db/migration/alembic_migration/versions/newton/contract/4086b3cffc01_rename_tenant_to_project.py: Apache (v2.0)
./neutron_taas/db/migration/alembic_migration/versions/newton/contract/80c85b675b6e_initial_newton_no_op_contract_script.py: Apache (v2.0)
./neutron_taas/db/migration/alembic_migration/versions/newton/expand/04625466c6fa_initial_newton_no_op_expand_script.py: Apache (v2.0)
./neutron_taas/db/migration/alembic_migration/versions/newton/expand/fddbdec8711a_add_status.py: Apache (v2.0)
./neutron_taas/db/migration/alembic_migration/versions/pike/contract/bac61f603e39_alter_tap_id_associations_to_support_tap_id_reuse.py: Apache (v2.0)

The code is licensed using the Apache 2.0 license. There is a spec file licensed using Creative Commons Attribution 3.0 Unported License. We should not include that file in the package, so we should be ok.

Comment 7 Ricardo Noriega 2018-01-16 13:55:32 UTC
Initial spec file:

https://review.rdoproject.org/r/#/c/11351/

Comment 9 Javier Peña 2018-01-29 15:44:14 UTC
Review notes:

- I have noted that the -doc subpackage is lacking the generated documentation (doc/build/html), please add it before merging the review.
- Licensecheck detects one file with a CC 3.0 license (a design spec), but it is not included in the package, so it's ok.
- The neutron directories are owned by required packages (python-neutron and openstack-neutron-common)
- The Source0 and %define require justification are expected, since the SRPM was generated using DLRN. 
- The rpmlint messages regarding files with 640 permissions are expected.

Package Review
==============

Legend:
[x] = Pass, [!] = Fail, [-] = Not applicable, [?] = Not evaluated
[ ] = Manual review needed



===== MUST items =====

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. Licenses
     found: "Apache (v2.0)", "*No copyright* Apache", "*No copyright* CC by
     (v3.0)", "Unknown or generated", "*No copyright* Apache (v2.0)". 40
     files have unknown license. Detailed output of licensecheck in /tmp
     /python-tap-as-a-service/licensecheck.txt
[x]: License file installed when any subpackage combination is installed.
[x]: Package requires other packages for directories it uses.
     Note: No known owner of /usr/share/neutron, /usr/share/neutron/server,
     /etc/neutron
[x]: Package must own all directories that it creates.
     Note: Directories without known owners: /usr/share/neutron,
     /etc/neutron, /usr/share/neutron/server
[x]: Package contains no bundled libraries without FPC exception.
[x]: Changelog in prescribed format.
[x]: Sources contain only permissible code or content.
[-]: Package contains desktop file if it is a GUI application.
[-]: Development files must be in a -devel package
[x]: Package uses nothing in %doc for runtime.
[x]: Package consistently uses macros (instead of hard-coded directory
     names).
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
[x]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: Requires correct, justified where necessary.
[x]: Spec file is legible and written in American English.
[-]: Package contains systemd file(s) if in need.
[x]: Package is not known to require an ExcludeArch tag.
[x]: Large documentation must go in a -doc subpackage. Large could be size
     (~1MB) or number of files.
     Note: Documentation size is 10240 bytes in 1 files.
[x]: Package complies to the Packaging Guidelines
[x]: Package successfully compiles and builds into binary rpms on at least
     one supported primary architecture.
[x]: Package installs properly.
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).
[x]: If (and only if) the source package includes the text of the
     license(s) in its own file, then that file, containing the text of the
     license(s) for the package is included in %license.
[x]: Package does not own files or directories owned by other packages.
[x]: All build dependencies are listed in BuildRequires, except for any
     that are listed in the exceptions section of Packaging Guidelines.
[x]: Package uses either %{buildroot} or $RPM_BUILD_ROOT
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: %config files are marked noreplace or the reason is justified.
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Dist tag is present.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Package use %makeinstall only when make install DESTDIR=... doesn't
     work.
[x]: Package is named using only allowed ASCII characters.
[x]: No %config files under /usr.
[x]: Package does not use a name that already exists.
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as
     provided in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: File names are valid UTF-8.
[x]: Packages must not store files under /srv, /opt or /usr/local

Python:
[x]: Python eggs must not download any dependencies during the build
     process.
[x]: A package which is used by another package via an egg interface should
     provide egg info.
[x]: Package meets the Packaging Guidelines::Python
[x]: Package contains BR: python2-devel or python3-devel
[x]: Binary eggs must be removed in %prep

===== SHOULD items =====

Generic:
[-]: If the source package does not include license text(s) as a separate
     file from upstream, the packager SHOULD query upstream to include it.
[x]: Final provides and requires are sane (see attachments).
[x]: Fully versioned dependency in subpackages if applicable.
     Note: No Requires: %{name}%{?_isa} = %{version}-%{release} in python2
     -tap-as-a-service , python-tap-as-a-service-doc , python-tap-as-a
     -service-tests
[x]: Package functions as described.
[x]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[x]: SourceX tarball generation or download is documented.
     Note: Package contains tarball without URL, check comments
[-]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: Package should compile and build into binary rpms on all supported
     architectures.
[x]: %check is present and all tests pass.
[x]: Packages should try to preserve timestamps of original installed
     files.
[x]: Spec use %global instead of %define unless justified.
     Note: %define requiring justification: %define upstream_version
     2.0.1.dev5
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: Packager, Vendor, PreReq, Copyright tags should not be in spec file
[x]: SourceX is a working URL.

===== EXTRA items =====

Generic:
[x]: Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).


Rpmlint
-------
Checking: python2-tap-as-a-service-2.0.1-0.20180124005643.e35704e.el7.centos.noarch.rpm
          python-tap-as-a-service-doc-2.0.1-0.20180124005643.e35704e.el7.centos.noarch.rpm
          python-tap-as-a-service-tests-2.0.1-0.20180124005643.e35704e.el7.centos.noarch.rpm
          python-tap-as-a-service-2.0.1-0.20180124005643.e35704e.el7.centos.src.rpm
python2-tap-as-a-service.noarch: E: no-changelogname-tag
python2-tap-as-a-service.noarch: W: non-standard-gid /etc/neutron/taas.ini neutron
python2-tap-as-a-service.noarch: E: non-readable /etc/neutron/taas.ini 640
python2-tap-as-a-service.noarch: W: non-standard-gid /etc/neutron/taas_plugin.ini neutron
python2-tap-as-a-service.noarch: E: non-readable /etc/neutron/taas_plugin.ini 640
python-tap-as-a-service-doc.noarch: E: no-changelogname-tag
python-tap-as-a-service-tests.noarch: E: no-changelogname-tag
python-tap-as-a-service-tests.noarch: W: no-documentation
python-tap-as-a-service.src: E: no-changelogname-tag
python-tap-as-a-service.src: W: invalid-url Source0: tap-as-a-service-2.0.1.dev5-0.20180124005643.e35704e.tar.gz
4 packages and 0 specfiles checked; 6 errors, 4 warnings.




Rpmlint (installed packages)
----------------------------
python2-tap-as-a-service.noarch: E: no-changelogname-tag
python2-tap-as-a-service.noarch: W: invalid-url URL: https://git.openstack.org/cgit/openstack/tap-as-a-service <urlopen error [Errno -2] Name or service not known>
python2-tap-as-a-service.noarch: W: non-standard-gid /etc/neutron/taas_plugin.ini neutron
python2-tap-as-a-service.noarch: E: non-readable /etc/neutron/taas_plugin.ini 0640L
python2-tap-as-a-service.noarch: W: non-standard-gid /etc/neutron/taas.ini neutron
python2-tap-as-a-service.noarch: E: non-readable /etc/neutron/taas.ini 0640L
python-tap-as-a-service-tests.noarch: E: no-changelogname-tag
python-tap-as-a-service-tests.noarch: W: invalid-url URL: https://git.openstack.org/cgit/openstack/tap-as-a-service <urlopen error [Errno -2] Name or service not known>
python-tap-as-a-service-tests.noarch: W: no-documentation
python-tap-as-a-service-doc.noarch: E: no-changelogname-tag
python-tap-as-a-service-doc.noarch: W: invalid-url URL: https://git.openstack.org/cgit/openstack/tap-as-a-service <urlopen error [Errno -2] Name or service not known>
3 packages and 0 specfiles checked; 5 errors, 6 warnings.



Requires
--------
python2-tap-as-a-service (rpmlib, GLIBC filtered):
    config(python2-tap-as-a-service)
    openstack-neutron-common
    python(abi)
    python-babel
    python-neutron-lib
    python-oslo-concurrency
    python-oslo-config
    python-oslo-db
    python-oslo-i18n
    python-oslo-log
    python-oslo-messaging
    python-oslo-service
    python-oslo-utils
    python-pbr
    python-setuptools

python-tap-as-a-service-tests (rpmlib, GLIBC filtered):
    python(abi)
    python-neutron-tests
    python-neutronclient
    python-neutronclient-tests
    python-os-testr
    python-oslotest
    python-subunit
    python-tap-as-a-service
    python-testrepository
    python-testresources
    python-testscenarios
    python-testtools

python-tap-as-a-service-doc (rpmlib, GLIBC filtered):



Provides
--------
python2-tap-as-a-service:
    config(python2-tap-as-a-service)
    python-tap-as-a-service
    python2-tap-as-a-service

python-tap-as-a-service-tests:
    python-tap-as-a-service-tests

python-tap-as-a-service-doc:
    python-tap-as-a-service-doc



Generated by fedora-review 0.6.1 (f03e4e7) last change: 2016-05-02
Command line :/usr/bin/fedora-review -m dlrn -n python-tap-as-a-service -r
Buildroot used: dlrn-centos7-x86_64
Active plugins: Python, Generic, Shell-api
Disabled plugins: Java, C/C++, fonts, SugarActivity, Ocaml, Perl, Haskell, R, PHP
Disabled flags: EXARCH, DISTTAG, EPEL5, BATCH, EPEL6

The package is APPROVED.

Comment 10 Javier Peña 2019-04-25 14:38:52 UTC
The package has been present in RDO Trunk for a while, closing the bug.


Note You need to log in before you can comment on or make changes to this bug.