Bug 140998 - Dependancy against pyorbit uses wrong version
Dependancy against pyorbit uses wrong version
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-python2 (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-27 13:25 EST by Jeff Odom
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-31 15:14:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Odom 2004-11-27 13:25:15 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
When installing gnome-python2-bonobo-2.6.0-3, the following failed
dependancy occurs:

        pyorbit >= 2.0.l is needed by gnome-python2-bonobo-2.6.0-3

Note that the current version of pyorbit is 2.0.1.  However,
gnome-python2-bonobo is looking for 2.0.l (that's an ell, not a one),
so the dependancy fails.  

Version-Release number of selected component (if applicable):
2.6.0-3

How reproducible:
Always

Steps to Reproduce:
1. rpm -U pyorbit-2.0.1-1.i386.rpm gnome-python2-bonobo-2.6.0-3.i386.rpm
2.
3.
    

Actual Results:  error: Failed dependencies:
        pyorbit >= 2.0.l is needed by gnome-python2-bonobo-2.6.0-3


Expected Results:  Successful package upgrade/install

Additional info:

It can of course be worked around by adding --nodeps to the rpm
command line.
Comment 1 Matthew Miller 2006-07-10 16:32:50 EDT
Fedora Core 3 is now maintained by the Fedora Legacy project for security
updates only. If this problem is a security issue, please reopen and
reassign to the Fedora Legacy product. If it is not a security issue and
hasn't been resolved in the current FC5 updates or in the FC6 test
release, reopen and change the version to match.

Thank you!
Comment 2 John Thacker 2006-10-31 15:14:11 EST
Amazingly, the typo still exists in the specfile.  However, it just works in FC5
and FC6 still pyorbit now has a version number of 2.14.1, which is greater than
2.0.l, where 'l' is the letter ell.  I'm of several minds as to whether to close
this bug or not, and if so, how.

Note You need to log in before you can comment on or make changes to this bug.