Bug 1409992 - Bug description is lost if the user has to go back to enter_bug.cgi
Summary: Bug description is lost if the user has to go back to enter_bug.cgi
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Bugzilla
Classification: Community
Component: Creating/Changing Bugs
Version: 5.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: 5.0
Assignee: Jeff Fearn 🐞
QA Contact: tools-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-04 06:24 UTC by Jason McDonald
Modified: 2018-12-09 06:29 UTC (History)
3 users (show)

Fixed In Version: 5.0.3.rh22
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-20 03:19:49 UTC


Attachments (Terms of Use)

Description Jason McDonald 2017-01-04 06:24:06 UTC
Description of problem:
If Bugzilla rejects a bug submission and tells the user to go back and try again, the bug description (which the user may have spent significant time crafting) gets replaced by the default template text.

Version-Release number of selected component (if applicable):
5.0.3 (beta.bugzilla.redhat.com)

How reproducible:
Always

Steps to Reproduce:
1. Go to New->Community-Bugzilla
2. Select a component and enter a bug Summary and Description
3. Request the needinfo flag from an account that is disabled. 
4. Click submit
5. Click the browser's Back button

Actual results:
After step 4, Bugzilla correctly say "You can't ask <foo@example.com> because that account is disabled.\nPlease press Back and try again."
After step 5, the bug Description entered in step 2 has been replaced by the default template text.

Expected results:
After step 5, the original bug description is intact.

Additional info:
- I consider this bug to be high priority due to the potential for users to lose a significant amount of work when their text is thrown away.
- Marked as a regression -- it doesn't happen in Bugzilla 4.x because that version doesn't object to requesting flags from a disabled account.

Comment 1 Jeff Fearn 🐞 2017-01-15 23:28:59 UTC
If the description gets changed by Bugzilla specific behavior then this is a bug, if it gets changed because of the browser then it is not a bug in Bugzilla.

Comment 2 Rony Gong 🔥 2017-01-19 03:25:34 UTC
Tested on QA environment(5.0.3-rh22)
Result: Pass


Note You need to log in before you can comment on or make changes to this bug.