Bug 1409994 - exception while adding Instance Images
Summary: exception while adding Instance Images
Keywords:
Status: CLOSED DUPLICATE of bug 1401576
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 4.0.5.5
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
: ---
Assignee: bugs@ovirt.org
QA Contact: Pavel Stehlik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-04 06:30 UTC by hifxj
Modified: 2017-01-06 03:48 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-05 15:46:23 UTC
oVirt Team: Virt


Attachments (Terms of Use)

Description hifxj 2017-01-04 06:30:05 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Edit virtual machine
2. Click '+' to add instance images
3. Click 'Create'
4. Input size '100'.
5. Click 'OK' -- exception occurred.
6. Click 'OK' again, This time it will succeed. 

Actual results:

Uncaught exception occurred. Please try reloading the page. Details: Exception caught: Exception caught: (TypeError) __gwt$exception: <skipped>: Cannot read property 'b' of null
Please have your administrator check the UI logs

Expected results:
Should not display exception.

Additional info:

UI log:

2017-01-04 13:59:53,342 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (default task-32) [] Permutation name: 36FFE9E683BD2C616FFB067DABA3A81E
2017-01-04 13:59:53,342 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (default task-32) [] Uncaught exception: com.google.gwt.event.shared.UmbrellaException: Exception caught: Exception caught: (TypeError) 
 __gwt$exception: <skipped>: Cannot read property 'b' of null
	at java.lang.Throwable.fillInStackTrace(Throwable.java:114) [rt.jar:1.8.0_102]
	at java.lang.RuntimeException.RuntimeException(RuntimeException.java:32) [rt.jar:1.8.0_102]
	at com.google.web.bindery.event.shared.UmbrellaException.UmbrellaException(UmbrellaException.java:70) [gwt-servlet.jar:]
	at com.google.gwt.event.shared.UmbrellaException.UmbrellaException(UmbrellaException.java:25) [gwt-servlet.jar:]
	at com.google.gwt.event.shared.HandlerManager.$fireEvent(HandlerManager.java:117) [gwt-servlet.jar:]
	at com.google.gwt.user.client.ui.Widget.$fireEvent(Widget.java:127) [gwt-servlet.jar:]
	at com.google.gwt.user.client.ui.Widget.fireEvent(Widget.java:127) [gwt-servlet.jar:]
	at com.google.gwt.event.dom.client.DomEvent.fireNativeEvent(DomEvent.java:110) [gwt-servlet.jar:]
	at com.google.gwt.user.client.ui.Widget.$onBrowserEvent(Widget.java:163) [gwt-servlet.jar:]
	at com.google.gwt.user.client.ui.CustomButton.onBrowserEvent(CustomButton.java:631) [gwt-servlet.jar:]
	at com.google.gwt.user.client.DOM.dispatchEvent(DOM.java:1648) [gwt-servlet.jar:]
	at com.google.gwt.user.client.impl.DOMImplStandard.dispatchEvent(DOMImplStandard.java:320) [gwt-servlet.jar:]
	at com.google.gwt.core.client.impl.Impl.apply(Impl.java:296) [gwt-servlet.jar:]
	at com.google.gwt.core.client.impl.Impl.entry0(Impl.java:335) [gwt-servlet.jar:]
	at Unknown.eval(webadmin-0.js@54)
	at com.google.gwt.dom.client.DOMImplStandard.$dispatchEvent(DOMImplStandard.java:68) [gwt-servlet.jar:]
	at com.google.gwt.user.client.ui.CustomButton.$onClick(CustomButton.java:822) [gwt-servlet.jar:]
	at org.ovirt.engine.ui.common.widget.dialog.AbstractDialogButton.onClick(AbstractDialogButton.java:45)
	at com.google.gwt.user.client.ui.CustomButton.onBrowserEvent(CustomButton.java:631) [gwt-servlet.jar:]
	at com.google.gwt.user.client.DOM.dispatchEvent(DOM.java:1648) [gwt-servlet.jar:]
	at com.google.gwt.user.client.DOM.dispatchEvent(DOM.java:1666) [gwt-servlet.jar:]
	at com.google.gwt.user.client.impl.DOMImplStandard.dispatchCapturedMouseEvent(DOMImplStandard.java:352) [gwt-servlet.jar:]
	at com.google.gwt.core.client.impl.Impl.apply(Impl.java:296) [gwt-servlet.jar:]
	at com.google.gwt.core.client.impl.Impl.entry0(Impl.java:335) [gwt-servlet.jar:]
	at Unknown.eval(webadmin-0.js@54)
Caused by: com.google.gwt.event.shared.UmbrellaException: Exception caught: (TypeError) 
 __gwt$exception: <skipped>: Cannot read property 'b' of null
	at java.lang.Throwable.fillInStackTrace(Throwable.java:114) [rt.jar:1.8.0_102]
	at java.lang.RuntimeException.RuntimeException(RuntimeException.java:32) [rt.jar:1.8.0_102]
	at com.google.web.bindery.event.shared.UmbrellaException.UmbrellaException(UmbrellaException.java:70) [gwt-servlet.jar:]
	at com.google.gwt.event.shared.UmbrellaException.UmbrellaException(UmbrellaException.java:25) [gwt-servlet.jar:]
	at com.google.gwt.event.shared.HandlerManager.$fireEvent(HandlerManager.java:117) [gwt-servlet.jar:]
	at com.google.gwt.user.client.ui.Widget.$fireEvent(Widget.java:127) [gwt-servlet.jar:]
	at com.google.gwt.user.client.ui.Widget.fireEvent(Widget.java:127) [gwt-servlet.jar:]
	at com.google.gwt.event.logical.shared.ValueChangeEvent.fire(ValueChangeEvent.java:40) [gwt-servlet.jar:]
	at org.ovirt.engine.ui.common.widget.uicommon.instanceimages.InstanceImageLineEditor$3.eventRaised(InstanceImageLineEditor.java:96)
	at org.ovirt.engine.ui.uicompat.Event.$raise(Event.java:114)
	at org.ovirt.engine.ui.uicommonweb.models.EntityModel.$setEntity(EntityModel.java:35)
	at org.ovirt.engine.ui.uicommonweb.models.EntityModel.setEntity(EntityModel.java:35)
	at org.ovirt.engine.ui.uicommonweb.models.vms.InstanceImageLineModel$3.onSave(InstanceImageLineModel.java:270)
	at org.ovirt.engine.ui.uicommonweb.models.vms.AbstractDiskModel.executeCommand(AbstractDiskModel.java:1046)
	at org.ovirt.engine.ui.uicommonweb.UICommand.$execute(UICommand.java:163)
	at org.ovirt.engine.ui.common.presenter.AbstractModelBoundPopupPresenterWidget$6.onClick(AbstractModelBoundPopupPresenterWidget.java:337)
	at com.google.gwt.event.dom.client.ClickEvent.dispatch(ClickEvent.java:55) [gwt-servlet.jar:]
	at com.google.gwt.event.shared.GwtEvent.dispatch(GwtEvent.java:76) [gwt-servlet.jar:]
	at com.google.web.bindery.event.shared.SimpleEventBus.$doFire(SimpleEventBus.java:173) [gwt-servlet.jar:]
	... 21 more
Caused by: com.google.gwt.core.client.JavaScriptException: (TypeError) 
 __gwt$exception: <skipped>: Cannot read property 'b' of null
	at org.ovirt.engine.ui.common.widget.AddRemoveRowWidget$AddRemoveRowPanel.$setButtonsEnabled(AddRemoveRowWidget.java:377)
	at org.ovirt.engine.ui.common.widget.AddRemoveRowWidget.$setButtonsEnabled(AddRemoveRowWidget.java:344)
	at org.ovirt.engine.ui.common.widget.AddRemoveRowWidget.toggleGhost(AddRemoveRowWidget.java:497)
	at org.ovirt.engine.ui.common.widget.AddRemoveRowWidget$3.onValueChange(AddRemoveRowWidget.java:232)
	at com.google.gwt.event.logical.shared.ValueChangeEvent.dispatch(ValueChangeEvent.java:127) [gwt-servlet.jar:]
	at com.google.gwt.event.shared.GwtEvent.dispatch(GwtEvent.java:76) [gwt-servlet.jar:]
	at com.google.web.bindery.event.shared.SimpleEventBus.$doFire(SimpleEventBus.java:173) [gwt-servlet.jar:]
	... 36 more

Comment 1 hifxj 2017-01-04 06:46:44 UTC
I just noticed that i can't remove the image added with step 6.
Always exception.

Uncaught exception occurred. Please try reloading the page. Details: Exception caught: (TypeError) __gwt$exception: <skipped>: Cannot read property 'Ed' of null
Please have your administrator check the UI logs

UI log:

2017-01-04 14:38:40,621 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (default task-54) [] Permutation name: 36FFE9E683BD2C616FFB067DABA3A81E
2017-01-04 14:38:40,621 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (default task-54) [] Uncaught exception: com.google.gwt.event.shared.UmbrellaException: Exception caught: (TypeError) 
 __gwt$exception: <skipped>: Cannot read property 'Ed' of null
	at java.lang.Throwable.fillInStackTrace(Throwable.java:114) [rt.jar:1.8.0_102]
	at java.lang.RuntimeException.RuntimeException(RuntimeException.java:32) [rt.jar:1.8.0_102]
	at com.google.web.bindery.event.shared.UmbrellaException.UmbrellaException(UmbrellaException.java:70) [gwt-servlet.jar:]
	at com.google.gwt.event.shared.UmbrellaException.UmbrellaException(UmbrellaException.java:25) [gwt-servlet.jar:]
	at com.google.gwt.event.shared.HandlerManager.$fireEvent(HandlerManager.java:117) [gwt-servlet.jar:]
	at com.google.gwt.user.client.ui.Widget.$fireEvent(Widget.java:127) [gwt-servlet.jar:]
	at com.google.gwt.user.client.ui.Widget.fireEvent(Widget.java:127) [gwt-servlet.jar:]
	at com.google.gwt.event.dom.client.DomEvent.fireNativeEvent(DomEvent.java:110) [gwt-servlet.jar:]
	at com.google.gwt.user.client.ui.Widget.$onBrowserEvent(Widget.java:163) [gwt-servlet.jar:]
	at com.google.gwt.user.client.ui.CustomButton.onBrowserEvent(CustomButton.java:631) [gwt-servlet.jar:]
	at com.google.gwt.user.client.DOM.dispatchEvent(DOM.java:1648) [gwt-servlet.jar:]
	at com.google.gwt.user.client.impl.DOMImplStandard.dispatchEvent(DOMImplStandard.java:320) [gwt-servlet.jar:]
	at com.google.gwt.core.client.impl.Impl.apply(Impl.java:296) [gwt-servlet.jar:]
	at com.google.gwt.core.client.impl.Impl.entry0(Impl.java:335) [gwt-servlet.jar:]
	at Unknown.eval(webadmin-0.js@54)
	at com.google.gwt.dom.client.DOMImplStandard.$dispatchEvent(DOMImplStandard.java:68) [gwt-servlet.jar:]
	at com.google.gwt.user.client.ui.CustomButton.$onClick(CustomButton.java:822) [gwt-servlet.jar:]
	at org.ovirt.engine.ui.common.widget.dialog.AbstractDialogButton.onClick(AbstractDialogButton.java:45)
	at com.google.gwt.user.client.ui.CustomButton.onBrowserEvent(CustomButton.java:631) [gwt-servlet.jar:]
	at com.google.gwt.user.client.DOM.dispatchEvent(DOM.java:1648) [gwt-servlet.jar:]
	at com.google.gwt.user.client.DOM.dispatchEvent(DOM.java:1666) [gwt-servlet.jar:]
	at com.google.gwt.user.client.impl.DOMImplStandard.dispatchCapturedMouseEvent(DOMImplStandard.java:352) [gwt-servlet.jar:]
	at com.google.gwt.core.client.impl.Impl.apply(Impl.java:296) [gwt-servlet.jar:]
	at com.google.gwt.core.client.impl.Impl.entry0(Impl.java:335) [gwt-servlet.jar:]
	at Unknown.eval(webadmin-0.js@54)
Caused by: com.google.gwt.core.client.JavaScriptException: (TypeError) 
 __gwt$exception: <skipped>: Cannot read property 'Ed' of null
	at com.google.gwt.user.client.ui.ComplexPanel.$remove(ComplexPanel.java:60) [gwt-servlet.jar:]
	at org.ovirt.engine.ui.common.widget.AddRemoveRowWidget.$removeWidget(AddRemoveRowWidget.java:340)
	at org.ovirt.engine.ui.common.widget.AddRemoveRowWidget.$doRemoveItem(AddRemoveRowWidget.java:307)
	at org.ovirt.engine.ui.common.widget.uicommon.instanceimages.InstanceImagesEditor$1.$removeApproved(InstanceImagesEditor.java:84)
	at org.ovirt.engine.ui.uicommonweb.models.vms.InstanceImagesModel.executeCommand(InstanceImagesModel.java:94)
	at org.ovirt.engine.ui.uicommonweb.UICommand.$execute(UICommand.java:163)
	at org.ovirt.engine.ui.common.presenter.AbstractModelBoundPopupPresenterWidget$6.onClick(AbstractModelBoundPopupPresenterWidget.java:337)
	at com.google.gwt.event.dom.client.ClickEvent.dispatch(ClickEvent.java:55) [gwt-servlet.jar:]
	at com.google.gwt.event.shared.GwtEvent.dispatch(GwtEvent.java:76) [gwt-servlet.jar:]
	at com.google.web.bindery.event.shared.SimpleEventBus.$doFire(SimpleEventBus.java:173) [gwt-servlet.jar:]
	... 21 more

Comment 2 Oved Ourfali 2017-01-05 13:10:20 UTC
Moving to Virt.
If you need UX assistance let me know.

Comment 3 Tomas Jelinek 2017-01-05 15:46:23 UTC
Hi, 

this has already been fixed and will land in 4.0.6:
https://bugzilla.redhat.com/show_bug.cgi?id=1401576

*** This bug has been marked as a duplicate of bug 1401576 ***

Comment 4 hifxj 2017-01-06 03:48:14 UTC
Ok, thanks. I'll try 4.0.6.


Note You need to log in before you can comment on or make changes to this bug.