Bug 1410 - Caps_Lock and Num_Lock hang terminal for 13 seconds
Caps_Lock and Num_Lock hang terminal for 13 seconds
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kbd (Show other bugs)
5.2
i386 Linux
high Severity medium
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-03-03 11:28 EST by brossard
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-04-01 14:53:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description brossard 1999-03-03 11:28:00 EST
On both RedHat 5.2 and 5.0, we have the same problem.
When
on the console the user presses on Caps_Lock or Num_Lock,
the terminal hangs for 13 seconds. Everything works
correctly, but 13 seconds is a long time to wait for a
keypress to work!
   The effect is the same whether X11 runs or not.
We use the following keymap file:
/usr/lib/kbd/keymaps/i386/qwertz/fr_CH-latin1.map.gz
although the same problem continues to happen when I used
loadkeys to switch back and forth with the US keymap.
    I have used loadkeys to change the key mapping for
keycode 58 between Caps_Lock and, for example, "a". The
problem disappears when the mapping is changed from
Caps_Lock, but reappears when the mapping is restored.
    For us the priority is fairly high on this problem
because linux is more and more being used on user's
desk and they don't understand when told that the Caps_Lock
key doesn't work and of course when they press either
Caps_Lock or Num_lock by error, they get very confused
when the keyboard stops working and then they complain
to their boss who complains to me...
    I have searched every archive I could get my hands on
and saw nothing relating to this problem. My guess would
be that it might be related to our hardware configuration.
   We see this on all our HP Vectra VL2 and XM2. These are
486 PC's. Our keyboard is the SwissFrench one, but I've
just restarted my test PC with our lone US keyboard and
directly at the login prompt the problem appears: press
Caps_Lock and 12-13 seconds later linux starts echoing
characters again.

   When I rlogin to the PC, in my rlogin window the
problem doesn't appear.

					Alain Brossard
					brossard@cdg.ch
Comment 1 Preston Brown 1999-03-29 17:16:59 EST
Dave, have you been able to verify this on 5.2?  I can't on 5.9 beta,
so I assume console-tools has fixed it, but I'd like to know if you
can verify.
Comment 2 David Lawrence 1999-04-01 14:53:59 EST
I was unable to replicate this problem on a freshly installed 5.2
machine.

Note You need to log in before you can comment on or make changes to this bug.