Bug 1410016 - Link in 4.5 broken - includes ???TITLE???
Summary: Link in 4.5 broken - includes ???TITLE???
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: doc-Linux_Domain_Identity_Management_Guide
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Aneta Šteflová Petrová
QA Contact: Namita Soman
URL:
Whiteboard:
: 1418004 1438692 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-04 08:33 UTC by Martin Babinsky
Modified: 2019-03-06 02:16 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-10 11:24:52 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Martin Babinsky 2017-01-04 08:33:30 UTC
Description of problem:

In the Section 4.5 of recent Linux Domain Identity, Authentication, and Policy Guide (https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/7/html/Linux_Domain_Identity_Authentication_and_Policy_Guide/creating-the-replica.html) there is a following paragraph which IMO references a non-existent sub-section in this part of documentation:

"""
In both of these situations, you can customize your replica by adding options to ipa-replica-install: see Section 4.5, “Using ???TITLE??? to Configure the Replica for Your Use Case”.
"""

I believe that this is a leftover from previous revisions of the Documentation that slipped through the review. Please remove it so that it does not confuse the reading public.

Comment 1 Aneta Šteflová Petrová 2017-01-04 08:53:07 UTC
The referenced sub-section actually exists - clicking the weird link leads to it.

The problem is probably caused by a DocBook tag in the title of the linked sub-section:

<bridgehead renderas="sect3" id="creating-the-replica-use-cases">Using <systemitem>ipa-replica-install</systemitem> to Configure the  Replica for Your Use Case</bridgehead>

Some part of the publication chain mishandles the tag and prints it as "???TITLE???" on the Customer Portal. I reported it to the CP team.

From our side, everything is okay. The only thing I could do is to remove the tag, but that would cause problems for us - we would be getting reports from our doc testing tool about the untagged string.

So I'd prefer to wait until the CP team investigates the issue from their side. I'll keep this BZ open until that happens.

Comment 4 Aneta Šteflová Petrová 2017-01-31 15:12:17 UTC
*** Bug 1418004 has been marked as a duplicate of this bug. ***

Comment 6 Aneta Šteflová Petrová 2017-04-04 08:58:14 UTC
*** Bug 1438692 has been marked as a duplicate of this bug. ***

Comment 7 Aneta Šteflová Petrová 2017-04-04 09:01:06 UTC
We've received another report for a different section of the guide: BZ#1438692. I've removed the DocBook tag from its title as well.

I also checked the html-single versions of all three RHEL 7 guides for IdM, and I didn't find the question marks anywhere else.

Comment 8 Aneta Šteflová Petrová 2017-04-10 11:24:52 UTC
We've published the update. For the latest version of the guide, see https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/7/html/Linux_Domain_Identity_Authentication_and_Policy_Guide/index.html


Note You need to log in before you can comment on or make changes to this bug.