Bug 141004 - Advansys SCSI module is missing
Summary: Advansys SCSI module is missing
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-27 22:20 UTC by Steve Bergman
Modified: 2015-01-04 22:13 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-02 21:48:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Steve Bergman 2004-11-27 22:20:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
The module is missing in action.  It exists in the kernel source code
but is not installed during the installation.

Version-Release number of selected component (if applicable):
kernel-2.6.9-1.681_FC3

How reproducible:
Always

Steps to Reproduce:
1. modprobe advansys
2. ls -l /lib/modules/....../kernel/drivers/scsi

    

Actual Results:  advansys module loads.

Expected Results:  FATAL: Module advansys not found.

Additional info:

Comment 1 Dave Jones 2004-11-27 23:56:00 UTC
this is marked as broken in the upstream kernel, as no-one bothered to convert
it to use new dma-mapping code that came about in 2.5.  Your best bet is
probably to ask the folks upstream on the linux-scsi@vger.kernel.org list
whether it's being worked on, or left to bitrot.

Comment 2 Steve Bergman 2004-11-28 08:53:12 UTC
2.5?  The module exists in Fedora Core 2 up through 2.6.6-1.435, though it does
seem to be missing from 2.6.7-1.494.2.2 and  2.6.8-1.521.  Or did this change
occur in 2.6.7?  Are drivers getting broken in the stable kernel series?

Comment 3 Dave Jones 2004-11-29 06:03:05 UTC
in 2.6.0 -> 2.6.7 it wasnt marked as broken, though it could corrupt data due to
a missing/broken conversion to the dma-mapping code.  It was then correctly
marked as broken later.

Comment 4 Steve Bergman 2004-11-29 17:44:44 UTC
OK. Thanks.  I was going to compile up a kernel with support, but if
it can corrupt data... this is used for our tape backups.  Time for a
new SCSI HA.  

Too bad about Advansys.  They were a good company and one of the
earlier players supporting Linux.  I believe they wrote the drivers in
house, made them open source, and supported them officially.

Comment 5 Dave Jones 2005-01-14 07:09:29 UTC
Aparently this is safe to enable on x86 even though its broken on other
architectures. I've fixed this in CVS, it'll go out in the next update.



Note You need to log in before you can comment on or make changes to this bug.