Bug 1410053 - specific label needed for /dev/mei0 [NEEDINFO]
Summary: specific label needed for /dev/mei0
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy
Version: 7.3
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Lukas Vrabec
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-04 11:03 UTC by Milos Malik
Modified: 2020-09-10 10:05 UTC (History)
8 users (show)

Fixed In Version: selinux-policy-3.13.1-125.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 15:20:12 UTC
Target Upstream Version:
mmalik: needinfo? (baitken)


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1861 0 normal SHIPPED_LIVE selinux-policy bug fix update 2017-08-01 17:50:24 UTC

Description Milos Malik 2017-01-04 11:03:08 UTC
Description of problem:
* our automated TC found out that /dev/mei0 is labeled device_t and there is not a more specific label for it

Version-Release number of selected component (if applicable):
selinux-policy-3.13.1-102.el7_3.11.noarch

How reproducible:
* always

Actual results:
/dev/mei0 system_u:object_r:device_t:s0

Additional information:
 * https://www.kernel.org/doc/Documentation/misc-devices/mei/mei.txt

Comment 2 Milos Malik 2017-01-04 11:06:41 UTC
Found something similar on my notebook:

$ lspci | grep -i mei
00:16.0 Communication controller: Intel Corporation 8 Series/C220 Series Chipset Family MEI Controller #1 (rev 04)
$ matchpathcon /dev/mei0 
/dev/mei0	system_u:object_r:device_t:s0
$ ls -l /dev/mei0 
crw-------. 1 root root 244, 0 Jan  4 07:44 /dev/mei0
$

Comment 7 errata-xmlrpc 2017-08-01 15:20:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1861


Note You need to log in before you can comment on or make changes to this bug.