Bug 1410073 - Fix failure of split-brain-favorite-child-policy.t in CentOS7
Summary: Fix failure of split-brain-favorite-child-policy.t in CentOS7
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: replicate
Version: 3.8
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ravishankar N
QA Contact:
URL:
Whiteboard:
Depends On: 1408757
Blocks: 1410072
TreeView+ depends on / blocked
 
Reported: 2017-01-04 12:02 UTC by Ravishankar N
Modified: 2017-01-16 12:27 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.8.8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1408757
Environment:
Last Closed: 2017-01-16 12:27:41 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Ravishankar N 2017-01-04 12:02:04 UTC
+++ This bug was initially created as a clone of Bug #1408757 +++

Description of problem:

Detailed in https://bugzilla.redhat.com/show_bug.cgi?id=1408660#c2

--- Additional comment from Worker Ant on 2016-12-27 00:44:42 EST ---

REVIEW: http://review.gluster.org/16288 (tests: Fix split-brain-favorite-child-policy.t failures) posted (#1) for review on master by Ravishankar N (ravishankar@redhat.com)

--- Additional comment from Worker Ant on 2016-12-27 01:36:36 EST ---

REVIEW: http://review.gluster.org/16288 (tests: Fix split-brain-favorite-child-policy.t failures) posted (#2) for review on master by Ravishankar N (ravishankar@redhat.com)

--- Additional comment from Worker Ant on 2016-12-27 07:21:57 EST ---

REVIEW: http://review.gluster.org/16288 (tests: Fix split-brain-favorite-child-policy.t failures) posted (#3) for review on master by Ravishankar N (ravishankar@redhat.com)

--- Additional comment from Worker Ant on 2016-12-29 19:30:46 EST ---

REVIEW: http://review.gluster.org/16288 (tests: Fix split-brain-favorite-child-policy.t failures) posted (#4) for review on master by Ravishankar N (ravishankar@redhat.com)

--- Additional comment from Worker Ant on 2017-01-03 01:13:56 EST ---

COMMIT: http://review.gluster.org/16288 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 76fff8cb2a164b596ca67e65c99623f5b68361fd
Author: Ravishankar N <ravishankar@redhat.com>
Date:   Thu Dec 29 12:10:00 2016 +0000

    tests: Fix split-brain-favorite-child-policy.t failures
    
    Problem:
    In CentOS-7, the file was receving an extra removexattr(security.ima)
    FOP which changed its ctime, breaking the assumption that a particular brick
    had the latest ctime based on the writevs done in the .t
    
    Fix:
    1. Compare the ctime of both files in the backend and pick the one with
    the latest ctime for the fav-child policy. Also unmount the volume
    before comparing, to avoid any further FOPS on the file that
    can possibly modify the timestamps.
    
    2. Added floating point handling in stat function. Thanks to Pranith for
    the helping debugging the regex.
    
    Change-Id: I06041a0f39a29d2593b867af8685d65c7cd99150
    BUG: 1408757
    Signed-off-by: Ravishankar N <ravishankar@redhat.com>
    Reviewed-on: http://review.gluster.org/16288
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>

Comment 1 Worker Ant 2017-01-04 12:02:42 UTC
REVIEW: http://review.gluster.org/16324 (tests: Fix split-brain-favorite-child-policy.t failures) posted (#1) for review on release-3.8 by Ravishankar N (ravishankar@redhat.com)

Comment 2 Worker Ant 2017-01-05 11:41:52 UTC
COMMIT: http://review.gluster.org/16324 committed in release-3.8 by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit cb8bc3396d16e777d9a2683886fefd43e747e8a3
Author: Ravishankar N <ravishankar@redhat.com>
Date:   Thu Dec 29 12:10:00 2016 +0000

    tests: Fix split-brain-favorite-child-policy.t failures
    
    Problem:
    In CentOS-7, the file was receving an extra removexattr(security.ima)
    FOP which changed its ctime, breaking the assumption that a particular brick
    had the latest ctime based on the writevs done in the .t
    
    Fix:
    1. Compare the ctime of both files in the backend and pick the one with
    the latest ctime for the fav-child policy. Also unmount the volume
    before comparing, to avoid any further FOPS on the file that
    can possibly modify the timestamps.
    
    2. Added floating point handling in stat function. Thanks to Pranith for
    the helping debugging the regex.
    
    > Reviewed-on: http://review.gluster.org/16288
    > Smoke: Gluster Build System <jenkins@build.gluster.org>
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    > Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    (cherry picked from commit 76fff8cb2a164b596ca67e65c99623f5b68361fd)
    
    Change-Id: I06041a0f39a29d2593b867af8685d65c7cd99150
    BUG: 1410073
    Signed-off-by: Ravishankar N <ravishankar@redhat.com>
    Reviewed-on: http://review.gluster.org/16324
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>

Comment 3 Niels de Vos 2017-01-16 12:27:41 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.8, please open a new bug report.

glusterfs-3.8.8 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2017-January/000064.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.