Bug 1410085 - Cannot boot VM from HDD
Summary: Cannot boot VM from HDD
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: ---
: ---
Assignee: Michal Skrivanek
QA Contact: meital avital
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-04 12:28 UTC by Andrei Stepanov
Modified: 2017-01-04 13:44 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-04 13:44:10 UTC
oVirt Team: Virt


Attachments (Terms of Use)
vdsm log (19.52 KB, text/plain)
2017-01-04 12:31 UTC, Andrei Stepanov
no flags Details
engine logs (11.84 KB, text/plain)
2017-01-04 12:32 UTC, Andrei Stepanov
no flags Details
No HDD entry in boot menu (16.30 KB, image/png)
2017-01-04 12:34 UTC, Andrei Stepanov
no flags Details

Description Andrei Stepanov 2017-01-04 12:28:02 UTC
VM cannot boot from HDD.

ovirt-engine-4.1.0-0.3.beta2.el7.noarch
* Wed Dec 21 2016 Anton Marchukov <amarchuk@redhat.com> - 4.1.0


1. Install a OS on a VM.
2. Edit the VM.
3. Select Boot Options tab.
4. Select  First Device = Hard Disk
4a. optional: enable Enable menu to select boot device.
5. Shutdown the VM. (shutdown QEMU process)
6. Start VM 
7. Open a console to the VM.

Host is configured to use local storage.

Actual results: VM cannot boot from hdd.
Expected results: It should boot directly from HardDisk.

The disk is set as Bootable. The third checkbox in the right column http://www.ovirt.org/images/wiki/Add_Virtual_Disk.png?1454370862


QEMU PROCESS:

/usr/libexec/qemu-kvm -name guest=RHEL6.8,debug-threads=on -S -object secret,id=masterKey0,format=raw,file=/var/lib/libvirt/qemu/domain-6-RHEL6.8/master-key.aes -machine pc-i440fx-rhel7.3.0,accel=kvm,usb=off -cpu Broadwell,+rtm,+hle -m size=4194304k,slots=16,maxmem=16777216k -realtime mlock=off -smp 2,maxcpus=16,sockets=16,cores=1,threads=1 -numa node,nodeid=0,cpus=0-1,mem=4096 -uuid 3cd8e608-b960-46ea-8eca-48a89697691c -smbios type=1,manufacturer=Red Hat,product=RHEV Hypervisor,version=7.3-7.el7_3.1,serial=72CEE085-F3EF-11E5-9C43-BC00000A0000,uuid=3cd8e608-b960-46ea-8eca-48a89697691c -no-user-config -nodefaults -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/domain-6-RHEL6.8/monitor.sock,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=2017-01-04T12:01:52,driftfix=slew -global kvm-pit.lost_tick_policy=discard -no-hpet -no-shutdown -boot menu=on,splash-time=10000,strict=on -device ich9-usb-ehci1,id=usb,bus=pci.0,addr=0x4.0x7 -device virtio-scsi-pci,id=scsi0,bus=pci.0,addr=0x3 -device virtio-serial-pci,id=virtio-serial0,max_ports=16,bus=pci.0,addr=0x5 -drive if=none,id=drive-ide0-1-0,readonly=on -device ide-cd,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -drive file=/rhev/data-center/44682f17-a889-4174-ad45-c3c12df632a6/70d3f1d6-8fcd-4e63-a527-22ee3284ae26/images/d3721135-7aee-481a-ad52-b03ad43b5012/5fc27cde-7a01-4d5e-a4b9-fd10dd557b06,format=raw,if=none,id=drive-scsi0-0-0-1,serial=d3721135-7aee-481a-ad52-b03ad43b5012,cache=none,werror=stop,rerror=stop,aio=threads -device scsi-hd,bus=scsi0.0,channel=0,scsi-id=0,lun=1,drive=drive-scsi0-0-0-1,id=scsi0-0-0-1,bootindex=1 -netdev tap,fd=30,id=hostnet0,vhost=on,vhostfd=32 -device virtio-net-pci,netdev=hostnet0,id=net0,mac=00:1a:4a:16:01:52,bus=pci.0,addr=0xa -chardev socket,id=charchannel0,path=/var/lib/libvirt/qemu/channels/3cd8e608-b960-46ea-8eca-48a89697691c.com.redhat.rhevm.vdsm,server,nowait -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=com.redhat.rhevm.vdsm -chardev socket,id=charchannel1,path=/var/lib/libvirt/qemu/channels/3cd8e608-b960-46ea-8eca-48a89697691c.org.qemu.guest_agent.0,server,nowait -device virtserialport,bus=virtio-serial0.0,nr=2,chardev=charchannel1,id=channel1,name=org.qemu.guest_agent.0 -chardev spicevmc,id=charchannel2,name=vdagent -device virtserialport,bus=virtio-serial0.0,nr=3,chardev=charchannel2,id=channel2,name=com.redhat.spice.0 -spice tls-port=5900,addr=10.34.131.41,x509-dir=/etc/pki/vdsm/libvirt-spice,tls-channel=default,tls-channel=main,tls-channel=display,tls-channel=inputs,tls-channel=cursor,tls-channel=playback,tls-channel=record,tls-channel=smartcard,tls-channel=usbredir,seamless-migration=on -device qxl-vga,id=video0,ram_size=268435456,vram_size=8388608,vram64_size_mb=0,vgamem_mb=64,bus=pci.0,addr=0x2 -object rng-random,id=objrng0,filename=/dev/urandom -device virtio-rng-pci,rng=objrng0,id=rng0,bus=pci.0,addr=0x6 -msg timestamp=on


file /local_storage/70d3f1d6-8fcd-4e63-a527-22ee3284ae26/images/d3721135-7aee-481a-ad52-b03ad43b5012/5fc27cde-7a01-4d5e-a4b9-fd10dd557b06
/local_storage/70d3f1d6-8fcd-4e63-a527-22ee3284ae26/images/d3721135-7aee-481a-ad52-b03ad43b5012/5fc27cde-7a01-4d5e-a4b9-fd10dd557b06: x86 boot sector; GRand Unified Bootloader, stage1 version 0x3, boot drive 0x80, 1st sector stage2 0x2c7b690, GRUB version 0.94; partition 1: ID=0x83, active, starthead 32, startsector 2048, 61376512 sectors; partition 2: ID=0x82, starthead 254, startsector 61378560, 1533952 sectors, code offset 0x48

Comment 1 Andrei Stepanov 2017-01-04 12:31:35 UTC
Created attachment 1237112 [details]
vdsm log

Comment 2 Andrei Stepanov 2017-01-04 12:32:15 UTC
Created attachment 1237113 [details]
engine logs

Comment 3 Andrei Stepanov 2017-01-04 12:34:01 UTC
Created attachment 1237114 [details]
No HDD entry in boot menu

Comment 4 Andrei Stepanov 2017-01-04 13:44:10 UTC
I have created a new VM, after OS installation it boots fine. Cannot reproduce.


Note You need to log in before you can comment on or make changes to this bug.