Bug 1410102 - Make install error for libguestfs-1.35.19
Summary: Make install error for libguestfs-1.35.19
Keywords:
Status: CLOSED DUPLICATE of bug 1614502
Alias: None
Product: Virtualization Tools
Classification: Community
Component: libguestfs
Version: unspecified
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Richard W.M. Jones
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-04 13:08 UTC by ameya
Modified: 2018-08-09 18:45 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-09 18:45:03 UTC


Attachments (Terms of Use)
Configure output of libguestfs-1.35.19 (68.40 KB, text/plain)
2017-01-04 13:40 UTC, ameya
no flags Details

Description ameya 2017-01-04 13:08:15 UTC
Description of problem:
Compile libguestfs-1.35.19 on CentOS Linux release 7.1.1503 (Core) , configure and make are fine, get the error on make install

Version-Release number of selected component (if applicable):
libguestfs-1.35.19 and below the version as well

How reproducible:
compile libguestfs-1.35.19 or stable version libguestfs-1.34.xx, make , make install REALLY_INSTALL=yes

Steps to Reproduce:
1. ./configure --prefix=/usr/local/ --disable-appliance --disable-daemon
2.make 
3.make install REALLY_INSTALL=yes

Actual results:
Making install in po
make[2]: Entering directory `/root/libguestfs-1.35.19/po'
make[3]: Entering directory `/root/libguestfs-1.35.19/po'
make[3]: Nothing to be done for `install-exec-am'.
make  install-data-hook
make[4]: Entering directory `/root/libguestfs-1.35.19/po'
make[4]: *** No rule to make target `../builder/index-parse.c', needed by `libguestfs.pot'.  Stop.
make[4]: Leaving directory `/root/libguestfs-1.35.19/po'
make[3]: *** [install-data-am] Error 2
make[3]: Leaving directory `/root/libguestfs-1.35.19/po'
make[2]: *** [install-am] Error 2
make[2]: Leaving directory `/root/libguestfs-1.35.19/po'
make[1]: *** [install-recursive] Error 1
make[1]: Leaving directory `/root/libguestfs-1.35.19'
make: *** [install] Error 2

Expected results:


Additional info:

Comment 1 Pino Toscano 2017-01-04 13:31:28 UTC
It looks like you are building without OCaml bindings, is it correct?
Can you please attach the full output of configure, if still available?

Comment 2 ameya 2017-01-04 13:40:52 UTC
Created attachment 1237176 [details]
Configure output of libguestfs-1.35.19

As requested the Configure output of libguestfs-1.35.19 on CentOS Linux release 7.1.1503 (Core)

Comment 3 ameya 2017-01-04 13:41:58 UTC
it's configured without OCaml bindings since it takes forever to make with OCaml bindings as confirmed on other tickets

Comment 4 Richard W.M. Jones 2017-01-04 13:54:52 UTC
It's still a bug even if the reporter doesn't have OCaml installed.

Comment 5 ameya 2017-01-04 13:56:15 UTC
What do you recommend ? How do I get it working ?

Comment 6 ameya 2017-01-04 13:57:04 UTC
I just need guestmount, guestfish and virt-df  on centos 7.X compiled

Comment 7 Richard W.M. Jones 2017-01-04 22:24:28 UTC
It's a bug so either you'll have to fix the bug in the Makefile
(please send patches to libguestfs at redhat.com) or else you'll
have to work around it by installing the OCaml compiler.

Comment 8 Richard W.M. Jones 2018-08-09 18:45:03 UTC

*** This bug has been marked as a duplicate of bug 1614502 ***


Note You need to log in before you can comment on or make changes to this bug.