Bug 1410108 - python-adal: FTBFS
Summary: python-adal: FTBFS
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-adal
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mohamed El Morabity
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-04 13:30 UTC by Tomas Orsava
Modified: 2017-01-10 21:50 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-10 21:50:30 UTC
Type: Bug


Attachments (Terms of Use)
python-adal build log (21.46 KB, text/plain)
2017-01-04 13:31 UTC, Tomas Orsava
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github AzureAD azure-activedirectory-library-for-python issues 61 0 None None None 2017-01-04 13:30:30 UTC

Description Tomas Orsava 2017-01-04 13:30:30 UTC
Description of problem:
python-adal cannot currently be built in rawhide due to an unsatisfiable dependency in setup.py—`requests>=2.0.0,<2.12`—as Fedora offers only version 2.12. [log]

There is an upstream issue opened to remove this condition [0], however, it looks like the fix involves a change in `urllib3` [1], which has already been merged. Nevertheless, a new version of `urllib3` with this change has not been released yet. I've tried patching Fedora's version of `urllib3`, but I found that the relevant code has diverged too much for a workable patch.

[log] https://kojipkgs.fedoraproject.org//work/tasks/1861/17161861/build.log
[0] https://github.com/AzureAD/azure-activedirectory-library-for-python/issues/61
[1] https://github.com/shazow/urllib3/pull/1063


Version-Release number of selected component (if applicable):
python-adal-0.4.3-2.fc26


How reproducible: Easy


Steps to Reproduce:
1. (scratch) Build python-adal in rawhide
2.
3.

Actual results:
[log] https://kojipkgs.fedoraproject.org//work/tasks/1861/17161861/build.log


Expected results: Successful build


Additional info: —

Comment 1 Tomas Orsava 2017-01-04 13:31:41 UTC
Created attachment 1237171 [details]
python-adal build log

Comment 2 Charalampos Stratakis 2017-01-09 13:21:49 UTC
Developers of urllib3 mentioned that it would be a month before a new release which will include these fixes.

Comment 3 Charalampos Stratakis 2017-01-09 13:29:26 UTC
Will need to wait for the upstreams to incorporate their fixes

Comment 4 Charalampos Stratakis 2017-01-10 21:50:30 UTC
Fixed in rawhide


Note You need to log in before you can comment on or make changes to this bug.